]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
- updated to 0.20.18
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala API
4
5 Summary:        UPnP library based on GObject and libsoup
6 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
7 Name:           gupnp
8 # note: 0.20.x is stable, 0.21.x unstable
9 Version:        0.20.18
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp/0.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  8cc1fa6a10d2dfdf30d0d7594fd2be4f
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  docbook-dtd44-xml
20 BuildRequires:  glib2-devel >= 1:2.40.0
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gssdp-devel >= 0.14.15
23 BuildRequires:  gtk-doc >= 1.14
24 BuildRequires:  libsoup-devel >= 2.48.0
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  libuuid-devel >= 1.36
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  tar >= 1:1.22
32 %{?with_vala:BuildRequires:     vala >= 2:0.20}
33 %{?with_vala:BuildRequires:     vala-gssdp >= 0.14.15}
34 BuildRequires:  xz
35 Requires:       glib2 >= 1:2.40.0
36 Requires:       gssdp >= 0.14.15
37 Requires:       libsoup >= 2.48.0
38 Requires:       libuuid >= 1.36
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GUPnP is an object-oriented open source framework for creating UPnP
43 devices and control points, written in C using GObject and libsoup.
44 The GUPnP API is intended to be easy to use, efficient and flexible.
45
46 %description -l pl.UTF-8
47 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
48 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
49 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
50 i elastyczne.
51
52 %package devel
53 Summary:        Header files for gupnp
54 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.40.0
58 Requires:       gssdp-devel >= 0.14.15
59 Requires:       libsoup-devel >= 2.48.0
60 Requires:       libuuid-devel >= 1.36
61 Requires:       libxml2-devel >= 1:2.6.30
62
63 %description devel
64 This package contains header files for the Linux SDK for UPnP Devices
65 (gupnp).
66
67 %description devel -l pl.UTF-8
68 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
69 programistycznego do urządzeń UPnP (gupnp).
70
71 %package static
72 Summary:        Static gupnp libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static gupnp libraries.
79
80 %description static -l pl.UTF-8
81 Statyczne biblioteki gupnp.
82
83 %package apidocs
84 Summary:        gupnp API documentation
85 Summary(pl.UTF-8):      Dokumentacja API gupnp
86 Group:          Documentation
87 Requires:       gtk-doc-common
88 %if "%{_rpmversion}" >= "5"
89 BuildArch:      noarch
90 %endif
91
92 %description apidocs
93 gupnp API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API gupnp.
97
98 %package -n vala-gupnp
99 Summary:        Vala API for gupnp library
100 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       vala >= 2:0.20
104 Requires:       vala-gssdp >= 0.14.15
105 %if "%{_rpmversion}" >= "5"
106 BuildArch:      noarch
107 %endif
108
109 %description -n vala-gupnp
110 Vala API for gupnp library.
111
112 %description -n vala-gupnp -l pl.UTF-8
113 API języka Vala dla biblioteki gupnp.
114
115 %prep
116 %setup -q
117
118 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' tools/gupnp-binding-tool
119
120 %build
121 %{__gtkdocize}
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-silent-rules \
129         --enable-gtk-doc \
130         --with-html-dir=%{_gtkdocdir} \
131         --with-context-manager=network-manager
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README
152 %attr(755,root,root) %{_bindir}/gupnp-binding-tool
153 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.0.so.4
155 %{_libdir}/girepository-1.0/GUPnP-1.0.typelib
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so
160 %{_datadir}/gir-1.0/GUPnP-1.0.gir
161 %{_includedir}/gupnp-1.0
162 %{_pkgconfigdir}/gupnp-1.0.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libgupnp-1.0.a
167
168 %files apidocs
169 %defattr(644,root,root,755)
170 %{_gtkdocdir}/gupnp
171
172 %if %{with vala}
173 %files -n vala-gupnp
174 %defattr(644,root,root,755)
175 %{_datadir}/vala/vapi/gupnp-1.0.deps
176 %{_datadir}/vala/vapi/gupnp-1.0.vapi
177 %endif
This page took 0.039998 seconds and 3 git commands to generate.