]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
- updated to 1.2.3 (partial fix + mitigations for CVE-2020-12695)
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala API
4
5 Summary:        UPnP library based on GObject and libsoup
6 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
7 Name:           gupnp
8 # note: 1.2.x is stable, 1.3.x unstable
9 Version:        1.2.3
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp/1.2/%{name}-%{version}.tar.xz
14 # Source0-md5:  08b2cedcdbbd0c66184995469a50fe52
15 URL:            https://wiki.gnome.org/Projects/GUPnP
16 BuildRequires:  docbook-dtd412-xml
17 BuildRequires:  docbook-dtd44-xml
18 BuildRequires:  glib2-devel >= 1:2.58
19 BuildRequires:  gobject-introspection-devel >= 1.36.0
20 BuildRequires:  gssdp-devel >= 1.2.3
21 BuildRequires:  gtk-doc >= 1.14
22 BuildRequires:  libsoup-devel >= 2.48.0
23 BuildRequires:  libuuid-devel >= 1.36
24 BuildRequires:  libxml2-devel >= 1:2.6.30
25 BuildRequires:  meson >= 0.48.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  tar >= 1:1.22
32 %{?with_vala:BuildRequires:     vala >= 2:0.20}
33 %{?with_vala:BuildRequires:     vala-gssdp >= 1.2.3}
34 BuildRequires:  xz
35 Requires:       glib2 >= 1:2.58
36 Requires:       gssdp >= 1.2.3
37 Requires:       libsoup >= 2.48.0
38 Requires:       libuuid >= 1.36
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GUPnP is an object-oriented open source framework for creating UPnP
43 devices and control points, written in C using GObject and libsoup.
44 The GUPnP API is intended to be easy to use, efficient and flexible.
45
46 %description -l pl.UTF-8
47 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
48 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
49 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
50 i elastyczne.
51
52 %package devel
53 Summary:        Header files for gupnp
54 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.58
58 Requires:       gssdp-devel >= 1.2.3
59 Requires:       libsoup-devel >= 2.48.0
60 Requires:       libuuid-devel >= 1.36
61 Requires:       libxml2-devel >= 1:2.6.30
62
63 %description devel
64 This package contains header files for the Linux SDK for UPnP Devices
65 (gupnp).
66
67 %description devel -l pl.UTF-8
68 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
69 programistycznego do urządzeń UPnP (gupnp).
70
71 %package static
72 Summary:        Static gupnp libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static gupnp libraries.
79
80 %description static -l pl.UTF-8
81 Statyczne biblioteki gupnp.
82
83 %package apidocs
84 Summary:        gupnp API documentation
85 Summary(pl.UTF-8):      Dokumentacja API gupnp
86 Group:          Documentation
87 Requires:       gtk-doc-common
88 %if "%{_rpmversion}" >= "4.6"
89 BuildArch:      noarch
90 %endif
91
92 %description apidocs
93 gupnp API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API gupnp.
97
98 %package -n vala-gupnp
99 Summary:        Vala API for gupnp library
100 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       vala >= 2:0.20
104 Requires:       vala-gssdp >= 1.2.3
105 %if "%{_rpmversion}" >= "4.6"
106 BuildArch:      noarch
107 %endif
108
109 %description -n vala-gupnp
110 Vala API for gupnp library.
111
112 %description -n vala-gupnp -l pl.UTF-8
113 API języka Vala dla biblioteki gupnp.
114
115 %prep
116 %setup -q
117
118 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' tools/gupnp-binding-tool-1.2
119
120 %build
121 %meson build \
122         -Dcontext_manager=network-manager \
123         -Dgtk_doc=true
124
125 %ninja_build -C build
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %ninja_install -C build
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS NEWS README
141 %attr(755,root,root) %{_bindir}/gupnp-binding-tool-1.2
142 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.2.so.0
144 %{_libdir}/girepository-1.0/GUPnP-1.2.typelib
145 %{_mandir}/man1/gupnp-binding-tool-1.2.1*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libgupnp-1.2.so
150 %{_datadir}/gir-1.0/GUPnP-1.2.gir
151 %{_includedir}/gupnp-1.2
152 %{_pkgconfigdir}/gupnp-1.2.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libgupnp-1.2.a
157
158 %files apidocs
159 %defattr(644,root,root,755)
160 %{_gtkdocdir}/gupnp
161
162 %if %{with vala}
163 %files -n vala-gupnp
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/gupnp-1.2.deps
166 %{_datadir}/vala/vapi/gupnp-1.2.vapi
167 %endif
This page took 0.088359 seconds and 3 git commands to generate.