]> git.pld-linux.org Git - packages/gtkmm3.git/blob - gtkmm3.spec
- updated to 3.4.1
[packages/gtkmm3.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 %define         glibmm_ver 2.32.0
6 Summary:        A C++ interface for the GTK+ (a GUI library for X)
7 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
8 Name:           gtkmm3
9 Version:        3.4.1
10 Release:        1
11 License:        LGPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.4/gtkmm-%{version}.tar.xz
14 # Source0-md5:  b7d9b14fe6083d63513b930a97b51630
15 URL:            http://www.gtkmm.org/
16 BuildRequires:  atkmm-devel >= 2.22.2
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  cairomm-devel >= 1.9.2
20 BuildRequires:  gdk-pixbuf2-devel >= 2.22.1
21 BuildRequires:  glibmm-devel >= %{glibmm_ver}
22 BuildRequires:  gtk+3-devel >= 3.4.0
23 BuildRequires:  libsigc++-devel
24 BuildRequires:  libstdc++-devel >= 5:3.3.1
25 BuildRequires:  libtool >= 2:2.0
26 BuildRequires:  mm-common >= 0.9.3
27 BuildRequires:  pangomm-devel >= 2.28.0
28 BuildRequires:  perl-base >= 1:5.6.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       atkmm >= 2.22.2
33 Requires:       cairomm >= 1.9.2
34 Requires:       gdk-pixbuf2 >= 2.22.1
35 Requires:       glibmm >= %{glibmm_ver}
36 Requires:       gtk+3 >= 3.4.0
37 Requires:       pangomm >= 2.28.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
42 library. The interface provides a convenient interface for C++
43 programmers to create GUIs with GTK+'s flexible object-oriented
44 framework. Features include type safe callbacks, widgets that are
45 extensible using inheritance and over 110 classes that can be freely
46 combined to quickly create complex user interfaces.
47
48 %description -l pl.UTF-8
49 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
50 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
51 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
52
53 %package devel
54 Summary:        gtkmm and gdkmm header files
55 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
56 Group:          X11/Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       atkmm-devel >= 2.22.2
59 Requires:       cairomm-devel >= 1.9.2
60 Requires:       gdk-pixbuf2-devel >= 2.22.1
61 Requires:       glibmm-devel >= %{glibmm_ver}
62 Requires:       gtk+3-devel >= 3.4.0
63 Requires:       pangomm-devel >= 2.28.0
64
65 %description devel
66 Header files for gtkmm library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki gtkmm.
70
71 %package static
72 Summary:        gtkmm and gdkmm static libraries
73 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 gtkmm and gdkmm static libraries.
79
80 %description static -l pl.UTF-8
81 Biblioteki statyczne gtkmm i gdkmm.
82
83 %package apidocs
84 Summary:        Reference documentation for gtkmm and gdkmm
85 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
86 Group:          Documentation
87 Requires:       devhelp
88
89 %description apidocs
90 Reference documentation for gtkmm and gdkmm.
91
92 %description apidocs -l pl.UTF-8
93 Szczegółowa dokumentacja gtkmm i gdkmm.
94
95 %prep
96 %setup -q -n gtkmm-%{version}
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I build
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         %{?with_static_libs:--enable-static}
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS PORTING README
126 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
128 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
134 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
135 %{_libdir}/gdkmm-3.0
136 %{_libdir}/gtkmm-3.0
137 %{_includedir}/gdkmm-3.0
138 %{_includedir}/gtkmm-3.0
139 %{_pkgconfigdir}/gdkmm-3.0.pc
140 %{_pkgconfigdir}/gtkmm-3.0.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libgdkmm-3.0.a
146 %{_libdir}/libgtkmm-3.0.a
147 %endif
148
149 %files apidocs
150 %defattr(644,root,root,755)
151 %{_docdir}/gtkmm-3.0
152 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.056333 seconds and 3 git commands to generate.