]> git.pld-linux.org Git - packages/gtkmm3.git/blob - gtkmm3.spec
- updated to 3.24.3
[packages/gtkmm3.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         atkmm_ver       2.24.2
6 %define         glibmm_ver      2.54.0
7 %define         gtk3_ver        3.24.0
8 %define         pangomm_ver     2.38.2
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm3
12 Version:        3.24.3
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        https://download.gnome.org/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
17 # Source0-md5:  9a9a00bcd634e3eca0b101809f2eae02
18 URL:            https://www.gtkmm.org/
19 BuildRequires:  atkmm-devel >= %{atkmm_ver}
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  cairomm-devel >= 1.12.0
23 BuildRequires:  doxygen >= 1:1.8.9
24 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
25 BuildRequires:  glibmm-devel >= %{glibmm_ver}
26 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
27 BuildRequires:  libepoxy-devel >= 1.2
28 BuildRequires:  libsigc++-devel
29 BuildRequires:  libstdc++-devel >= 6:4.7
30 BuildRequires:  libtool >= 2:2.0
31 BuildRequires:  mm-common >= 0.9.10
32 BuildRequires:  pangomm-devel >= %{pangomm_ver}
33 BuildRequires:  perl-base >= 1:5.6.0
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.752
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires:       atkmm >= %{atkmm_ver}
39 Requires:       cairomm >= 1.12.0
40 Requires:       gdk-pixbuf2 >= 2.36.0
41 Requires:       glibmm >= %{glibmm_ver}
42 Requires:       gtk+3 >= %{gtk3_ver}
43 Requires:       pangomm >= %{pangomm_ver}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
48 library. The interface provides a convenient interface for C++
49 programmers to create GUIs with GTK+'s flexible object-oriented
50 framework. Features include type safe callbacks, widgets that are
51 extensible using inheritance and over 110 classes that can be freely
52 combined to quickly create complex user interfaces.
53
54 %description -l pl.UTF-8
55 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
56 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
57 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
58
59 %package devel
60 Summary:        gtkmm and gdkmm header files
61 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
62 Group:          X11/Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       atkmm-devel >= %{atkmm_ver}
65 Requires:       cairomm-devel >= 1.12.0
66 Requires:       gdk-pixbuf2-devel >= 2.36.0
67 Requires:       glibmm-devel >= %{glibmm_ver}
68 Requires:       gtk+3-devel >= %{gtk3_ver}
69 Requires:       libstdc++-devel >= 6:4.6
70 Requires:       pangomm-devel >= %{pangomm_ver}
71
72 %description devel
73 Header files for gtkmm library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki gtkmm.
77
78 %package static
79 Summary:        gtkmm and gdkmm static libraries
80 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
81 Group:          X11/Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 gtkmm and gdkmm static libraries.
86
87 %description static -l pl.UTF-8
88 Biblioteki statyczne gtkmm i gdkmm.
89
90 %package apidocs
91 Summary:        Reference documentation for gtkmm and gdkmm
92 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
93 Group:          Documentation
94 Requires:       devhelp
95 %{?noarchpackage}
96
97 %description apidocs
98 Reference documentation for gtkmm and gdkmm.
99
100 %description apidocs -l pl.UTF-8
101 Szczegółowa dokumentacja gtkmm i gdkmm.
102
103 %prep
104 %setup -q -n gtkmm-%{version}
105
106 # missing in release tarball, not needed for Linux
107 mkdir win32_installer
108 touch win32_installer/filelist.am \
109         win32_installer/gtkmm-installer.nsi.in
110
111 %build
112 mm-common-prepare --copy --force
113 %{__libtoolize}
114 %{__aclocal} -I build
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --enable-maintainer-mode \
120         --disable-silent-rules \
121         %{?with_static_libs:--enable-static}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README
142 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
144 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
150 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
151 %{_libdir}/gdkmm-3.0
152 %{_libdir}/gtkmm-3.0
153 %{_includedir}/gdkmm-3.0
154 %{_includedir}/gtkmm-3.0
155 %{_pkgconfigdir}/gdkmm-3.0.pc
156 %{_pkgconfigdir}/gtkmm-3.0.pc
157
158 %if %{with static_libs}
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libgdkmm-3.0.a
162 %{_libdir}/libgtkmm-3.0.a
163 %endif
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_docdir}/gtkmm-3.0
168 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.057269 seconds and 3 git commands to generate.