]> git.pld-linux.org Git - packages/gtk-webkit.git/commitdiff
- updated to 2.4.0 auto/th/gtk-webkit-2.4.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Apr 2014 03:27:06 +0000 (05:27 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Apr 2014 03:27:06 +0000 (05:27 +0200)
- removed outdated sync-builtins patch

gtk-webkit-sync-builtins.patch [deleted file]
gtk-webkit.spec

diff --git a/gtk-webkit-sync-builtins.patch b/gtk-webkit-sync-builtins.patch
deleted file mode 100644 (file)
index 3d94d37..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
---- webkitgtk-2.0.0/configure.ac.orig  2013-04-12 08:25:14.896829422 +0200
-+++ webkitgtk-2.0.0/configure.ac       2013-04-12 08:27:21.244776999 +0200
-@@ -32,6 +32,18 @@
- AM_INIT_AUTOMAKE([foreign subdir-objects dist-xz no-dist-gzip tar-ustar])
- m4_include([Source/autotools/SetupAutomake.m4])
-+dnl Check whether the target supports 64-bit __sync_*_compare_and_swap.
-+AC_TRY_LINK([#include <stdint.h>],
-+    [uint64_t foo, bar;
-+     bar = __sync_val_compare_and_swap(&foo, 0, 1);],
-+     wtf_cv_have_64bit_sync_builtins=yes,
-+     wtf_cv_have_64bit_sync_builtins=no)
-+
-+if test $wtf_cv_have_64bit_sync_builtins = yes; then
-+    AC_DEFINE(HAVE_64BIT_SYNC_BUILTINS, 1,
-+              [Define to 1 if the target supports 64-bit __sync_*_compare_and_swap])
-+fi
-+
- ######################################################################################
- # Processing of configuration files
- ######################################################################################
---- webkitgtk-2.0.0/Source/WTF/wtf/Atomics.h~  2013-04-12 08:05:55.951740895 +0200
-+++ webkitgtk-2.0.0/Source/WTF/wtf/Atomics.h   2013-04-12 08:22:46.701992338 +0200
-@@ -70,6 +70,9 @@
- #elif OS(ANDROID)
- #include <sys/atomics.h>
- #endif
-+#ifndef HAVE_64BIT_SYNC_BUILTINS
-+#include <pthread.h>
-+#endif
- namespace WTF {
-@@ -113,8 +113,15 @@
- inline int atomicIncrement(int volatile* addend) { return __sync_add_and_fetch(addend, 1); }
- inline int atomicDecrement(int volatile* addend) { return __sync_sub_and_fetch(addend, 1); }
-+#ifdef HAVE_64BIT_SYNC_BUILTINS
- inline int64_t atomicIncrement(int64_t volatile* addend) { return __sync_add_and_fetch(addend, 1); }
- inline int64_t atomicDecrement(int64_t volatile* addend) { return __sync_sub_and_fetch(addend, 1); }
-+#else
-+static pthread_mutex_t global_wtf_lock = PTHREAD_MUTEX_INITIALIZER;
-+
-+inline int64_t atomicIncrement(int64_t volatile* addend) { pthread_mutex_lock(&global_wtf_lock); int64_t v = (*addend)++; pthread_mutex_unlock(&global_wtf_lock); return v; }
-+inline int64_t atomicDecrement(int64_t volatile* addend) { pthread_mutex_lock(&global_wtf_lock); int64_t v = (*addend)--; pthread_mutex_unlock(&global_wtf_lock); return v; }
-+#endif
- #endif
index 6e7ebfd1fa11c4794242b465c1dc1384b3577c5e..55fc163a169215088598ec9755117d208bd3339e 100644 (file)
@@ -5,14 +5,14 @@
 Summary:       Port of WebKit embeddable web component to GTK+
 Summary(pl.UTF-8):     Port osadzalnego komponentu WWW WebKit do GTK+
 Name:          gtk-webkit
-Version:       2.2.4
+Version:       2.4.0
 Release:       1
 License:       BSD-like
 Group:         X11/Libraries
 Source0:       http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
-# Source0-md5: d2af0d2d75f18cac33bd82ee63e22571
-Patch0:                %{name}-sync-builtins.patch
+# Source0-md5: c759bf11fe4cadd1268630f16a97f7b9
 URL:           http://webkitgtk.org/
+BuildRequires: /usr/bin/ld.gold
 BuildRequires: EGL-devel
 BuildRequires: OpenGL-GLX-devel
 BuildRequires: at-spi2-core-devel >= 2.6.0
@@ -25,7 +25,7 @@ BuildRequires:        flex >= 2.5.33
 BuildRequires: fontconfig-devel >= 2.5.0
 BuildRequires: freetype-devel >= 1:2.1.8
 BuildRequires: gcc-c++ >= 6:4.7
-BuildRequires: geoclue-devel
+BuildRequires: geoclue2-devel >= 2.1.5
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 1:2.36.0
 BuildRequires: glibc-misc
@@ -33,6 +33,7 @@ BuildRequires:        glibc-misc
 BuildRequires: gperf
 BuildRequires: gstreamer-devel >= 1.0.3
 BuildRequires: gstreamer-plugins-base-devel >= 1.0.3
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: gtk+2-devel >= 2:2.24.10
 BuildRequires: gtk-doc >= 1.10
 BuildRequires: harfbuzz-devel >= 0.9.7
@@ -63,7 +64,6 @@ BuildRequires:        xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xz
 BuildRequires: zlib-devel
-BuildRequires: /usr/bin/ld.gold
 Requires:      cairo >= 1.10
 Requires:      enchant >= 0.22
 Requires:      fontconfig-libs >= 2.5.0
@@ -80,6 +80,9 @@ Requires:     pango >= 1:1.32.0
 %{?with_introspection:Conflicts:       gir-repository < 0.6.5-7}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# __once_call, __once_called non-function symbols from libstdc++
+%define                skip_post_check_so      lib.*gtk-1.0.*
+
 %description
 gtk-webkit is a port of the WebKit embeddable web component to GTK+.
 
@@ -104,7 +107,6 @@ Pliki programistyczne komponentu WebKit dla GTK+ 2.
 
 %prep
 %setup -q -n webkitgtk-%{version}
-%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -135,7 +137,7 @@ rm -rf $RPM_BUILD_ROOT
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
 # packaged in gtk-webkit3
-%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/webkitgtk
+%{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/{webkitgtk,webkitdomgtk}
 
 %find_lang WebKitGTK-2.0
 
This page took 0.100766 seconds and 4 git commands to generate.