]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
Updated to 1.14.4
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  gpl             # GPL licensed components
4 %bcond_without  vdpau           # build libav without VDPAU support
5 %bcond_with     system_ffmpeg   # system ffmpeg (note: upstream does not accept bugs with system ffmpeg)
6
7 %define         gstname gst-libav
8 %define         gst_major_ver   1.0
9 %define         gst_req_ver     1.14.0
10 %define         gstpb_req_ver   1.14.0
11 %define         ffmpeg_ver      3.3.5
12
13 %include        /usr/lib/rpm/macros.gstreamer
14 Summary:        GStreamer Streaming-media framework plug-in using libav
15 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
16 Name:           gstreamer-libav
17 Version:        1.14.4
18 Release:        1
19 %if %{with gpl}
20 License:        GPL v2+
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Libraries
25 Source0:        https://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
26 # Source0-md5:  58342db11dbb201a66a62577dcf7bab5
27 Patch0:         link.patch
28 URL:            https://gstreamer.freedesktop.org/
29 BuildRequires:  autoconf >= 2.69
30 BuildRequires:  automake >= 1:1.14
31 BuildRequires:  glib2-devel >= 1:2.40.0
32 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
33 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
34 BuildRequires:  gtk-doc >= 1.12
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  orc-devel >= 0.4.16
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 BuildRequires:  python >= 2.1
39 BuildRequires:  rpmbuild(macros) >= 1.470
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 %if %{with system_ffmpeg}
43 # libavformat,libavcodec,libavutil,libswscale needed
44 BuildRequires:  ffmpeg-devel >= %{ffmpeg_ver}
45 %else
46 # libav dependencies
47 BuildRequires:  SDL-devel
48 BuildRequires:  bzip2-devel
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xz-devel
51 BuildRequires:  zlib-devel
52 %ifarch %{ix86} %{x8664}
53 BuildRequires:  yasm
54 %endif
55 BuildRequires:  libvdpau-devel
56 %if %{with vdpau}
57 BuildRequires:  xorg-lib-libXvMC-devel
58 %endif
59 %endif
60 Requires:       glib2 >= 1:2.40.0
61 Requires:       gstreamer >= %{gst_req_ver}
62 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
63 %if %{with system_ffmpeg}
64 Requires:       ffmpeg-libs >= %{ffmpeg_ver}
65 %endif
66 Requires:       orc >= 0.4.16
67 Obsoletes:      gstreamer-ffmpeg
68 Obsoletes:      gstreamer-real
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 GStreamer is a streaming-media framework, based on graphs of filters
73 which operate on media data. Applications using this library can do
74 anything from real-time sound processing to playing videos, and just
75 about anything else media-related. Its plugin-based architecture means
76 that new data types or processing capabilities can be added simply by
77 installing new plug-ins.
78
79 This plugin contains the libav codecs, containing codecs for most
80 popular multimedia formats.
81
82 %description -l pl.UTF-8
83 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
84 grafie filtrów operujących na danych medialnych. Aplikacje używające
85 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
86 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
87 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
88 nowych typów danych lub możliwości obróbki.
89
90 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
91 najpopularniejsze formaty multimedialne.
92
93 %package apidocs
94 Summary:        API documentation for GStreamer libav plugin
95 Summary(pl.UTF-8):      Dokumentacja API do wtyczki GStreamera libav
96 Group:          Documentation
97 Requires:       gtk-doc-common
98 %if "%{_rpmversion}" >= "5"
99 BuildArch:      noarch
100 %endif
101
102 %description apidocs
103 API documentation for GStreamer libav plugin.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API do wtyczki GStreamera libav.
107
108 %prep
109 %setup -q -n %{gstname}-%{version}
110 %patch0 -p1
111
112 %build
113 %{__libtoolize}
114 %{__aclocal} -I m4 -I common/m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118
119 LIBAV_OPTS="%{?with_vdpau:--enable-vdpau}"
120 %ifarch x32
121 LIBAV_OPTS="$LIBAV_OPTS --disable-asm"
122 %endif
123 %configure \
124         CPPFLAGS="%{rpmcppflags}" \
125         %{?with_system_ffmpeg:--with-system-libav} \
126         --with-libav-extra-configure="$LIBAV_OPTS" \
127         %{?with_gpl:--enable-gpl} \
128         --disable-silent-rules \
129         --disable-static \
130         --with-html-dir=%{_gtkdocdir}
131
132 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
133 %{__make} \
134         V=1
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS README TODO
150 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
151 # disabled in (upstream) 1.2.0 until someone fixes it
152 #%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
153
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/gst-libav-plugins-1.0
This page took 0.446754 seconds and 4 git commands to generate.