]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
- updated to 1.6.0
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  gpl             # GPL licensed components
4 %bcond_without  vdpau           # build libav without VDPAU support
5 %bcond_with     system_ffmpeg   # system ffmpeg (note: upstream does not accept bugs with system ffmpeg)
6
7 %define         gstname gst-libav
8 %define         gst_major_ver   1.0
9 %define         gst_req_ver     1.6.0
10 %define         gstpb_req_ver   1.6.0
11 %define         ffmpeg_ver      2.8
12
13 %include        /usr/lib/rpm/macros.gstreamer
14 Summary:        GStreamer Streaming-media framework plug-in using libav
15 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
16 Name:           gstreamer-libav
17 Version:        1.6.0
18 Release:        1
19 %if %{with gpl}
20 License:        GPL v2+
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Libraries
25 Source0:        http://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
26 # Source0-md5:  eda67328be0878bb73449c29ca55baf8
27 URL:            http://gstreamer.net/
28 BuildRequires:  autoconf >= 2.69
29 BuildRequires:  automake >= 1:1.14
30 BuildRequires:  bzip2-devel
31 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
32 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
33 BuildRequires:  gtk-doc >= 1.12
34 BuildRequires:  libtool >= 2:2.2.6
35 BuildRequires:  orc-devel >= 0.4.16
36 BuildRequires:  pkgconfig >= 1:0.9.0
37 BuildRequires:  python >= 2.1
38 BuildRequires:  rpmbuild(macros) >= 1.470
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRequires:  xz-devel
42 %if %{with system_ffmpeg}
43 # libavformat,libavcodec,libavutil,libswscale needed
44 BuildRequires:  ffmpeg-devel >= %{ffmpeg_ver}
45 %else
46 # libav dependencies
47 BuildRequires:  SDL-devel
48 BuildRequires:  zlib-devel
49 %ifarch %{ix86} %{x8664}
50 BuildRequires:  yasm
51 %endif
52 %if %{with vdpau}
53 BuildRequires:  libvdpau-devel
54 BuildRequires:  xorg-lib-libXvMC-devel
55 %endif
56 %endif
57 Requires:       gstreamer >= %{gst_req_ver}
58 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
59 %if %{with system_ffmpeg}
60 Requires:       ffmpeg-libs >= %{ffmpeg_ver}
61 %endif
62 Requires:       orc >= 0.4.16
63 Obsoletes:      gstreamer-ffmpeg
64 Obsoletes:      gstreamer-real
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 GStreamer is a streaming-media framework, based on graphs of filters
69 which operate on media data. Applications using this library can do
70 anything from real-time sound processing to playing videos, and just
71 about anything else media-related. Its plugin-based architecture means
72 that new data types or processing capabilities can be added simply by
73 installing new plug-ins.
74
75 This plugin contains the libav codecs, containing codecs for most
76 popular multimedia formats.
77
78 %description -l pl.UTF-8
79 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
80 grafie filtrów operujących na danych medialnych. Aplikacje używające
81 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
82 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
83 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
84 nowych typów danych lub możliwości obróbki.
85
86 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
87 najpopularniejsze formaty multimedialne.
88
89 %package apidocs
90 Summary:        API documentation for GStreamer libav plugin
91 Summary(pl.UTF-8):      Dokumentacja API do wtyczki GStreamera libav
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 API documentation for GStreamer libav plugin.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API do wtyczki GStreamera libav.
100
101 %prep
102 %setup -q -n %{gstname}-%{version}
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4 -I common/m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110
111 %configure \
112         CPPFLAGS="%{rpmcppflags}" \
113         %{?with_system_ffmpeg:--with-system-libav} \
114         %{?with_vdpau:--with-libav-extra-configure="--enable-vdpau"} \
115         %{?with_gpl:--enable-gpl} \
116         --disable-silent-rules \
117         --disable-static \
118         --with-html-dir=%{_gtkdocdir}
119
120 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
121 %{__make} \
122         V=1
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README TODO
138 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
139 # disabled in (upstream) 1.2.0 until someone fixes it
140 #%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
141
142 %files apidocs
143 %defattr(644,root,root,755)
144 %{_gtkdocdir}/gst-libav-plugins-1.0
This page took 0.278409 seconds and 4 git commands to generate.