]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
- updated to 1.4.0.1; sniffer ported to gtk4, docs are based on gi-docgen now
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # gi-docgen based API documentation
4 %bcond_without  vala    # Vala bindings
5
6 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
7 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
8 Name:           gssdp
9 # note: 1.4.x is stable, 1.5.x unstable
10 Version:        1.4.0.1
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        https://download.gnome.org/sources/gssdp/1.4/%{name}-%{version}.tar.xz
15 # Source0-md5:  aad066cf237f2f4de8ebf82de4142f27
16 URL:            https://wiki.gnome.org/Projects/GUPnP
17 BuildRequires:  docbook-dtd412-xml
18 %{?with_apidocs:BuildRequires:  gi-docgen >= 2021.1}
19 BuildRequires:  glib2-devel >= 1:2.54
20 BuildRequires:  gobject-introspection-devel >= 1.36.0
21 BuildRequires:  gtk4-devel >= 4
22 BuildRequires:  libsoup-devel >= 2.26.1
23 BuildRequires:  meson >= 0.54.0
24 BuildRequires:  ninja >= 1.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpm-build >= 4.6
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 %{?with_vala:BuildRequires:     vala >= 2:0.20}
30 BuildRequires:  xz
31 Requires:       glib2 >= 1:2.54
32 Requires:       libsoup >= 2.26.1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GSSDP is a GObject-based API that implements resource discovery and
37 announcement over SSDP (Simple Service Discovery Protocol).
38
39 %description -l pl.UTF-8
40 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
41 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
42 Discovery Protocol).
43
44 %package sniffer
45 Summary:        Graphical SSDP sniffer
46 Summary(pl.UTF-8):      Graficzny sniffer SSDP
47 Group:          X11/Applications/Networking
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       gtk4 >= 4
50
51 %description sniffer
52 Graphical SSDP sniffer.
53
54 %description sniffer -l pl.UTF-8
55 Graficzny sniffer SSDP.
56
57 %package devel
58 Summary:        Header files for GSSDP
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       glib2-devel >= 1:2.54
63 Requires:       libsoup-devel >= 2.26.1
64
65 %description devel
66 This package contains header files for GSSDP library.
67
68 %description devel -l pl.UTF-8
69 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
70
71 %package static
72 Summary:        Static GSSDP library
73 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static GSSDP library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka GSSDP.
82
83 %package apidocs
84 Summary:        GSSDP API documentation
85 Summary(pl.UTF-8):      Dokumentacja API GSSDP
86 Group:          Documentation
87 Requires:       gtk-doc-common
88 BuildArch:      noarch
89
90 %description apidocs
91 GSSDP API documentation.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API GSSDP.
95
96 %package -n vala-gssdp
97 Summary:        Vala binding for GSSDP library
98 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       vala >= 2:0.20
102 BuildArch:      noarch
103
104 %description -n vala-gssdp
105 Vala binding for GSSDP library.
106
107 %description -n vala-gssdp -l pl.UTF-8
108 Wiązanie języka Vala do biblioteki GSSDP.
109
110 %prep
111 %setup -q
112
113 %build
114 %meson build \
115         %{?with_apidocs:-Dgtk_doc=true}
116
117 %ninja_build -C build
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %ninja_install -C build
123
124 %if %{with apidocs}
125 # FIXME: where to package gi-docgen generated docs?
126 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
127 %{__mv} $RPM_BUILD_ROOT%{_docdir}/gssdp-1.2/reference/* $RPM_BUILD_ROOT%{_gtkdocdir}
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README.md
139 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.2.so.0
141 %{_libdir}/girepository-1.0/GSSDP-1.2.typelib
142
143 %files sniffer
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so
150 %{_datadir}/gir-1.0/GSSDP-1.2.gir
151 %{_includedir}/gssdp-1.2
152 %{_pkgconfigdir}/gssdp-1.2.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libgssdp-1.2.a
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/GSSDP
162 %endif
163
164 %if %{with vala}
165 %files -n vala-gssdp
166 %defattr(644,root,root,755)
167 %{_datadir}/vala/vapi/gssdp-1.2.deps
168 %{_datadir}/vala/vapi/gssdp-1.2.vapi
169 %endif
This page took 0.18956 seconds and 3 git commands to generate.