]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
14c219a83c5219a578e9bfcc9841b19a07bb0a99
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 Name:           grub2
48 Version:        2.00
49 Release:        6
50 License:        GPL v2
51 Group:          Base
52 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
53 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
54 Source1:        update-grub
55 Source2:        update-grub.8
56 Source3:        grub.sysconfig
57 Source4:        grub-custom.cfg
58 Patch1:         pld-sysconfdir.patch
59 Patch2:         grub-garbage.patch
60 Patch3:         grub-lvmdevice.patch
61 Patch4:         pld-mkconfigdir.patch
62 Patch5:         grub-mkconfig-diagnostics.patch
63 Patch6:         ppc.patch
64 Patch7:         %{name}-awk.patch
65 Patch8:         posix.patch
66 Patch9:         %{name}-gets.patch
67 Patch10:        %{name}-fonts_path.patch
68 Patch11:        %{name}-tftp_fixes.patch
69 Patch12:        add-vlan-tag-support.patch
70 Patch13:        just-say-linux.patch
71 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
72 Patch15:        add-X-option-to-printf-functions.patch
73 Patch16:        dhcp-client-id-and-uuid-options-added.patch
74 Patch17:        fix-http-crash.patch
75 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
76 Patch19:        search-for-specific-config-file-for-netboot.patch
77 Patch20:        ignore-kernel-symlinks.patch
78 Patch21:        choose-preferred-initrd.patch
79 Patch22:        %{name}-cfg.patch
80 Patch23:        %{name}-freetype_include.patch
81 Patch24:        %{name}-efinet_fix.patch
82 URL:            http://www.gnu.org/software/grub/
83 BuildRequires:  autoconf >= 2.53
84 BuildRequires:  automake >= 1:1.11.1-1
85 BuildRequires:  bison
86 BuildRequires:  device-mapper-devel
87 BuildRequires:  flex >= 2.5.35
88 BuildRequires:  fonts-TTF-DejaVu
89 BuildRequires:  freetype-devel >= 2
90 BuildRequires:  gawk
91 BuildRequires:  gettext-devel
92 BuildRequires:  glibc-static
93 BuildRequires:  help2man
94 BuildRequires:  libfuse-devel
95 BuildRequires:  libtool
96 BuildRequires:  ncurses-devel
97 BuildRequires:  rpm >= 4.4.9-56
98 BuildRequires:  rpmbuild(macros) >= 1.213
99 BuildRequires:  sed >= 4.0
100 BuildRequires:  tar >= 1:1.22
101 BuildRequires:  texinfo
102 BuildRequires:  xz
103 BuildRequires:  xz-devel
104 %ifarch %{x8664}
105 BuildRequires:  /usr/lib/libc.so
106 %if "%{pld_release}" == "ac"
107 BuildRequires:  libgcc32
108 %else
109 BuildRequires:  gcc-multilib
110 %endif
111 %endif
112 Requires:       %{name}-platform = %{version}-%{release}
113 Requires:       pld-release
114 Requires:       which
115 %ifarch %{ix86} %{x8664}
116 Suggests:       %{name}-platform-pc
117 %endif
118 Suggests:       cdrkit-mkisofs
119 Suggests:       os-prober
120 Provides:       bootloader
121 Conflicts:      grub
122 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         _sbindir        /sbin
126 %define         _bindir         %{_sbindir}
127 %define         _libdir         /lib
128 %define         _datadir        %{_libdir}
129 %define         _libexecdir     %{_libdir}/grub
130 %define         _grubdir        /boot/grub
131 %define         _localedir      /usr/share/locale
132
133 # part of grub code is not relocable (these are not Linux libs)
134 # stack protector also breaks non-Linux binaries
135 # any kind of forced optimizations makes grub2 unreliable (random
136 # reboots and hangs on boot menu screen)
137 %define         filterout_c     -fPIC -O.
138 %undefine       _ssp_cflags
139 %undefine       _fortify_cflags
140
141 %description
142 GRUB is a GPLed bootloader intended to unify bootloading across x86
143 operating systems. In addition to loading the Linux and *BSD kernels,
144 it implements the Multiboot standard, which allows for flexible
145 loading of multiple boot images (needed for modular kernels such as
146 the GNU Hurd).
147
148 GRUB 2 is derived from PUPA which was a research project to
149 investigate the next generation of GRUB. GRUB 2 has been rewritten
150 from scratch to clean up everything for modularity and portability.
151
152 GRUB 2 targets at the following goals:
153 - Scripting support, such as conditionals, loops, variables and
154   functions.
155 - Graphical interface.
156 - Dynamic loading of modules in order to extend itself at the run time
157   rather than at the build time.
158 - Portability for various architectures.
159 - Internationalization. This includes support for non-ASCII character
160   code, message catalogs like gettext, fonts, graphics console, and so
161   on.
162 - Real memory management, to make GNU GRUB more extensible.
163 - Modular, hierarchical, object-oriented framework for file systems,
164   files, devices, drives, terminals, commands, partition tables and OS
165   loaders.
166 - Cross-platform installation which allows for installing GRUB from a
167   different architecture.
168 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
169 - Fix design mistakes in GRUB Legacy, which could not be solved for
170   backward-compatibility, such as the way of numbering partitions.
171
172 %description -l de.UTF-8
173 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
174 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
175 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
176
177 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
178 und wird unter der GPL vertrieben. Aufgrund seiner höheren
179 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
180 traditionellen Boot-Loader LILO.
181
182 %description -l hu.UTF-8
183 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
184 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
185 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
186 GNU Hurd).
187
188 GRUB2 céljai a következők:
189 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
190   függvények.
191 - grafikus felület
192 - modulok dinamikus betöltése futási időben
193 - hordozhatóság több architektúrára
194 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
195   mint gettext, betűtípusok, grafikus konzolon, és így tovább
196 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
197 - moduláris, hierarchikus, objektum-orientált keretrendszer
198   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
199   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
200
201 %description -l es.UTF-8
202 Éste es GRUB - Grand Unified Boot Loader - un administrador de
203 inicialización capaz de entrar en la mayoría de los sistemas
204 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
205 también en la mayoría de los sistemas operacionales comerciales para
206 PC.
207
208 El administrador GRUB puede ser una buena alternativa a LILO, para
209 usuarios conmás experiencia y que deseen obtener más recursos de su
210 cargador de inicialización (boot loader).
211
212 %description -l pl.UTF-8
213 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
214 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
215 Linuksa i *BSD: posiada również implementację standardu Multiboot,
216 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
217 (czego wymagają modułowe jądra, takie jak GNU Hurd).
218
219 %description -l pt_BR.UTF-8
220 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
221 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
222 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
223 operacionais comerciais para PC.
224
225 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
226 avançados e que querem mais recursos de seu boot loader.
227
228 %package -n bash-completion-%{name}
229 Summary:        bash-completion for GRUB
230 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
231 Group:          Applications/Shells
232 Requires:       bash-completion
233
234 %description -n bash-completion-%{name}
235 This package provides bash-completion for GRUB.
236
237 %description -n bash-completion-%{name} -l pl.UTF-8
238 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
239
240 %package platform-pc
241 Summary:        PC BIOS platform support for GRUB
242 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
243 Group:          Base
244 Provides:       %{name}-platform = %{version}-%{release}
245
246 %description platform-pc
247 PC BIOS platform support for GRUB.
248
249 %description platform-pc -l pl.UTF-8
250 Obsługa platformy PC BIOS dla GRUB-a.
251
252 %package platform-efi
253 Summary:        (U)EFI platform support for GRUB
254 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
255 Group:          Base
256 Suggests:       efibootmgr
257 Provides:       %{name}-platform = %{version}-%{release}
258
259 %description platform-efi
260 (U)EFI platform support for GRUB.
261
262 %description platform-efi -l pl.UTF-8
263 Obsługa platformy (U)EFI dla GRUB-a.
264
265 %package mkfont
266 Summary:        GRUB font files converter
267 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
268 Group:          Base
269
270 %description mkfont
271 Converts common font file formats into PF2.
272
273 %description mkfont -l pl.UTF-8
274 Program do konwersji popularnych formatów plików fontów do PF2.
275
276 %package theme-starfield
277 Summary:        starfield theme for GRUB
278 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
279 Group:          Base
280
281 %description theme-starfield
282 starfield theme for GRUB.
283
284 %description theme-starfield -l pl.UTF-8
285 Motyw starfield dla GRUB-a.
286
287 %prep
288 %setup -q -n grub-%{version}
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292 %patch4 -p1
293 %patch5 -p1
294 %patch6 -p1
295 %patch7 -p1
296 %patch8 -p1
297 %patch9 -p1
298 %patch10 -p1
299 %patch11 -p1
300 %patch12 -p1
301 %patch13 -p1
302 %patch14 -p1
303 %patch15 -p1
304 %patch16 -p1
305 %patch17 -p1
306 %patch18 -p1
307 %patch19 -p1
308 %patch20 -p1
309 %patch21 -p1
310 %patch22 -p0
311 %patch23 -p1
312 %patch24 -p1
313
314 %build
315 # if gold is used then grub doesn't even boot
316 # https://savannah.gnu.org/bugs/?34539
317 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
318 install -d our-ld
319 ln -s /usr/bin/ld.bfd our-ld/ld
320 export PATH=$(pwd)/our-ld:$PATH
321
322 cp -f /usr/share/automake/config.sub .
323 %{__libtoolize}
324 %{__aclocal} -I m4
325 %{__autoheader}
326 echo timestamp > stamp-h.in
327 %{__autoconf}
328 %{__automake}
329
330 for platform in %{platforms} ; do
331         install -d build-${platform}
332         cd build-${platform}
333
334         if [ "$platform" != "efi" ] ; then
335                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
336         else
337                 platform_opts=""
338         fi
339
340         ln -s ../configure .
341         # mawk stalls at ./genmoddep.awk, so force gawk
342         AWK=gawk \
343         %configure \
344                 --with-platform=${platform} \
345                 --disable-werror \
346         %if %{with grubemu}
347                 --enable-grub-emu-usb \
348                 --enable-grub-emu-sdl \
349                 --enable-grub-emu-pci \
350         %endif
351                 $platform_opts \
352                 TARGET_LDFLAGS=-static
353
354         %{__make}
355         cd ..
356 done
357
358 %install
359 rm -rf $RPM_BUILD_ROOT
360
361 for platform in %{platforms} ; do
362         cd build-${platform}
363         %{__make} install \
364                 pkgdatadir=%{_libexecdir} \
365                 pkglibdir=%{_libexecdir} \
366                 DESTDIR=$RPM_BUILD_ROOT
367         cd ..
368 done
369
370 # not in Th (?)
371 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
372 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
373
374 %find_lang grub
375
376 # this must be after 'make install'
377 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
378
379 install -d $RPM_BUILD_ROOT%{_grubdir}
380 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
381
382 # grub.d/41_custom
383 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
384 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
385
386 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
387 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
388
389 install -d $RPM_BUILD_ROOT/etc/sysconfig
390 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
391
392 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
393 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
394
395 # platform specific, unnecessarily always installed
396 %ifnarch %{ix86} %{x8664}
397 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
398 %endif
399 %ifnarch sparc64
400 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
401 %endif
402
403 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
404 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
405 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
406
407 # needs to be exactly 1KiB
408 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
409 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
410
411 %clean
412 rm -rf $RPM_BUILD_ROOT
413
414 %post -p %{_sbindir}/postshell
415 -/usr/sbin/fix-info-dir -c %{_infodir}
416
417 %postun -p %{_sbindir}/postshell
418 -/usr/sbin/fix-info-dir -c %{_infodir}
419
420 %triggerpostun -- %{name} < 2.00-2
421 # Note this trigger on version upgrade needed only for upgrade from
422 # old grub2 packages which contained modules in /boot/grub
423 # or were built with optimizations enabled
424 # don't do anything on --downgrade
425 if [ $1 -le 1 ]; then
426         exit 0
427 fi
428 echo "Grub was upgraded, trying to setup it to boot sector"
429 /sbin/grub-install '(hd0)' || :
430
431 %triggerpostun -- %{name} < 1.99-7.3
432 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
433 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
434         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
435         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
436 fi
437
438 %files -f grub.lang
439 %defattr(644,root,root,755)
440 %doc AUTHORS ChangeLog NEWS README THANKS TODO
441 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
442 %attr(755,root,root) %{_sbindir}/grub-editenv
443 %attr(755,root,root) %{_sbindir}/grub-fstest
444 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
445 %attr(755,root,root) %{_sbindir}/grub-install
446 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
447 %attr(755,root,root) %{_sbindir}/grub-mkconfig
448 %attr(755,root,root) %{_sbindir}/grub-mklayout
449 %attr(755,root,root) %{_sbindir}/grub-mknetdir
450 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
451 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
452 %attr(755,root,root) %{_sbindir}/grub-mkrescue
453 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
454 %attr(755,root,root) %{_sbindir}/grub-mount
455 %attr(755,root,root) %{_sbindir}/grub-ofpathname
456 %attr(755,root,root) %{_sbindir}/grub-reboot
457 %attr(755,root,root) %{_sbindir}/grub-script-check
458 %attr(755,root,root) %{_sbindir}/grub-set-default
459 %attr(755,root,root) %{_sbindir}/update-grub
460 %ifarch %{ix86} %{x8664}
461 %attr(755,root,root) %{_sbindir}/grub-bios-setup
462 %{_mandir}/man8/grub-bios-setup.8*
463 %endif
464 %ifarch %{ix86} %{x8664}
465 %attr(755,root,root) %{_sbindir}/grub-mkimage
466 %{_mandir}/man1/grub-mkimage.1*
467 %else
468 %attr(755,root,root) %{_sbindir}/grub-probe
469 %{_mandir}/man8/grub-probe.8*
470 %endif
471 %ifarch sparc64
472 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
473 %{_mandir}/man8/grub-sparc64-setup.8*
474 %endif
475 %{_mandir}/man1/grub-editenv.1*
476 %{_mandir}/man1/grub-fstest.1*
477 %{_mandir}/man1/grub-kbdcomp.1*
478 %{_mandir}/man1/grub-menulst2cfg.1*
479 %{_mandir}/man1/grub-mklayout.1*
480 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
481 %{_mandir}/man1/grub-mkrelpath.1*
482 %{_mandir}/man1/grub-mkrescue.1*
483 %{_mandir}/man1/grub-mkstandalone.1*
484 %{_mandir}/man1/grub-mount.1*
485 %{_mandir}/man1/grub-script-check.1*
486 %{_mandir}/man8/grub-install.8*
487 %{_mandir}/man8/grub-mkconfig.8*
488 %{_mandir}/man8/grub-mknetdir.8*
489 %{_mandir}/man8/grub-ofpathname.8*
490 %{_mandir}/man8/grub-reboot.8*
491 %{_mandir}/man8/grub-set-default.8*
492 %{_mandir}/man8/update-grub.8*
493 %if %{with grubemu}
494 %attr(755,root,root) %{_sbindir}/grub-emu
495 %{_mandir}/man8/grub-emu.8*
496 %endif
497 %{_libexecdir}/grub-mkconfig_lib
498
499 %dir %{_grubdir}
500 %dir %{_libexecdir}
501 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
502
503 %dir %{_libexecdir}/locale
504 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
505 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
506
507 # generated by grub at runtime
508 %ghost %{_grubdir}/device.map
509 %ghost %{_grubdir}/core.img
510 %ghost %{_grubdir}/grubenv
511
512 %dir /lib/grub.d
513 %doc /lib/grub.d/README
514 %attr(755,root,root) /lib/grub.d/00_header
515 %attr(755,root,root) /lib/grub.d/10_linux
516 %attr(755,root,root) /lib/grub.d/20_linux_xen
517 %attr(755,root,root) /lib/grub.d/30_os-prober
518 %attr(755,root,root) /lib/grub.d/41_custom
519
520 %ifarch %{ix86} %{x8664}
521 %attr(755,root,root) %{_sbindir}/grub-probe
522 %{_mandir}/man8/grub-probe.8*
523 %endif
524
525 %{_infodir}/grub*.info*
526
527 %dir %{_datadir}/grub/themes
528
529 %if %{with pc}
530 %files platform-pc
531 %defattr(644,root,root,755)
532 %dir %{_libexecdir}/*-pc
533 %{_libexecdir}/*-pc/modinfo.sh
534 %{_libexecdir}/*-pc/*.exec
535 %{_libexecdir}/*-pc/*.image
536 %{_libexecdir}/*-pc/*.lst
537 %{_libexecdir}/*-pc/*.mod
538 %{_libexecdir}/*-pc/*.module
539 %{_libexecdir}/*-pc/lzma_decompress.img
540 %{_libexecdir}/*-pc/config.h
541 %{_libexecdir}/*-pc/gdb_grub
542 %{_libexecdir}/*-pc/gmodule.pl
543 %if %{with efiemu}
544 %{_libexecdir}/*-pc/efiemu*.o
545 %endif
546 %{_libexecdir}/*-pc/kernel.img
547 %ifarch %{ix86} %{x8664} sparc sparc64
548 %{_libexecdir}/*-pc/boot.img
549 %{_libexecdir}/*-pc/cdboot.img
550 %{_libexecdir}/*-pc/diskboot.img
551 %{_libexecdir}/*-pc/lnxboot.img
552 %{_libexecdir}/*-pc/pxeboot.img
553 %endif
554 %endif
555
556 %if %{with efi}
557 %files platform-efi
558 %defattr(644,root,root,755)
559 %dir %{_libexecdir}/*-efi
560 %{_libexecdir}/*-efi/modinfo.sh
561 %{_libexecdir}/*-efi/*.exec
562 %{_libexecdir}/*-efi/*.lst
563 %{_libexecdir}/*-efi/*.mod
564 %{_libexecdir}/*-efi/*.module
565 %{_libexecdir}/*-efi/config.h
566 %{_libexecdir}/*-efi/gdb_grub
567 %{_libexecdir}/*-efi/gmodule.pl
568 %{_libexecdir}/*-efi/kernel.img
569 %endif
570
571 %files mkfont
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_sbindir}/grub-mkfont
574 %{_mandir}/man1/grub-mkfont.1*
575
576 %files theme-starfield
577 %defattr(644,root,root,755)
578 %{_datadir}/grub/themes/starfield
579
580 %files -n bash-completion-%{name}
581 %defattr(644,root,root,755)
582 /etc/bash_completion.d/grub
This page took 0.08443 seconds and 3 git commands to generate.