]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
c0a5052241403511e318b910ca063ae1d06b8e15
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_with     pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de):    GNU-Version der Pattern-Matching-Utilities
7 Summary(es):    Utilitarios grep GNU
8 Summary(fr):    Utilitaires grep de GNU
9 Summary(ja):    GNU grep ¤ÎÆüËܸìÂбþÈǤǤ¹.
10 Summary(pl):    GNU grep
11 Summary(pt_BR): Utilitários grep GNU
12 Summary(ru):    õÔÉÌÉÔÙ ÐÏÉÓËÁ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
13 Summary(tr):    Dosyalarda katar arama aracý
14 Summary(uk):    õÔÉ̦ÔÉ ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
15 Name:           grep
16 Version:        2.5.1
17 Release:        12
18 Epoch:          2
19 License:        GPL
20 Group:          Applications/Text
21 Source0:        ftp://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  ae69f8112cdc63615cefe944f38bbee7
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-egrep.patch
27 Patch2:         %{name}-locale-names.patch
28 %{?with_pcre:BuildRequires:     pcre-devel}
29 BuildRequires:  gettext-devel
30 BuildRequires:  automake
31 BuildRequires:  autoconf
32 BuildRequires:  libtool
33 %{?with_pcre:Requires:  pcre}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _bindir         /bin
37 %define         _exec_prefix    /
38
39 %description
40 The GNU versions of commonly used grep utilities. Grep searches one or
41 more input files for lines which contain a match to a specified
42 pattern and then prints the matching lines. GNU's grep utilities
43 include grep, egrep and fgrep.
44
45 %description -l de
46 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
47 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
48 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
49 enthält grep, egrep und fgrep.
50
51 %description -l es
52 Esta es la implementación GNU del popular utilitario grep. Permite la
53 localización rápida de strings en archivos texto.
54
55 %description -l fr
56 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
57 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
58 les fichiers.
59
60 %description -l ja
61 GNU ¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë grep, egrep, fgrep (°Ê²¼Ã±¤Ë grep) ¤ò¥Þ¥ë¥Á¥Ð
62 ¥¤¥È¥Ñ¥Ã¥Á(mb1.04)¤Ë¤è¤Ã¤ÆÆüËܸìÂбþ¤Ë¤·¤¿¤â¤Î¤Ç¤¹.
63
64 %description -l pl
65 GNU grep jest implementacj± popularnego programu uniksowego `grep'.
66 Grep jest jednym z podstawowych narzêdzi, korzysta z niego prawie
67 ka¿dy skrypt shella.
68
69 %description -l pt_BR
70 Esta é a implementação GNU do popular utilitário grep. Permite a
71 localização rápida de strings em arquivos texto.
72
73 %description -l ru
74 üÔÏ ÒÅÁÌÉÚÁÃÉÑ GNU ÕÔÉÌÉÔÙ grep, ÐÒÅÄÎÁÚÎÁÞÅÎÎÏÊ ÄÌÑ ÂÙÓÔÒÏÇÏ ÐÏÉÓËÁ
75 ÐÏ ÏÂÒÁÚÃÕ × ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÁÈ.
76
77 %description -l tr
78 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn
79 GNU sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada
80 kullanýlýr.
81
82 %description -l uk
83 ãÅ GNU ÒÅÁ̦ÚÁæѠÐÏÐÕÌÑÒÎϧ ÕÔÉ̦ÔÉ grep, ÐÒÉÚÎÁÞÅÎϧ ÄÌÑ Û×ÉÄËÏÇÏ
84 ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÕ × ÔÅËÓÔÏ×ÉÈ ÆÁÊÌÁÈ.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 rm -f m4/{header,init}.m4
93
94 # hack: AC_FUNC_STRERROR_R from strerror_r.m4 must override autoconf's version
95 # (it contains HAVE_WORKING_STRERROR_R define, needed with glibc 2.x, as
96 #  glibc version returns pointer to string and doesn't seem to store string in
97 #  supplied buffer(???))
98 cat m4/strerror_r.m4 >> acinclude.m4
99 touch m4/{header,init}.m4
100
101 # there is nb.po included, but more outdated than no.po (only no was in LINGUAS)
102 mv -f po/{no,nb}.po
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__automake}
108 %{__autoconf}
109 %ifarch sparc sparc64
110 CPPFLAGS=""
111 export CPPFLAGS
112 %endif
113 %configure \
114         %{!?with_pcre:--disable-perl-regexp} \
115         --without-included-regex \
116         --enable-nls
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT/etc/env.d
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
127 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
128
129 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
130
131 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
132 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
133 EOF
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
142
143 %postun
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc NEWS README ChangeLog TODO
149 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/*
150 %attr(755,root,root) %{_bindir}/*
151 %{_mandir}/man1/*
152 %lang(cs) %{_mandir}/cs/man1/*
153 %lang(de) %{_mandir}/de/man1/*
154 %lang(es) %{_mandir}/es/man1/*
155 %lang(fi) %{_mandir}/fi/man1/*
156 %lang(fr) %{_mandir}/fr/man1/*
157 %lang(hu) %{_mandir}/hu/man1/*
158 %lang(it) %{_mandir}/it/man1/*
159 %lang(ja) %{_mandir}/ja/man1/*
160 %lang(nl) %{_mandir}/nl/man1/*
161 %lang(pl) %{_mandir}/pl/man1/*
162 %{_infodir}/*info*
This page took 0.196293 seconds and 2 git commands to generate.