]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- rediffed
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # PCRE support
4 %bcond_without  tests   # don't perform "make check"
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        3.6
18 Release:        2
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        https://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.xz
23 # Source0-md5:  f47fe27049510b2249dba7f862ac1b51
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-pl.po-update.patch
28 Patch2:         disable-unstable-test.patch
29 URL:            http://www.gnu.org/software/grep/grep.html
30 BuildRequires:  autoconf >= 2.63
31 BuildRequires:  automake >= 1:1.11
32 BuildRequires:  gettext-tools >= 0.18.2
33 %{?with_pcre:BuildRequires:     pcre-devel}
34 BuildRequires:  pkgconfig >= 1:0.9.0
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  texinfo
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _bindir         /bin
41 %define         _exec_prefix    /
42
43 %description
44 The GNU versions of commonly used grep utilities. Grep searches one or
45 more input files for lines which contain a match to a specified
46 pattern and then prints the matching lines. GNU's grep utilities
47 include grep, egrep and fgrep.
48
49 %description -l de.UTF-8
50 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
51 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
52 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
53 enthält grep, egrep und fgrep.
54
55 %description -l es.UTF-8
56 Esta es la implementación GNU del popular utilitario grep. Permite la
57 localización rápida de strings en archivos texto.
58
59 %description -l fr.UTF-8
60 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
61 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
62 les fichiers.
63
64 %description -l ja.UTF-8
65 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
66 イトパッチ(mb1.04)によって日本語対応にしたものです.
67
68 %description -l pl.UTF-8
69 GNU grep jest implementacją popularnego programu uniksowego `grep'.
70 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
71 każdy skrypt shella.
72
73 %description -l pt_BR.UTF-8
74 Esta é a implementação GNU do popular utilitário grep. Permite a
75 localização rápida de strings em arquivos texto.
76
77 %description -l ru.UTF-8
78 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
79 по образцу в текстовых файлах.
80
81 %description -l tr.UTF-8
82 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
83 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
84 kullanılır.
85
86 %description -l uk.UTF-8
87 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
88 пошуку по шаблону в текстових файлах.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 %{__rm} po/stamp-po
97
98 %build
99 %{__gettextize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         %{!?with_pcre:--disable-perl-regexp} \
106         --disable-silent-rules \
107         --without-included-regex
108 %{__make}
109
110 %if %{with tests}
111 # mksh fails "unset columns" check (bash and pdksh are OK)
112 %{__make} -j1 check-expensive \
113         SHELL=/bin/bash
114 %endif
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/etc/shrc.d
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
124 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
125
126 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
127
128 cat << EOF >$RPM_BUILD_ROOT/etc/shrc.d/grep.sh
129 #alias grep='/bin/grep --devices=skip --directories=skip --color=auto'
130 EOF
131 cat << EOF >$RPM_BUILD_ROOT/etc/shrc.d/grep.csh
132 #alias grep '/bin/grep --devices=skip --directories=skip --color=auto'
133 EOF
134
135 %find_lang %{name}
136
137 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
138 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
139 %{__rm} $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post -p /sbin/postshell
145 -/usr/sbin/fix-info-dir -c %{_infodir}
146
147 %postun -p /sbin/postshell
148 -/usr/sbin/fix-info-dir -c %{_infodir}
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README THANKS TODO
153 %config(noreplace) %verify(not md5 mtime size) /etc/shrc.d/grep.*sh
154 %attr(755,root,root) %{_bindir}/egrep
155 %attr(755,root,root) %{_bindir}/fgrep
156 %attr(755,root,root) %{_bindir}/grep
157 %{_mandir}/man1/egrep.1*
158 %{_mandir}/man1/fgrep.1*
159 %{_mandir}/man1/grep.1*
160 %lang(cs) %{_mandir}/cs/man1/*
161 %lang(de) %{_mandir}/de/man1/*
162 %lang(es) %{_mandir}/es/man1/*
163 %lang(fi) %{_mandir}/fi/man1/*
164 %lang(fr) %{_mandir}/fr/man1/*
165 %lang(hu) %{_mandir}/hu/man1/*
166 %lang(it) %{_mandir}/it/man1/*
167 %lang(ja) %{_mandir}/ja/man1/*
168 %lang(nl) %{_mandir}/nl/man1/*
169 %lang(pl) %{_mandir}/pl/man1/*
170 %{_infodir}/grep.info*
This page took 0.077886 seconds and 3 git commands to generate.