]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- updated to 2.5.1a (bugreport and maintainer address update, tarball cleanup)
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_with     pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de):    GNU-Version der Pattern-Matching-Utilities
7 Summary(es):    Utilitarios grep GNU
8 Summary(fr):    Utilitaires grep de GNU
9 Summary(ja):    GNU grep ¤ÎÆüËܸìÂбþÈǤǤ¹.
10 Summary(pl):    GNU grep
11 Summary(pt_BR): Utilitários grep GNU
12 Summary(ru):    õÔÉÌÉÔÙ ÐÏÉÓËÁ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
13 Summary(tr):    Dosyalarda katar arama aracý
14 Summary(uk):    õÔÉ̦ÔÉ ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
15 Name:           grep
16 Version:        2.5.1a
17 Release:        1
18 Epoch:          2
19 License:        GPL
20 Group:          Applications/Text
21 Source0:        ftp://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  71db1cb262c27f02461c4bca514591ce
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-egrep.patch
27 Patch2:         %{name}-locale-names.patch
28 URL:            http://www.gnu.org/software/grep/grep.html
29 %{?with_pcre:BuildRequires:     pcre-devel}
30 BuildRequires:  gettext-devel
31 BuildRequires:  automake
32 BuildRequires:  autoconf
33 BuildRequires:  libtool
34 %{?with_pcre:Requires:  pcre}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _bindir         /bin
38 %define         _exec_prefix    /
39
40 %description
41 The GNU versions of commonly used grep utilities. Grep searches one or
42 more input files for lines which contain a match to a specified
43 pattern and then prints the matching lines. GNU's grep utilities
44 include grep, egrep and fgrep.
45
46 %description -l de
47 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
48 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
49 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
50 enthält grep, egrep und fgrep.
51
52 %description -l es
53 Esta es la implementación GNU del popular utilitario grep. Permite la
54 localización rápida de strings en archivos texto.
55
56 %description -l fr
57 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
58 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
59 les fichiers.
60
61 %description -l ja
62 GNU ¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë grep, egrep, fgrep (°Ê²¼Ã±¤Ë grep) ¤ò¥Þ¥ë¥Á¥Ð
63 ¥¤¥È¥Ñ¥Ã¥Á(mb1.04)¤Ë¤è¤Ã¤ÆÆüËܸìÂбþ¤Ë¤·¤¿¤â¤Î¤Ç¤¹.
64
65 %description -l pl
66 GNU grep jest implementacj± popularnego programu uniksowego `grep'.
67 Grep jest jednym z podstawowych narzêdzi, korzysta z niego prawie
68 ka¿dy skrypt shella.
69
70 %description -l pt_BR
71 Esta é a implementação GNU do popular utilitário grep. Permite a
72 localização rápida de strings em arquivos texto.
73
74 %description -l ru
75 üÔÏ ÒÅÁÌÉÚÁÃÉÑ GNU ÕÔÉÌÉÔÙ grep, ÐÒÅÄÎÁÚÎÁÞÅÎÎÏÊ ÄÌÑ ÂÙÓÔÒÏÇÏ ÐÏÉÓËÁ
76 ÐÏ ÏÂÒÁÚÃÕ × ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÁÈ.
77
78 %description -l tr
79 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn
80 GNU sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada
81 kullanýlýr.
82
83 %description -l uk
84 ãÅ GNU ÒÅÁ̦ÚÁæѠÐÏÐÕÌÑÒÎϧ ÕÔÉ̦ÔÉ grep, ÐÒÉÚÎÁÞÅÎϧ ÄÌÑ Û×ÉÄËÏÇÏ
85 ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÕ × ÔÅËÓÔÏ×ÉÈ ÆÁÊÌÁÈ.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 rm -f m4/{header,init}.m4
94
95 # hack: AC_FUNC_STRERROR_R from strerror_r.m4 must override autoconf's version
96 # (it contains HAVE_WORKING_STRERROR_R define, needed with glibc 2.x, as
97 #  glibc version returns pointer to string and doesn't seem to store string in
98 #  supplied buffer(???))
99 cat m4/strerror_r.m4 >> acinclude.m4
100 touch m4/{header,init}.m4
101
102 # there is nb.po included, but more outdated than no.po (only no was in LINGUAS)
103 mv -f po/{no,nb}.po
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__automake}
109 %{__autoconf}
110 %ifarch sparc sparc64
111 CPPFLAGS=""
112 export CPPFLAGS
113 %endif
114 %configure \
115         %{!?with_pcre:--disable-perl-regexp} \
116         --without-included-regex \
117         --enable-nls
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT/etc/env.d
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
128 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
129
130 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
131
132 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
133 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
134 EOF
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
143
144 %postun
145 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc NEWS README ChangeLog TODO
150 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/*
151 %attr(755,root,root) %{_bindir}/*
152 %{_mandir}/man1/*
153 %lang(cs) %{_mandir}/cs/man1/*
154 %lang(de) %{_mandir}/de/man1/*
155 %lang(es) %{_mandir}/es/man1/*
156 %lang(fi) %{_mandir}/fi/man1/*
157 %lang(fr) %{_mandir}/fr/man1/*
158 %lang(hu) %{_mandir}/hu/man1/*
159 %lang(it) %{_mandir}/it/man1/*
160 %lang(ja) %{_mandir}/ja/man1/*
161 %lang(nl) %{_mandir}/nl/man1/*
162 %lang(pl) %{_mandir}/pl/man1/*
163 %{_infodir}/*info*
This page took 0.540063 seconds and 3 git commands to generate.