]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
- first attempt to install the beast :-\
[packages/grass.git] / grass.spec
1
2 #
3 # todo:
4 # 1. Manuals conflicts with ImageMagick 
5 # file /usr/X11R6/man/man1/display.1.gz from install of grass-5.0.0pre3-1
6 #   conflicts with file from package ImageMagick-5.4.4-1
7 # file /usr/X11R6/man/man1/import.1.gz from install of grass-5.0.0pre3-1
8 #   conflicts with file from package ImageMagick-5.4.4-1
9 #
10 # 2. see %install section :-\
11 #
12
13 Summary:        The Geographic Resources Analysis Support System
14 Summary(pl):    System obs³uguj±cy analizê zasobów geograficznych
15 Name:           grass
16 Version:        5.0.0pre3
17 Release:        1
18 License:        GPL
19 Group:          X11/Applications
20 Source0:        http://grass.itc.it/grass5/source/%{name}%{version}.tar.gz
21 URL:            http://grass.itc.it/
22 BuildRequires:  blas-devel
23 #BuildRequires: gdal-devel
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  fftw-devel
26 BuildRequires:  freetype-devel
27 BuildRequires:  gd-devel
28 BuildRequires:  gdbm-devel
29 BuildRequires:  lapack-devel
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libtiff-devel
33 BuildRequires:  motif-devel
34 BuildRequires:  postgresql-backend-devel
35 BuildRequires:  postgresql-devel
36 BuildRequires:  tcl-devel
37 BuildRequires:  tk-devel
38 BuildRequires:  unixODBC-devel
39 BuildRequires:  zlib-devel
40 BuildRequires:  gcc-g77
41 BuildRequires:  flex
42 BuildRequires:  bison
43 BuildRequires:  ncurses-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49 %define         _sysconfdir     /etc/X11
50
51 %description
52 GRASS (the Geographic Resources Analysis Support System) is a software
53 raster- and vector-based GIS (Geographic Information System), image
54 processing system, graphics production system, and spatial modeling
55 system. GRASS contains many modules for raster data manipulation,
56 vector data manipulation, rendering images on the monitor or paper,
57 multispectral image processing, point data management and general data
58 management. It also has tools for interfacing with digitizers,
59 scanners, and the RIM, Informix, Postgres, and Oracle databases.
60
61 %description -l pl
62 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
63 oraz wektorowym systemem GIS (System Informacji Geograficznej),
64 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
65 GRASS zawiera wiele modu³ów wspomagaj±cych manipulacjê danymi
66 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
67 papierze, obróbkê multispektralnych obrazów, punktowe oraz ogólne
68 zarz±dzanie danymi. Zawiera równie¿ narzêdzia do wspó³pracy z
69 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
70 Oracle.
71
72 %package OpenGL
73 Summary:        NVIZ - a 3D-tool for GRASS
74 Summary(pl):    NVIZ - narzêdzie 3D dla GRASSa
75 Group:          X11/Applications
76 Requires:       %{name} = %{version}
77
78 %description OpenGL
79 Package contains nviz, which is a GRASS module-in-progress which
80 allows users to realistically render multiple surfaces in a 3D space,
81 optionally using thematic coloring, draping GRASS vector files over
82 the surfaces, and displaying GRASS site files either draped on the
83 surfaces or as 3D point locations.
84
85 %description OpenGL -l pl
86 Pakiet zawiera modu³ nviz, który rozszerza funkcjonalno¶æ systemu
87 GRASS o mo¿liwo¶æ realistycznego renderowania wielu powierzchni w
88 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
89 mog± byæ tematycznie kolorowane, mo¿na zawieszaæ pliki wektorowe
90 GRASSa.
91
92 %package pg
93 Summary:        PostgreSQL database interface
94 Summary(pl):    Interfejs do bazy PostgreSQL
95 Group:          X11/Applications
96 Requires:       %{name} = %{version}
97
98 %description pg
99 PostgreSQL database interface for GRASS.
100
101 %dewscription pg -l pl
102 Interfejs do bazy PostgreSQL dla GRASSa.
103
104 %package odbc
105 Summary:        ODBC database interface
106 Summary(pl):    Interfejs ODBC dla GRASSa
107 Group:          X11/Applications
108 Requires:       %{name} = %{version}
109
110 %description odbc
111 ODBC database interface for GRASS.
112
113 %description odbc -l pl
114 Interfejs ODBC dla GRASSa.
115
116 %package devel
117 Summary:        Header files for GRASS
118 Summary(pl):    Pliki nag³ówkowe systemu GRASS
119 Group:          X11/Development/Libraries
120 Requires:       %{name} = %{version}
121
122 %description devel 
123 Header files for GRASS.
124
125 %description devel -l pl
126 Pliki nag³ówkowe systemu GRASS.
127
128 %package static
129 Summary:        GRASS static libraries
130 Summary(pl):    Biblioteki statyczne systemu GRASS
131 Group:          X11/Development/Libraries
132 Requires:       %{name} = %{version}
133
134 %description static 
135 GRASS static libraries.
136
137 %description static -l pl
138 Biblioteki statyczne systemu GRASS.
139
140 %prep
141 %setup -q -n %{name}%{version}
142
143 %build
144 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
145         CPPFLAGS="`pkg-config libpng12 --cflags`"; export CPPFLAGS
146 fi
147 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"; export CFLAGS
148 %configure2_13 \
149         --with-lapack \
150         --with-motif \
151         --with-freetype \
152         --with-includes=%{_includedir} \
153         --with-libs=%{_libdir} \
154         --with-postgres-includes=/usr/include/postgresql/server \
155         --with-freetype-includes=/usr/include/freetype2
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_includedir}/grass5,%{_libdir}/grass5}
162
163 cd dist.%{_host}
164
165 # bin: there are many binaries with the same content, i.e. d.*, i.* -
166 #      create symlinks instead of binaries?
167 # etc: it is a big mess; do not move the content of "etc" dir to /etc
168 # txt: move to %docdir?
169 # tcltkgrass: separate package?
170 # bwidget: move to devel or separate package?
171 # dev: move the content to /dev or leave it as below?
172 cp -a bin bwidget etc dev driver fonts scripts tcltkgrass txt $RPM_BUILD_ROOT%{_libdir}/grass5
173
174 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
175 install lib/* $RPM_BUILD_ROOT%{_libdir}
176 install include/* $RPM_BUILD_ROOT%{_includedir}/grass5
177
178 cd ..
179
180 gzip -9nf AUTHORS BUGS COPYING NEWS.html ONGOING TODO.txt documents/*.*
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %files
186 %defattr(644,root,root,755)
187 %doc *.gz */*.gz
188 %dir %{_libdir}/grass5
189 %dir %{_libdir}/grass5/bin
190 %attr(755,root,root) %{_libdir}/grass5/bin/*
191 %{_libdir}/grass5/bwidget
192 %{_libdir}/grass5/etc
193 %{_libdir}/grass5/dev
194 %{_libdir}/grass5/driver
195 %{_libdir}/grass5/fonts
196 %{_libdir}/grass5/scripts
197 %{_libdir}/grass5/tcltkgrass
198 %{_libdir}/grass5/txt
199 %{_mandir}/man1/*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %{_includedir}/grass5
204
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/*.a
This page took 0.07667 seconds and 3 git commands to generate.