]> git.pld-linux.org Git - packages/graphene.git/blob - graphene.spec
- updated to 1.8.2
[packages/graphene.git] / graphene.spec
1 # NOTE: despite some comments in configure, SSE2 is not selected at runtime;
2 # SSE2 option seems to change the ABI of library
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 %bcond_without  introspection   # gobject introspection
7 %bcond_with     sse2            # x86 SSE2 fast paths
8 %bcond_without  armneon         # ARM NEON fast paths
9
10 %ifarch pentium4 %{x8664}
11 %define with_sse2       1
12 %endif
13 Summary:        Graphene - a thin layer of types for graphic libraries
14 Summary(pl.UTF-8):      Graphene - cienka warstwa typów dla bibliotek graficznych
15 Name:           graphene
16 Version:        1.8.2
17 Release:        1
18 License:        MIT
19 Group:          Libraries
20 Source0:        http://ftp.gnome.org/pub/GNOME/sources/graphene/1.8/%{name}-%{version}.tar.xz
21 # Source0-md5:  87e023dcf748da9fb83bed4f18f6a8e6
22 Patch0:         %{name}-gir.patch
23 URL:            https://github.com/ebassi/graphene
24 BuildRequires:  gcc >= 5:3.2
25 %if %{with sse2}
26 BuildRequires:  gcc >= 6:4.9
27 %endif
28 BuildRequires:  glib2-devel >= 1:2.40.0
29 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.41.0}
30 BuildRequires:  gtk-doc >= 1.20
31 BuildRequires:  meson >= 0.43.1
32 BuildRequires:  ninja
33 BuildRequires:  pkgconfig
34 %{?with_introspection:BuildRequires:    python3 >= 1:3}
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       glib2 >= 1:2.40.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Graphene provides a small set of mathematical types needed to
42 implement graphic libraries that deal with 2D and 3D transformations
43 and projections.
44
45 %description -l pl.UTF-8
46 Graphene udostępnia mały zestaw typów matematycznych potrzebnych przy
47 implementowaniu bibliotek graficznych wykonujących przekształcenia i
48 rzuty 2D oraz 3D.
49
50 %package devel
51 Summary:        Header files for Graphene library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Graphene
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       glib2-devel >= 1:2.40.0
56
57 %description devel
58 Header files for Graphene library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki Graphene.
62
63 %package static
64 Summary:        Static Graphene library
65 Summary(pl.UTF-8):      Statyczna biblioteka Graphene
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static Graphene library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka Graphene.
74
75 %package apidocs
76 Summary:        API documentation for Graphene library
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki Graphene
78 Group:          Documentation
79 %if "%{_rpmversion}" >= "5"
80 BuildArch:      noarch
81 %endif
82
83 %description apidocs
84 API documentation for Graphene library.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki Graphene.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92
93 %build
94 %meson build \
95         %{!?with_armneon:-Darm_neon=false} \
96         -Dgtk_doc=true \
97         %{!?with_introspection:-Dintrospection=false} \
98         %{!?with_sse2:-Dsse2=false} \
99         -Dtests=false
100
101 %meson_build -C build
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %meson_install -C build
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc LICENSE README.md
117 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libgraphene-1.0.so.0
119 %if %{with introspection}
120 %{_libdir}/girepository-1.0/Graphene-1.0.typelib
121 %endif
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libgraphene-1.0.so
126 %{_includedir}/graphene-1.0
127 %dir %{_libdir}/graphene-1.0
128 %{_libdir}/graphene-1.0/include
129 %if %{with introspection}
130 %{_datadir}/gir-1.0/Graphene-1.0.gir
131 %endif
132 %{_pkgconfigdir}/graphene-1.0.pc
133 %{_pkgconfigdir}/graphene-gobject-1.0.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libgraphene-1.0.a
139 %endif
140
141 %files apidocs
142 %defattr(644,root,root,755)
143 %{_gtkdocdir}/graphene
This page took 0.09166 seconds and 4 git commands to generate.