]> git.pld-linux.org Git - packages/grantlee-qt5.git/blob - grantlee.spec
- release 2 (by relup.sh)
[packages/grantlee-qt5.git] / grantlee.spec
1 %define         qt_ver          4.7.1
2 %define         major_ver       0.5
3
4 Summary:        Grantlee - set of frameworks for use with Qt
5 Summary(pl.UTF-8):      Grantlee - zbiór szkieletów do wykorzystania z Qt
6 Name:           grantlee
7 Version:        0.5.1
8 Release:        2
9 License:        LGPL v2.1+
10 Group:          Libraries
11 Source0:        http://downloads.grantlee.org/%{name}-%{version}.tar.gz
12 # Source0-md5:  775f22dac0953029b414ed3b7379098c
13 Patch0:         %{name}-link.patch
14 URL:            http://www.gitorious.org/grantlee/pages/Home
15 BuildRequires:  QtCore-devel >= %{qt_ver}
16 BuildRequires:  QtGui-devel >= %{qt_ver}
17 BuildRequires:  QtScript-devel >= %{qt_ver}
18 BuildRequires:  QtSql-devel >= %{qt_ver}
19 BuildRequires:  QtTest-devel >= %{qt_ver}
20 BuildRequires:  QtWebKit-devel >= %{qt_ver}
21 BuildRequires:  cmake >= 2.8.11
22 BuildRequires:  qt4-build >= %{qt_ver}
23 BuildRequires:  qt4-qmake >= %{qt_ver}
24 BuildRequires:  qt4-linguist >= %{qt_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         filterout       -flto
29
30 %description
31 Grantlee is a string template engine based on the Django template
32 system and written using Qt.
33
34 %description -l pl.UTF-8
35 Grantlee to silnik szablonów oparty na systemie szablonów Django i
36 napisany przy użyciu Qt.
37
38 %package devel
39 Summary:        Header files for grantlee libraries
40 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek grantlee
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       QtCore-devel >= %{qt_ver}
44 # only _gui (textdocument) library
45 Requires:       QtGui-devel >= %{qt_ver}
46
47 %description devel
48 Header files for grantlee libraries.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe bibliotek grantlee.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56
57 %build
58 install -d build
59 cd build
60 %cmake ..
61
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc AUTHORS CHANGELOG README
79 %attr(755,root,root) %{_libdir}/libgrantlee_core.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_core.so.0
81 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so.*.*.*
82 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_gui.so.0
83 %dir %{_libdir}/grantlee
84 %dir %{_libdir}/grantlee/%{major_ver}
85 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaultfilters.so
86 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaulttags.so
87 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_i18ntags.so
88 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_loadertags.so
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libgrantlee_core.so
93 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so
94 %{_includedir}/grantlee_core.h
95 %{_includedir}/grantlee_templates.h
96 %{_includedir}/grantlee_textdocument.h
97 %{_includedir}/grantlee
98 %{_libdir}/cmake/grantlee
This page took 0.253417 seconds and 3 git commands to generate.