]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- up to 1.0.1 auto/th/gpac-1.0.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Oct 2021 21:03:17 +0000 (23:03 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Oct 2021 21:03:17 +0000 (23:03 +0200)
dont-err-build-on-uknown-system.patch [deleted file]
ffmpeg3.patch [deleted file]
gpac-apps.patch [deleted file]
gpac-cxx.patch [deleted file]
gpac-flags.patch [deleted file]
gpac-install-is-not-clean.patch
gpac-install.patch [deleted file]
gpac.spec
wxWidgets3.patch [deleted file]

diff --git a/dont-err-build-on-uknown-system.patch b/dont-err-build-on-uknown-system.patch
deleted file mode 100644 (file)
index 2d57c36..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: Don't fail build intentionally on unknown systems
-Author: Balint Reczey <balint@balintreczey.hu>
-
-diff --git a/include/gpac/configuration.h b/include/gpac/configuration.h
-index 2c58fc3..70dcafc 100644
---- a/include/gpac/configuration.h
-+++ b/include/gpac/configuration.h
-@@ -147,8 +147,8 @@
- #define GPAC_HAS_JPEG
- #define GPAC_HAS_PNG
--#else
--#error "Unknown target platform used with static configuration file"
-+//#else
-+//#error "Unknown target platform used with static configuration file"
- #endif
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
deleted file mode 100644 (file)
index 9131610..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
---- gpac/applications/dashcast/video_encoder.c~        2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/video_encoder.c 2016-03-23 08:34:30.284438268 +0100
-@@ -87,7 +87,7 @@
-               video_output_file->codec_ctx->time_base.den = video_data_conf->time_base.den;
-               video_output_file->codec_ctx->time_base.num = video_data_conf->time_base.num * video_data_conf->time_base.den / video_data_conf->framerate;
-       }
--      video_output_file->codec_ctx->pix_fmt = PIX_FMT_YUV420P;
-+      video_output_file->codec_ctx->pix_fmt = AV_PIX_FMT_YUV420P;
-       video_output_file->codec_ctx->gop_size = video_data_conf->framerate;
- //    video_output_file->codec_ctx->codec_id = video_codec->id;
---- gpac/applications/dashcast/video_muxer.c~  2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/video_muxer.c   2016-03-23 08:35:04.941564779 +0100
-@@ -642,7 +642,7 @@
-       video_stream->codec->time_base = video_codec_ctx->time_base;
--      video_stream->codec->pix_fmt = PIX_FMT_YUV420P;
-+      video_stream->codec->pix_fmt = AV_PIX_FMT_YUV420P;
-       video_stream->codec->gop_size = video_codec_ctx->time_base.den; //video_output_file->video_data_conf->framerate;
-       av_opt_set(video_stream->codec->priv_data, "preset", "ultrafast", 0);
---- gpac/applications/dashcast/video_scaler.c~ 2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/video_scaler.c  2016-03-23 08:35:29.971877188 +0100
-@@ -125,7 +125,7 @@
-       dc_consumer_init(&video_scaled_data->consumer, video_cb_size, name);
-       video_scaled_data->num_producers = max_source;
--      video_scaled_data->out_pix_fmt = PIX_FMT_YUV420P;
-+      video_scaled_data->out_pix_fmt = AV_PIX_FMT_YUV420P;
-       GF_SAFE_ALLOC_N(video_scaled_data->vsprop, max_source, VideoScaledProp);
-       memset(video_scaled_data->vsprop, 0, max_source * sizeof(VideoScaledProp));
-@@ -189,7 +189,7 @@
-               video_scaled_data_node->cropped_frame->width  = video_input_data->vprop[index].width  - video_input_data->vprop[index].crop_x;
-               video_scaled_data_node->cropped_frame->height = video_input_data->vprop[index].height - video_input_data->vprop[index].crop_y;
- #endif
--              if (av_picture_crop((AVPicture*)video_scaled_data_node->cropped_frame, (AVPicture*)video_data_node->vframe, PIX_FMT_YUV420P, video_input_data->vprop[index].crop_y, video_input_data->vprop[index].crop_x) < 0) {
-+              if (av_picture_crop((AVPicture*)video_scaled_data_node->cropped_frame, (AVPicture*)video_data_node->vframe, AV_PIX_FMT_YUV420P, video_input_data->vprop[index].crop_y, video_input_data->vprop[index].crop_x) < 0) {
-                       GF_LOG(GF_LOG_ERROR, GF_LOG_DASH, ("Video scaler: error while cropping picture.\n"));
-                       return -1;
-               }
---- gpac/applications/dashcast/audio_decoder.c~        2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/audio_decoder.c 2016-03-23 08:37:24.863173759 +0100
-@@ -204,7 +204,7 @@
-                       packet.data = NULL;
-                       packet.size = 0;
--#ifndef FF_API_AVFRAME_LAVC
-+#if 0
-                       avcodec_get_frame_defaults(audio_input_data->aframe);
- #else
-                       av_frame_unref(audio_input_data->aframe);
-@@ -239,7 +239,7 @@
-               if (packet.stream_index == audio_input_file->astream_idx) {
-                       /* Set audio frame to default */
--#ifndef FF_API_AVFRAME_LAVC
-+#if 0
-                       avcodec_get_frame_defaults(audio_input_data->aframe);
- #else
-                       av_frame_unref(audio_input_data->aframe);
---- gpac/applications/dashcast/audio_encoder.c~        2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/audio_encoder.c 2016-03-23 08:37:37.899978004 +0100
-@@ -84,7 +84,7 @@
-       audio_output_file->frame_bytes = audio_output_file->codec_ctx->frame_size * av_get_bytes_per_sample(DC_AUDIO_SAMPLE_FORMAT) * DC_AUDIO_NUM_CHANNELS;
--#ifndef FF_API_AVFRAME_LAVC
-+#if 0
-       avcodec_get_frame_defaults(audio_output_file->aframe);
- #else
-       av_frame_unref(audio_output_file->aframe);
---- gpac/applications/dashcast/video_decoder.c~        2014-10-07 23:10:04.000000000 +0200
-+++ gpac/applications/dashcast/video_decoder.c 2016-03-23 08:38:02.470233825 +0100
-@@ -244,7 +244,7 @@
-                       video_data_node->source_number = source_number;
-                       /* Flush decoder */
-                       memset(&packet, 0, sizeof(AVPacket));
--#ifndef FF_API_AVFRAME_LAVC
-+#if 0
-                       avcodec_get_frame_defaults(video_data_node->vframe);
- #else
-                       av_frame_unref(video_data_node->vframe);
-@@ -283,7 +283,7 @@
-                       video_data_node->source_number = source_number;
-                       /* Set video frame to default */
--#ifndef FF_API_AVFRAME_LAVC
-+#if 0
-                       avcodec_get_frame_defaults(video_data_node->vframe);
- #else
-                       av_frame_unref(video_data_node->vframe);
diff --git a/gpac-apps.patch b/gpac-apps.patch
deleted file mode 100644 (file)
index 47bc2e4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -urNp -x '*.orig' gpac-0.8.0.org/applications/Makefile gpac-0.8.0/applications/Makefile
---- gpac-0.8.0.org/applications/Makefile       2019-06-27 12:20:45.000000000 +0200
-+++ gpac-0.8.0/applications/Makefile   2021-03-13 09:23:01.300056818 +0100
-@@ -33,15 +33,15 @@ V4STUDIODIR=
- INSTDIRS=mp4client
- ifeq ($(CONFIG_XUL),no)
- else
--#INSTDIRS+=osmozilla
--#APPDIRS+=osmozilla
-+INSTDIRS+=osmozilla
-+APPDIRS+=osmozilla
- endif
- #disable due to version incompatibilities
- ifeq ($(USE_WXWIDGETS), yes)
--#APPDIRS+=osmo4_wx
-+APPDIRS+=osmo4_wx
- #V4STUDIODIR=V4Studio
--#INSTDIRS+=osmo4_wx
-+INSTDIRS+=osmo4_wx
- endif
- #MP4BOX_STATIC
diff --git a/gpac-cxx.patch b/gpac-cxx.patch
deleted file mode 100644 (file)
index e5dab21..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
---- gpac-0.8.0/configure.orig  2020-03-14 20:22:30.223421888 +0100
-+++ gpac-0.8.0/configure       2020-03-15 14:04:05.355022427 +0100
-@@ -698,7 +698,7 @@
- docxx() {
-- $cc -o $TMPO $TMPC $@ 0>/dev/null 2>$TMPL
-+ $cxx -o $TMPO $TMPC $@ 0>/dev/null 2>$TMPL
-  dolog $@
- }
-@@ -1024,7 +1024,7 @@
- #include <Platinum.h>
- int main( void ) { return 0; }
- EOF
--if docxx -o $TMPO $TMPC -I$local_inc/platinum $LDFLAGS -L$local_lib -lPlatinum -lPltMediaServer -lPltMediaConnect -lPltMediaRenderer -lNeptune -lZlib -lpthread ; then
-+if docxx -I$local_inc/platinum $LDFLAGS -L$local_lib -lPlatinum -lPltMediaServer -lPltMediaConnect -lPltMediaRenderer -lNeptune -lZlib -lpthread ; then
-   has_platinum="yes"
- fi
-@@ -1046,7 +1046,7 @@
-   return 0;
- }
- EOF
--if docxx -o $TMPO $TMPC $LDFLAGS $avcap_cflags $avcap_ldflags ; then
-+if docxx $LDFLAGS $avcap_cflags $avcap_ldflags ; then
-   has_avcap="yes"
- else
-     if test "$darwin" = "yes" ; then
-@@ -1056,7 +1056,7 @@
-         avcap_cflags="-I$local_inc -I$local_inc/avcap/linux"
-         avcap_ldflags="-lavcap -lpthread"
-     fi
--    if docxx -o $TMPO $TMPC $avcap_cflags $LDFLAGS -L$local_lib $avcap_ldflags ; then
-+    if docxx $avcap_cflags $LDFLAGS -L$local_lib $avcap_ldflags ; then
-         has_avcap="yes"
-         avcap_ldflags="-L$local_lib $avcap_ldflags"
-     fi
-@@ -2325,7 +2325,7 @@
- if test "$pkg_config" != "no"; then
-   if test "$has_xul" = "no" ; then
-     if $pkg_config --exists libxul 2>>$logs ; then
--        if docxx -o $TMPO $TMPCXX `$pkg_config --cflags libxul` `$pkg_config --libs libxul` ; then
-+        if docxx `$pkg_config --cflags libxul` `$pkg_config --libs libxul` ; then
-             has_xul="system"
-             xul_flags="`$pkg_config --cflags libxul` `$pkg_config --libs libxul`"
-         fi
diff --git a/gpac-flags.patch b/gpac-flags.patch
deleted file mode 100644 (file)
index 1071b73..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- gpac-0.7.1/applications/osmo4_wx/Makefile~ 2018-09-17 12:18:34.000000000 +0200
-+++ gpac-0.7.1/applications/osmo4_wx/Makefile  2018-09-17 12:19:25.217933596 +0200
-@@ -46,7 +46,7 @@ SRCS := $(OBJS:.o=.cpp)
- all: $(PROG)
- Osmo4$(EXE): $(OBJS)
--      $(CC) -o ../../bin/gcc/$@ $(OBJS) -L../../bin/gcc -lgpac $(WX_LFLAGS) $(LINKFLAGS) $(LDFLAGS)
-+      $(CC) -o ../../bin/gcc/$@ $(OBJS) -L../../bin/gcc -lgpac $(WX_LFLAGS) `pkg-config --libs gtk+-2.0` -lstdc++ $(LINKFLAGS) $(LDFLAGS)
- clean: 
-       rm -f $(OBJS) ../../bin/gcc/$(PROG)
---- gpac-0.7.1/modules/jack/Makefile~  2017-04-26 13:33:17.000000000 +0200
-+++ gpac-0.7.1/modules/jack/Makefile   2018-09-17 12:20:29.753236206 +0200
-@@ -25,7 +25,7 @@ LIB=gm_jack$(DYN_LIB_SUFFIX)
- all: $(LIB)
- $(LIB): $(OBJS)
--      $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -L/usr/lib  -ljack
-+      $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -ljack
- clean: 
-       rm -f $(OBJS) ../../bin/gcc/$(LIB)
index 81bca57c41d8a5ca4d496eccca284989aa630936..aed276d06958f1b454ec8b871ef9148f0ec8d5a9 100644 (file)
@@ -1,17 +1,7 @@
---- gpac/applications/osmo4_wx/Makefile.orig   2011-10-21 14:41:56.000000000 +0200
-+++ gpac/applications/osmo4_wx/Makefile        2012-06-15 20:20:49.688455299 +0200
-@@ -67,7 +67,6 @@
-             $(DESTDIR)$(mac_apps)/Osmo4.app/Contents/MacOS
-       echo -n 'APPLOsm4' > $(DESTDIR)$(mac_apps)/Osmo4.app/Contents/PkgInfo
- else
--      rm -f wxOsmo4.o
-       mkdir -p $(DESTDIR)$(prefix)/bin
-       install -m 755 $(INSTFLAGS) ../../bin/gcc/Osmo4 "$(DESTDIR)$(prefix)/bin"
- endif
---- gpac/applications/mp4client/Makefile.orig  2011-05-20 19:11:05.000000000 +0200
-+++ gpac/applications/mp4client/Makefile       2012-06-15 20:20:27.218456243 +0200
-@@ -44,7 +44,7 @@
- clean: 
+--- gpac-1.0.1/applications/mp4client/Makefile~        2020-09-10 18:38:49.000000000 +0200
++++ gpac-1.0.1/applications/mp4client/Makefile 2021-10-24 22:39:03.166080322 +0200
+@@ -66,7 +66,7 @@
+ clean:
        rm -f $(OBJS) ../../bin/gcc/$(PROG)
  
 -install: clean
diff --git a/gpac-install.patch b/gpac-install.patch
deleted file mode 100644 (file)
index 1b846b9..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- gpac-0.7.1/applications/osmozilla/Makefile~        2017-04-26 13:33:17.000000000 +0200
-+++ gpac-0.7.1/applications/osmozilla/Makefile 2018-09-17 13:57:38.870996859 +0200
-@@ -6,10 +6,6 @@ ifeq ($(CONFIG_WIN32),yes)
- USER_NAME=root
- else
- USER_NAME=$(shell whoami)
--ifeq ($(USER_NAME), root)
--else
--MOZILLA_DIR=local
--endif
- endif
- CFLAGS=$(CXXFLAGS) $(XUL_CFLAGS) -I"$(SRC_PATH)/include"
-@@ -72,19 +68,8 @@ ifeq ($(CONFIG_WIN32),yes)
- endif
- install: 
--ifeq ($(MOZILLA_DIR), local)
--ifeq ($(USER_NAME), root)
--      @echo "*** Root cannot install local mozilla plugins! ***"
--      @echo "*** Exit root mode and reinstall mozilla plugin! ***"
--else
--      $(MAKE) $(LIB)
--      $(INSTALL) -D -m 755 ../../bin/gcc/$(LIB) "$(HOME)/.mozilla/plugins/$(LIB)"
--      $(INSTALL) -D -m 755 ../../bin/gcc/nposmozilla.xpt "$(HOME)/.mozilla/components/nposmozilla.xpt"
--endif
--else
-       $(INSTALL) -D -m 755 ../../bin/gcc/$(LIB) "$(MOZILLA_DIR)/components/$(LIB)"
-       $(INSTALL) -D -m 755 ../../bin/gcc/nposmozilla.xpt "$(MOZILLA_DIR)/components/nposmozilla.xpt"
--endif
- uninstall:
- ifeq ($(MOZILLA_DIR), local)
index fd8e9cb7648285c0e36c7f8af9a9fa18182948ab..443c3532b8317d65855d7f9a8bea8677545b4790 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
@@ -16,7 +16,6 @@
 %bcond_without mad             # MP3 support
 %bcond_without png             # PNG support
 %bcond_without xvid            # xvid support
-%bcond_without wx              # wxWidgets support
 %bcond_with    mozilla         # Mozilla (xulrunner/firefox/iceweasel, NPAPI+XPCOM based) plugin
 #
 %ifarch x32
 Summary:       GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
 Summary(pl.UTF-8):     GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
-Version:       0.8.0
-Release:       3
+Version:       1.0.1
+Release:       1
 License:       LGPL v2+
 Group:         Applications/Multimedia
 #Source0Download: https://github.com/gpac/gpac/releases
 Source0:       https://github.com/gpac/gpac/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 06ecb86b4da83e2d38e108f513c2ed8a
-Patch0:                %{name}-install.patch
-Patch1:                %{name}-cxx.patch
-
-Patch3:                %{name}-install-is-not-clean.patch
-Patch4:                %{name}-flags.patch
-Patch5:                wxWidgets3.patch
-
-Patch7:                %{name}-apps.patch
-Patch8:                ffmpeg3.patch
-Patch11:       dont-err-build-on-uknown-system.patch
+# Source0-md5: 52f6711e43a8d271ebec0c2ea2afab4a
+Patch0:                %{name}-install-is-not-clean.patch
 URL:           http://www.gpac.io/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -55,7 +45,6 @@ BuildRequires:        alsa-lib-devel >= 0.9
 %{?with_faad:BuildRequires:    faad2-devel}
 %{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.6}
 %{?with_freetype:BuildRequires:        freetype-devel}
-%{?with_wx:BuildRequires:      gtk+2-devel >= 2:2.20.1}
 BuildRequires: jack-audio-connection-kit-devel
 %{?with_js:BuildRequires:      js-devel < 2:1.8.5}
 %{?with_freenect:BuildRequires:        libfreenect-devel}
@@ -66,14 +55,13 @@ BuildRequires:      libogg-devel
 BuildRequires: libtheora-devel
 BuildRequires: libvorbis-devel
 BuildRequires: libxml2-devel
-BuildRequires: openjpeg-devel >= 1.5
+BuildRequires: openjpeg2-devel
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
 BuildRequires: rpmbuild(macros) >= 1.357
 BuildRequires: sed >= 4.0
 BuildRequires: unzip
-%{?with_wx:BuildRequires:      wxGTK2-unicode-devel >= 2.6.0}
 BuildRequires: xmlrpc-c-server-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXv-devel
@@ -81,6 +69,7 @@ BuildRequires:        xorg-lib-libXv-devel
 %{?with_xvid:BuildRequires:    xvid-devel}
 BuildRequires: xz-devel
 BuildRequires: zlib-devel
+Obsoletes:     gpac-gui < 1.0.1-1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -137,18 +126,6 @@ Static GPAC library.
 %description static -l pl.UTF-8
 Statyczna biblioteka GPAC.
 
-%package gui
-Summary:       wxWidgets-based GUI for GPAC
-Summary(pl.UTF-8):     Oparty na wxWidgets graficzny interfejs do GPAC
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
-
-%description gui
-Osmo4 - wxWidgets-based GUI for GPAC.
-
-%description gui -l pl.UTF-8
-Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
-
 %package -n browser-plugin-%{name}
 Summary:       GPAC browser plugin
 Summary(pl.UTF-8):     Wtyczka GPAC do przegląderek WWW
@@ -166,17 +143,7 @@ Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-
-%patch7 -p1
-%patch8 -p1
-%patch11 -p1
-
-%{__sed} -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
 %if %{without avcap}
 %{__sed} -i -e 's,has_avcap="yes",has_avcap="no",' configure
 %endif
@@ -193,10 +160,9 @@ chmod a+x configure
        --cc="%{__cc}" \
        --cxx="%{__cxx}" \
        --disable-opt \
-       %{!?with_wx:--disable-wx} \
        %{?with_amr:--enable-amr} \
        --enable-pic \
-       --extra-cflags="%{rpmcflags} -I/usr/include/openjpeg-1.5" \
+       --extra-cflags="%{rpmcflags}" \
        --extra-ldflags="%{rpmldflags}" \
        %{?with_mozilla:--mozdir=%{_browserpluginsdir}} \
        %{?with_mozilla:--xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"} \
@@ -226,9 +192,6 @@ install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
        DESTDIR=$RPM_BUILD_ROOT \
        MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
 
-# needless
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/{win32,wince}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -245,18 +208,21 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS Changelog README.md TODO
-%attr(755,root,root) %{_bindir}/MP42TS
+%doc Changelog README.md
 %attr(755,root,root) %{_bindir}/MP4Box
 %attr(755,root,root) %{_bindir}/MP4Client
+%attr(755,root,root) %{_bindir}/gpac
 %attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgpac.so.8
+%attr(755,root,root) %ghost %{_libdir}/libgpac.so.10
 %dir %{_libdir}/gpac
 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
 %{_datadir}/gpac
 %{_mandir}/man1/gpac.1*
+%{_mandir}/man1/gpac-filters.1*
 %{_mandir}/man1/mp4box.1*
 %{_mandir}/man1/mp4client.1*
+%{_desktopdir}/gpac.desktop
+%{_pixmapsdir}/gpac.png
 
 %files devel
 %defattr(644,root,root,755)
@@ -268,13 +234,6 @@ fi
 %defattr(644,root,root,755)
 %{_libdir}/libgpac_static.a
 
-%if %{with wx}
-%files gui
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/DashCast
-%attr(755,root,root) %{_bindir}/Osmo4
-%endif
-
 %if %{with mozilla}
 %files -n browser-plugin-%{name}
 %defattr(644,root,root,755)
diff --git a/wxWidgets3.patch b/wxWidgets3.patch
deleted file mode 100644 (file)
index be7feb6..0000000
+++ /dev/null
@@ -1,256 +0,0 @@
-diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/Playlist.cpp gpac-0.8.0/applications/osmo4_wx/Playlist.cpp
---- gpac-0.8.0.org/applications/osmo4_wx/Playlist.cpp  2019-06-27 12:20:45.000000000 +0200
-+++ gpac-0.8.0/applications/osmo4_wx/Playlist.cpp      2021-03-13 09:23:00.666722560 +0100
-@@ -296,7 +296,7 @@ void wxPlaylist::RefreshList()
- void wxPlaylist::OnAddFile(wxCommandEvent &WXUNUSED(event))
- {
--      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), m_pApp->GetFileFilter(), wxOPEN | wxCHANGE_DIR | /*wxHIDE_READONLY |*/ wxMULTIPLE);
-+      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), m_pApp->GetFileFilter(), wxFD_OPEN | wxFD_CHANGE_DIR | /*wxFD_HIDE_READONLY |*/ wxFD_MULTIPLE);
-       if (dlg.ShowModal() == wxID_OK) {
-               wxArrayString stra;
-@@ -452,7 +452,7 @@ void wxPlaylist::OnSave(wxCommandEvent &
-       char szPath[GF_MAX_PATH];
-       if (!gf_list_count(m_entries)) return;
--      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxSAVE | wxCHANGE_DIR | wxOVERWRITE_PROMPT);
-+      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxFD_SAVE | wxFD_CHANGE_DIR | wxFD_OVERWRITE_PROMPT);
-       if (dlg.ShowModal() != wxID_OK) return;
-       strcpy(szPath, dlg.GetPath().mb_str(wxConvUTF8));
-@@ -501,7 +501,7 @@ void wxPlaylist::Save(char *szPath, Bool
- void wxPlaylist::OnOpen(wxCommandEvent & WXUNUSED(event))
- {
--      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U & PLS Playlists|*.m3u;*.pls|M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxOPEN | wxCHANGE_DIR/* | wxHIDE_READONLY*/);
-+      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U & PLS Playlists|*.m3u;*.pls|M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxFD_OPEN | wxFD_CHANGE_DIR/* | wxFD_HIDE_READONLY*/);
-       if (dlg.ShowModal() != wxID_OK) return;
-       Clear();
-diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/menubtn.cpp gpac-0.8.0/applications/osmo4_wx/menubtn.cpp
---- gpac-0.8.0.org/applications/osmo4_wx/menubtn.cpp   2019-06-27 12:20:45.000000000 +0200
-+++ gpac-0.8.0/applications/osmo4_wx/menubtn.cpp       2021-03-13 09:23:00.666722560 +0100
-@@ -86,7 +86,7 @@ bool wxCustomButton::Create(wxWindow* pa
-       wxSize bestSize = DoGetBestSize();
-       SetSize(wxSize(size.x<0 ? bestSize.x:size.x, size.y<0 ? bestSize.y:size.y));
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       SetBestSize(GetSize());
- #else
-       SetInitialSize(GetSize());
-@@ -161,7 +161,7 @@ void wxCustomButton::OnMouseEvents(wxMou
-               m_eventType = wxEVT_LEFT_UP;
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
- #else
-               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
-@@ -200,7 +200,7 @@ void wxCustomButton::OnMouseEvents(wxMou
-               m_eventType = wxEVT_RIGHT_UP;
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
- #else
-               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
-@@ -319,7 +319,7 @@ void wxCustomButton::Redraw()
- void wxCustomButton::Paint( wxDC &dc )
- {
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       dc.BeginDrawing();
- #endif
-@@ -407,7 +407,7 @@ void wxCustomButton::Paint( wxDC &dc )
-       dc.SetBackground(wxNullBrush);
-       dc.SetBrush(wxNullBrush);
-       dc.SetPen(wxNullPen);
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       dc.EndDrawing();
- #endif
- }
-@@ -580,7 +580,7 @@ public:
-               {
-                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-                       if (GetRect().Inside(p) || labelBut->GetRect().Inside(p))
- #else
-                       if (GetRect().Contains(p) || labelBut->GetRect().Contains(p))
-@@ -628,7 +628,7 @@ public:
-               {
-                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-                       if (GetRect().Inside(p) || dropBut->GetRect().Inside(p))
- #else
-                       if (GetRect().Contains(p) || dropBut->GetRect().Contains(p))
-@@ -706,7 +706,7 @@ bool wxMenuButton::Create( wxWindow* par
-       SetSize( wxSize(size.x < 0 ? bestSize.x : size.x,
-                       size.y < 0 ? bestSize.y : size.y) );
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       SetBestSize(GetSize());
- #else
-       SetInitialSize(GetSize());
-diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/wxGPACControl.cpp gpac-0.8.0/applications/osmo4_wx/wxGPACControl.cpp
---- gpac-0.8.0.org/applications/osmo4_wx/wxGPACControl.cpp     2019-06-27 12:20:45.000000000 +0200
-+++ gpac-0.8.0/applications/osmo4_wx/wxGPACControl.cpp 2021-03-13 09:23:00.666722560 +0100
-@@ -398,7 +398,7 @@ wxGPACControl::wxGPACControl(wxWindow *p
-       /*audio dec enum*/
-       sOpt = gf_cfg_get_key(cfg, "Systems", "DefAudioDec");
--      u32 count = gf_modules_get_count(m_pApp->m_user.modules);
-+      count = gf_modules_get_count(m_pApp->m_user.modules);
-       GF_BaseDecoder *ifc_d;
-       select = 0;
-       s32 to_sel = 0;
-diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/wxOsmo4.cpp gpac-0.8.0/applications/osmo4_wx/wxOsmo4.cpp
---- gpac-0.8.0.org/applications/osmo4_wx/wxOsmo4.cpp   2019-06-27 12:20:45.000000000 +0200
-+++ gpac-0.8.0/applications/osmo4_wx/wxOsmo4.cpp       2021-03-13 09:23:00.666722560 +0100
-@@ -227,9 +227,9 @@ Bool GPAC_EventProc(void *ptr, GF_Event
- #if 0
-               /*log*/
-               if (evt->message.error)
--                      ::wxLogMessage(wxString(evt->message.message, wxConvUTF8) + wxT(" (") + wxString(servName, wxConvUTF8) + wxT(") ") + wxString(gf_error_to_string(evt->message.error), wxConvUTF8) );
-+                      wxLogMessage(wxString(evt->message.message, wxConvUTF8) + wxT(" (") + wxString(servName, wxConvUTF8) + wxT(") ") + wxString(gf_error_to_string(evt->message.error), wxConvUTF8) );
-               else
--                      ::wxLogMessage(wxString(evt->message.message, wxConvUTF8) + wxT(" (") + wxString(servName, wxConvUTF8) + wxT(")"));
-+                      wxLogMessage(wxString(evt->message.message, wxConvUTF8) + wxT(" (") + wxString(servName, wxConvUTF8) + wxT(")"));
- #endif
-       }
-       break;
-@@ -289,7 +289,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
-                       {
-                               wxGPACEvent wxevt(app);
-                               wxevt.gpac_evt = *evt;
--                              app->AddPendingEvent(wxevt);
-+                              app->GetEventHandler()->AddPendingEvent(wxevt);
-                       }
-                       break;
-                       }
-@@ -302,7 +302,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
-               wxevt.gpac_evt.type = GF_EVENT_CONNECT;
-               wxevt.gpac_evt.connect.is_connected = evt->connect.is_connected;
-               if (!evt->connect.is_connected) app->m_duration = 0;
--              app->AddPendingEvent(wxevt);
-+              app->GetEventHandler()->AddPendingEvent(wxevt);
-       }
-       break;
-       case GF_EVENT_NAVIGATE:
-@@ -310,7 +310,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
-               wxGPACEvent wxevt(app);
-               wxevt.to_url = wxString(evt->navigate.to_url, wxConvUTF8);
-               wxevt.gpac_evt.type = evt->type;
--              app->AddPendingEvent(wxevt);
-+              app->GetEventHandler()->AddPendingEvent(wxevt);
-       }
-       return 1;
-       case GF_EVENT_SET_CAPTION:
-@@ -318,7 +318,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
-               wxGPACEvent wxevt(app);
-               wxevt.to_url = wxString(evt->caption.caption, wxConvUTF8);
-               wxevt.gpac_evt.type = evt->type;
--              app->AddPendingEvent(wxevt);
-+              app->GetEventHandler()->AddPendingEvent(wxevt);
-       }
-       return 1;
-@@ -330,7 +330,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
-       {
-               wxGPACEvent wxevt(app);
-               wxevt.gpac_evt = *evt;
--              app->AddPendingEvent(wxevt);
-+              app->GetEventHandler()->AddPendingEvent(wxevt);
-       }
-       break;
-       case GF_EVENT_DBLCLICK:
-@@ -539,7 +539,7 @@ Bool wxOsmo4Frame::LoadTerminal()
-       wxString abs_gpac_path = wxT("");
-       char *gpac_cfg, *sep;
--      ::wxLogMessage(wxT("Looking for GPAC configuration file"));
-+      wxLogMessage(wxT("Looking for GPAC configuration file"));
-       /*load config*/
-       Bool first_launch = 0;
-@@ -568,7 +568,7 @@ Bool wxOsmo4Frame::LoadTerminal()
-       gf_sys_init(GF_MemTrackerNone);
--      ::wxLogMessage(wxT("GPAC configuration file opened - looking for modules"));
-+      wxLogMessage(wxT("GPAC configuration file opened - looking for modules"));
-       m_user.modules = gf_modules_new(str, m_user.config);
-       /*initial launch*/
-@@ -594,12 +594,12 @@ Bool wxOsmo4Frame::LoadTerminal()
--      ::wxLogMessage(wxT("%d modules found:"), gf_modules_get_count(m_user.modules));
-+      wxLogMessage(wxT("%d modules found:"), gf_modules_get_count(m_user.modules));
-       for (u32 i=0; i<gf_modules_get_count(m_user.modules); i++) {
--              ::wxLogMessage(wxT("\t") + wxString(gf_modules_get_file_name(m_user.modules, i), wxConvUTF8) );
-+              wxLogMessage(wxT("\t") + wxString(gf_modules_get_file_name(m_user.modules, i), wxConvUTF8) );
-       }
--      ::wxLogMessage(wxT("Starting GPAC Terminal"));
-+      wxLogMessage(wxT("Starting GPAC Terminal"));
-       /*now load terminal*/
-       m_user.opaque = this;
-       m_user.EventProc = GPAC_EventProc;
-@@ -611,7 +611,7 @@ Bool wxOsmo4Frame::LoadTerminal()
-               wxMessageDialog(NULL, wxT("Fatal Error"), wxT("Cannot load GPAC Terminal"), wxOK).ShowModal();
-               return 0;
-       } else {
--              ::wxLogMessage(wxT("GPAC Terminal started") );
-+              wxLogMessage(wxT("GPAC Terminal started") );
-       }
-       return 1;
- }
-@@ -877,7 +877,7 @@ wxOsmo4Frame::wxOsmo4Frame() :
-       sOpt = gf_cfg_get_key(m_user.config, "Audio", "DriverName");
-       if (!strcmp(sOpt, "No Audio Output Available")) {
--              ::wxLogMessage(wxT("WARNING: no audio output availble - make sure no other program is locking the sound card"));
-+              wxLogMessage(wxT("WARNING: no audio output availble - make sure no other program is locking the sound card"));
-               SetStatus(wxT("No audio ouput available"));
-       } else {
-@@ -1140,7 +1140,7 @@ wxString wxOsmo4Frame::GetFileFilter()
- void wxOsmo4Frame::OnFileOpen(wxCommandEvent & WXUNUSED(event))
- {
--      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), GetFileFilter(), wxOPEN | wxMULTIPLE | wxCHANGE_DIR /*| wxHIDE_READONLY*/);
-+      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), GetFileFilter(), wxFD_OPEN | wxFD_MULTIPLE | wxFD_CHANGE_DIR /*| wxHIDE_READONLY*/);
-       if (dlg.ShowModal() != wxID_OK) return;
-@@ -1934,7 +1934,7 @@ void wxMyComboBox::OnKeyUp(wxKeyEvent &e
-               evt.SetEventType(wxEVT_COMMAND_COMBOBOX_SELECTED);
-               evt.SetEventObject(this);
-               evt.SetId(GetId());
--              GetParent()->AddPendingEvent(evt);
-+              GetParent()->GetEventHandler()->AddPendingEvent(evt);
-       }
- }
-@@ -2169,7 +2169,7 @@ void wxOsmo4Frame::OnUpdateStreamMenu(wx
- void wxOsmo4Frame::OnAddSub(wxCommandEvent &WXUNUSED(event))
- {
--      wxFileDialog dlg(this, wxT("Add Subtitle"), wxT(""), wxT(""), wxT("All Subtitles|*.srt;*.ttxt|SRT Subtitles|*.srt|3GPP TimedText|*.ttxt|"), wxOPEN | wxCHANGE_DIR /* | wxHIDE_READONLY*/);
-+      wxFileDialog dlg(this, wxT("Add Subtitle"), wxT(""), wxT(""), wxT("All Subtitles|*.srt;*.ttxt|SRT Subtitles|*.srt|3GPP TimedText|*.ttxt|"), wxFD_OPEN | wxFD_CHANGE_DIR /* | wxHIDE_READONLY*/);
-       if (dlg.ShowModal() == wxID_OK) {
-               AddSubtitle(dlg.GetPath().mb_str(wxConvUTF8), 1);
This page took 0.938491 seconds and 4 git commands to generate.