]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- rediff patches
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 13 Mar 2021 08:26:02 +0000 (09:26 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 13 Mar 2021 08:26:02 +0000 (09:26 +0100)
gpac-apps.patch
wxWidgets3.patch

index e97601877ecfb4e1e65960e94150b2476445674c..47bc2e494f1e5f9bbfa2182194f3715636a48499 100644 (file)
@@ -1,6 +1,7 @@
---- gpac/applications/Makefile.orig    2012-05-22 23:29:22.000000000 +0200
-+++ gpac/applications/Makefile 2012-06-16 18:26:34.918450437 +0200
-@@ -17,15 +17,15 @@
+diff -urNp -x '*.orig' gpac-0.8.0.org/applications/Makefile gpac-0.8.0/applications/Makefile
+--- gpac-0.8.0.org/applications/Makefile       2019-06-27 12:20:45.000000000 +0200
++++ gpac-0.8.0/applications/Makefile   2021-03-13 09:23:01.300056818 +0100
+@@ -33,15 +33,15 @@ V4STUDIODIR=
  INSTDIRS=mp4client
  ifeq ($(CONFIG_XUL),no)
  else
@@ -19,4 +20,4 @@
 +INSTDIRS+=osmo4_wx
  endif
  
- ALLDIRS=$(APPDIRS)
+ #MP4BOX_STATIC
index e17c6ca30e16dc453929f63e32ba742bd4877de7..be7feb6b983d0ab695b01364e2dcaf4f208e1f25 100644 (file)
@@ -1,16 +1,16 @@
-diff -ur gpac/applications/osmo4_wx/Playlist.cpp gpac.wx3/applications/osmo4_wx/Playlist.cpp
---- gpac/applications/osmo4_wx/Playlist.cpp    2010-07-28 17:53:09.000000000 +0200
-+++ gpac.wx3/applications/osmo4_wx/Playlist.cpp        2014-01-18 19:00:08.102059900 +0100
-@@ -292,7 +292,7 @@
+diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/Playlist.cpp gpac-0.8.0/applications/osmo4_wx/Playlist.cpp
+--- gpac-0.8.0.org/applications/osmo4_wx/Playlist.cpp  2019-06-27 12:20:45.000000000 +0200
++++ gpac-0.8.0/applications/osmo4_wx/Playlist.cpp      2021-03-13 09:23:00.666722560 +0100
+@@ -296,7 +296,7 @@ void wxPlaylist::RefreshList()
  
- void wxPlaylist::OnAddFile(wxCommandEvent &WXUNUSED(event)) 
+ void wxPlaylist::OnAddFile(wxCommandEvent &WXUNUSED(event))
  {
 -      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), m_pApp->GetFileFilter(), wxOPEN | wxCHANGE_DIR | /*wxHIDE_READONLY |*/ wxMULTIPLE);
 +      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), m_pApp->GetFileFilter(), wxFD_OPEN | wxFD_CHANGE_DIR | /*wxFD_HIDE_READONLY |*/ wxFD_MULTIPLE);
  
        if (dlg.ShowModal() == wxID_OK) {
                wxArrayString stra;
-@@ -448,7 +448,7 @@
+@@ -452,7 +452,7 @@ void wxPlaylist::OnSave(wxCommandEvent &
        char szPath[GF_MAX_PATH];
        if (!gf_list_count(m_entries)) return;
  
@@ -19,19 +19,106 @@ diff -ur gpac/applications/osmo4_wx/Playlist.cpp gpac.wx3/applications/osmo4_wx/
        if (dlg.ShowModal() != wxID_OK) return;
  
        strcpy(szPath, dlg.GetPath().mb_str(wxConvUTF8));
-@@ -497,7 +497,7 @@
+@@ -501,7 +501,7 @@ void wxPlaylist::Save(char *szPath, Bool
  
- void wxPlaylist::OnOpen(wxCommandEvent & WXUNUSED(event)) 
+ void wxPlaylist::OnOpen(wxCommandEvent & WXUNUSED(event))
  {
 -      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U & PLS Playlists|*.m3u;*.pls|M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxOPEN | wxCHANGE_DIR/* | wxHIDE_READONLY*/);
 +      wxFileDialog dlg(this, wxT("Select file(s)"), wxT(""), wxT(""), wxT("M3U & PLS Playlists|*.m3u;*.pls|M3U Playlists|*.m3u|ShoutCast Playlists|*.pls|"), wxFD_OPEN | wxFD_CHANGE_DIR/* | wxFD_HIDE_READONLY*/);
        if (dlg.ShowModal() != wxID_OK) return;
  
        Clear();
-diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/wxOsmo4.cpp
---- gpac/applications/osmo4_wx/wxOsmo4.cpp     2011-07-29 15:14:43.000000000 +0200
-+++ gpac.wx3/applications/osmo4_wx/wxOsmo4.cpp 2014-01-18 18:59:09.155393660 +0100
-@@ -224,9 +224,9 @@
+diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/menubtn.cpp gpac-0.8.0/applications/osmo4_wx/menubtn.cpp
+--- gpac-0.8.0.org/applications/osmo4_wx/menubtn.cpp   2019-06-27 12:20:45.000000000 +0200
++++ gpac-0.8.0/applications/osmo4_wx/menubtn.cpp       2021-03-13 09:23:00.666722560 +0100
+@@ -86,7 +86,7 @@ bool wxCustomButton::Create(wxWindow* pa
+       wxSize bestSize = DoGetBestSize();
+       SetSize(wxSize(size.x<0 ? bestSize.x:size.x, size.y<0 ? bestSize.y:size.y));
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+       SetBestSize(GetSize());
+ #else
+       SetInitialSize(GetSize());
+@@ -161,7 +161,7 @@ void wxCustomButton::OnMouseEvents(wxMou
+               m_eventType = wxEVT_LEFT_UP;
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
+ #else
+               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
+@@ -200,7 +200,7 @@ void wxCustomButton::OnMouseEvents(wxMou
+               m_eventType = wxEVT_RIGHT_UP;
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
+ #else
+               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
+@@ -319,7 +319,7 @@ void wxCustomButton::Redraw()
+ void wxCustomButton::Paint( wxDC &dc )
+ {
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+       dc.BeginDrawing();
+ #endif
+@@ -407,7 +407,7 @@ void wxCustomButton::Paint( wxDC &dc )
+       dc.SetBackground(wxNullBrush);
+       dc.SetBrush(wxNullBrush);
+       dc.SetPen(wxNullPen);
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+       dc.EndDrawing();
+ #endif
+ }
+@@ -580,7 +580,7 @@ public:
+               {
+                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+                       if (GetRect().Inside(p) || labelBut->GetRect().Inside(p))
+ #else
+                       if (GetRect().Contains(p) || labelBut->GetRect().Contains(p))
+@@ -628,7 +628,7 @@ public:
+               {
+                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+                       if (GetRect().Inside(p) || dropBut->GetRect().Inside(p))
+ #else
+                       if (GetRect().Contains(p) || dropBut->GetRect().Contains(p))
+@@ -706,7 +706,7 @@ bool wxMenuButton::Create( wxWindow* par
+       SetSize( wxSize(size.x < 0 ? bestSize.x : size.x,
+                       size.y < 0 ? bestSize.y : size.y) );
+-#if (wxMINOR_VERSION<8)
++#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
+       SetBestSize(GetSize());
+ #else
+       SetInitialSize(GetSize());
+diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/wxGPACControl.cpp gpac-0.8.0/applications/osmo4_wx/wxGPACControl.cpp
+--- gpac-0.8.0.org/applications/osmo4_wx/wxGPACControl.cpp     2019-06-27 12:20:45.000000000 +0200
++++ gpac-0.8.0/applications/osmo4_wx/wxGPACControl.cpp 2021-03-13 09:23:00.666722560 +0100
+@@ -398,7 +398,7 @@ wxGPACControl::wxGPACControl(wxWindow *p
+       /*audio dec enum*/
+       sOpt = gf_cfg_get_key(cfg, "Systems", "DefAudioDec");
+-      u32 count = gf_modules_get_count(m_pApp->m_user.modules);
++      count = gf_modules_get_count(m_pApp->m_user.modules);
+       GF_BaseDecoder *ifc_d;
+       select = 0;
+       s32 to_sel = 0;
+diff -urNp -x '*.orig' gpac-0.8.0.org/applications/osmo4_wx/wxOsmo4.cpp gpac-0.8.0/applications/osmo4_wx/wxOsmo4.cpp
+--- gpac-0.8.0.org/applications/osmo4_wx/wxOsmo4.cpp   2019-06-27 12:20:45.000000000 +0200
++++ gpac-0.8.0/applications/osmo4_wx/wxOsmo4.cpp       2021-03-13 09:23:00.666722560 +0100
+@@ -227,9 +227,9 @@ Bool GPAC_EventProc(void *ptr, GF_Event
  #if 0
                /*log*/
                if (evt->message.error)
@@ -42,54 +129,54 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
 +                      wxLogMessage(wxString(evt->message.message, wxConvUTF8) + wxT(" (") + wxString(servName, wxConvUTF8) + wxT(")"));
  #endif
        }
-               break;
-@@ -286,7 +286,7 @@
+       break;
+@@ -289,7 +289,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
                        {
                                wxGPACEvent wxevt(app);
                                wxevt.gpac_evt = *evt;
 -                              app->AddPendingEvent(wxevt);
 +                              app->GetEventHandler()->AddPendingEvent(wxevt);
                        }
-                               break;
+                       break;
                        }
-@@ -299,7 +299,7 @@
+@@ -302,7 +302,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
                wxevt.gpac_evt.type = GF_EVENT_CONNECT;
                wxevt.gpac_evt.connect.is_connected = evt->connect.is_connected;
                if (!evt->connect.is_connected) app->m_duration = 0;
 -              app->AddPendingEvent(wxevt);
 +              app->GetEventHandler()->AddPendingEvent(wxevt);
        }
-               break;
+       break;
        case GF_EVENT_NAVIGATE:
-@@ -307,7 +307,7 @@
+@@ -310,7 +310,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
                wxGPACEvent wxevt(app);
                wxevt.to_url = wxString(evt->navigate.to_url, wxConvUTF8);
                wxevt.gpac_evt.type = evt->type;
 -              app->AddPendingEvent(wxevt);
 +              app->GetEventHandler()->AddPendingEvent(wxevt);
        }
-               return 1;
+       return 1;
        case GF_EVENT_SET_CAPTION:
-@@ -315,7 +315,7 @@
+@@ -318,7 +318,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
                wxGPACEvent wxevt(app);
                wxevt.to_url = wxString(evt->caption.caption, wxConvUTF8);
                wxevt.gpac_evt.type = evt->type;
 -              app->AddPendingEvent(wxevt);
 +              app->GetEventHandler()->AddPendingEvent(wxevt);
        }
-               return 1;
+       return 1;
  
-@@ -327,7 +327,7 @@
+@@ -330,7 +330,7 @@ Bool GPAC_EventProc(void *ptr, GF_Event
        {
                wxGPACEvent wxevt(app);
                wxevt.gpac_evt = *evt;
 -              app->AddPendingEvent(wxevt);
 +              app->GetEventHandler()->AddPendingEvent(wxevt);
        }
-               break;
+       break;
        case GF_EVENT_DBLCLICK:
-@@ -536,7 +536,7 @@
-     wxString abs_gpac_path = wxT("");
+@@ -539,7 +539,7 @@ Bool wxOsmo4Frame::LoadTerminal()
+       wxString abs_gpac_path = wxT("");
        char *gpac_cfg, *sep;
  
 -      ::wxLogMessage(wxT("Looking for GPAC configuration file"));
@@ -97,16 +184,16 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
  
        /*load config*/
        Bool first_launch = 0;
-@@ -565,7 +565,7 @@
+@@ -568,7 +568,7 @@ Bool wxOsmo4Frame::LoadTerminal()
  
-       gf_sys_init(0);
+       gf_sys_init(GF_MemTrackerNone);
  
 -      ::wxLogMessage(wxT("GPAC configuration file opened - looking for modules"));
 +      wxLogMessage(wxT("GPAC configuration file opened - looking for modules"));
  
        m_user.modules = gf_modules_new(str, m_user.config);
        /*initial launch*/
-@@ -591,12 +591,12 @@
+@@ -594,12 +594,12 @@ Bool wxOsmo4Frame::LoadTerminal()
  
  
  
@@ -122,7 +209,7 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
        /*now load terminal*/
        m_user.opaque = this;
        m_user.EventProc = GPAC_EventProc;
-@@ -608,7 +608,7 @@
+@@ -611,7 +611,7 @@ Bool wxOsmo4Frame::LoadTerminal()
                wxMessageDialog(NULL, wxT("Fatal Error"), wxT("Cannot load GPAC Terminal"), wxOK).ShowModal();
                return 0;
        } else {
@@ -140,7 +227,7 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
                SetStatus(wxT("No audio ouput available"));
  
        } else {
-@@ -1137,7 +1137,7 @@
+@@ -1140,7 +1140,7 @@ wxString wxOsmo4Frame::GetFileFilter()
  
  void wxOsmo4Frame::OnFileOpen(wxCommandEvent & WXUNUSED(event))
  {
@@ -149,7 +236,7 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
  
        if (dlg.ShowModal() != wxID_OK) return;
  
-@@ -1900,7 +1900,7 @@
+@@ -1934,7 +1934,7 @@ void wxMyComboBox::OnKeyUp(wxKeyEvent &e
                evt.SetEventType(wxEVT_COMMAND_COMBOBOX_SELECTED);
                evt.SetEventObject(this);
                evt.SetId(GetId());
@@ -158,7 +245,7 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
        }
  }
  
-@@ -2135,7 +2135,7 @@
+@@ -2169,7 +2169,7 @@ void wxOsmo4Frame::OnUpdateStreamMenu(wx
  
  void wxOsmo4Frame::OnAddSub(wxCommandEvent &WXUNUSED(event))
  {
@@ -167,89 +254,3 @@ diff -ur gpac/applications/osmo4_wx/wxOsmo4.cpp gpac.wx3/applications/osmo4_wx/w
  
        if (dlg.ShowModal() == wxID_OK) {
                AddSubtitle(dlg.GetPath().mb_str(wxConvUTF8), 1);
---- gpac/applications/osmo4_wx/wxGPACControl.cpp~      2014-10-07 23:09:59.000000000 +0200
-+++ gpac/applications/osmo4_wx/wxGPACControl.cpp       2014-10-07 23:36:33.313608359 +0200
-@@ -398,7 +398,7 @@
-       /*audio dec enum*/
-       sOpt = gf_cfg_get_key(cfg, "Systems", "DefAudioDec");
--      u32 count = gf_modules_get_count(m_pApp->m_user.modules);
-+      count = gf_modules_get_count(m_pApp->m_user.modules);
-       GF_BaseDecoder *ifc_d;
-       select = 0;
-       s32 to_sel = 0;
-
---- gpac/applications/osmo4_wx/menubtn.cpp~    2014-10-07 23:09:59.000000000 +0200
-+++ gpac/applications/osmo4_wx/menubtn.cpp     2014-10-07 23:42:37.356710868 +0200
-@@ -86,7 +86,7 @@ bool wxCustomButton::Create(wxWindow* pa
-       wxSize bestSize = DoGetBestSize();
-       SetSize(wxSize(size.x<0 ? bestSize.x:size.x, size.y<0 ? bestSize.y:size.y));
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       SetBestSize(GetSize());
- #else
-       SetInitialSize(GetSize());
-@@ -161,7 +161,7 @@ void wxCustomButton::OnMouseEvents(wxMou
-               m_eventType = wxEVT_LEFT_UP;
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
- #else
-               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
-@@ -200,7 +200,7 @@ void wxCustomButton::OnMouseEvents(wxMou
-               m_eventType = wxEVT_RIGHT_UP;
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-               if (wxRect(wxPoint(0,0), GetSize()).Inside(event.GetPosition()))
- #else
-               if (wxRect(wxPoint(0,0), GetSize()).Contains(event.GetPosition()))
-@@ -319,7 +319,7 @@ void wxCustomButton::Redraw()
- void wxCustomButton::Paint( wxDC &dc )
- {
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       dc.BeginDrawing();
- #endif
-@@ -407,7 +407,7 @@ void wxCustomButton::Paint( wxDC &dc )
-       dc.SetBackground(wxNullBrush);
-       dc.SetBrush(wxNullBrush);
-       dc.SetPen(wxNullPen);
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       dc.EndDrawing();
- #endif
- }
-@@ -580,7 +580,7 @@ public:
-               {
-                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-                       if (GetRect().Inside(p) || labelBut->GetRect().Inside(p))
- #else
-                       if (GetRect().Contains(p) || labelBut->GetRect().Contains(p))
-@@ -628,7 +628,7 @@ public:
-               {
-                       wxPoint p = GetParent()->ScreenToClient(wxGetMousePosition());
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-                       if (GetRect().Inside(p) || dropBut->GetRect().Inside(p))
- #else
-                       if (GetRect().Contains(p) || dropBut->GetRect().Contains(p))
-@@ -706,7 +706,7 @@ bool wxMenuButton::Create( wxWindow* par
-       SetSize( wxSize(size.x < 0 ? bestSize.x : size.x,
-                       size.y < 0 ? bestSize.y : size.y) );
--#if (wxMINOR_VERSION<8)
-+#if (wxMINOR_VERSION<8) && (wxMAJOR_VERSION < 3)
-       SetBestSize(GetSize());
- #else
-       SetInitialSize(GetSize());
This page took 0.497072 seconds and 4 git commands to generate.