]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- export functions needed by libx264 auto/th/gpac-0.5.0-3 auto/ti/gpac-0.5.0-3
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Oct 2012 20:04:36 +0000 (22:04 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 2 Oct 2012 20:04:36 +0000 (22:04 +0200)
- rel 3

gpac-export.patch
gpac.spec

index d250f43dc2e4e17d9da71080a4255cc2c6331914..30c668c15cb512c0bb6d37a287d64dee098674cd 100644 (file)
  u32 gf_rand()
  {
        return rand();
+--- gpac/src/isomedia/isom_write.c.orig        2012-03-29 14:36:23.000000000 +0200
++++ gpac/src/isomedia/isom_write.c     2012-10-02 21:55:13.269904532 +0200
+@@ -1140,6 +1140,7 @@
+       return Track_SetStreamDescriptor(trak, StreamDescriptionIndex, entry->dataReferenceIndex, esd, NULL);
+ }
++GF_EXPORT
+ GF_Err gf_isom_set_visual_info(GF_ISOFile *movie, u32 trackNumber, u32 StreamDescriptionIndex, u32 Width, u32 Height)
+ {
+       GF_Err e;
+@@ -1187,6 +1188,7 @@
+       }
+ }
++GF_EXPORT
+ GF_Err gf_isom_set_pixel_aspect_ratio(GF_ISOFile *movie, u32 trackNumber, u32 StreamDescriptionIndex, u32 hSpacing, u32 vSpacing)
+ {
+       GF_Err e;
+--- gpac/src/isomedia/avc_ext.c.orig   2012-03-27 11:48:05.000000000 +0200
++++ gpac/src/isomedia/avc_ext.c        2012-10-02 21:54:35.469905865 +0200
+@@ -170,6 +170,7 @@
+ #ifndef GPAC_DISABLE_ISOM_WRITE
++GF_EXPORT
+ GF_Err gf_isom_avc_config_new(GF_ISOFile *the_file, u32 trackNumber, GF_AVCConfig *cfg, char *URLname, char *URNname, u32 *outDescriptionIndex)
+ {
+       GF_TrackBox *trak;
index 71709d949676abda353b2308771773f668be4990..95f45cf9a31d8beba54103a6d2ff95d106980bbd 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
@@ -21,7 +21,7 @@ Summary:      GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-
 Summary(pl.UTF-8):     GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
 Version:       0.5.0
-Release:       2
+Release:       3
 License:       LGPL v2+
 Group:         Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
This page took 1.626385 seconds and 4 git commands to generate.