]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- up to 2.2.1 master auto/th/gpac-2.2.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Oct 2023 12:13:03 +0000 (14:13 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Oct 2023 12:13:03 +0000 (14:13 +0200)
ffmpeg6.patch [new file with mode: 0644]
gpac-install-is-not-clean.patch [deleted file]
gpac.spec

diff --git a/ffmpeg6.patch b/ffmpeg6.patch
new file mode 100644 (file)
index 0000000..0e7c182
--- /dev/null
@@ -0,0 +1,51 @@
+From ba14e34dd7a3c4cef5a56962898e9f863dd4b4f3 Mon Sep 17 00:00:00 2001
+From: jeanlf <jeanlf@gpac.io>
+Date: Mon, 13 Mar 2023 09:43:52 +0100
+Subject: [PATCH] fixed compil with ffmpeg 6 - cf #2406
+
+---
+ src/filters/ff_mx.c | 20 ++++++++++++++++----
+ 1 file changed, 16 insertions(+), 4 deletions(-)
+
+diff --git a/src/filters/ff_mx.c b/src/filters/ff_mx.c
+index 34e5f59e7c..5cf1d98941 100644
+--- a/src/filters/ff_mx.c
++++ b/src/filters/ff_mx.c
+@@ -503,7 +503,11 @@ static GF_Err ffmx_close_seg(GF_Filter *filter, GF_FFMuxCtx *ctx, Bool send_evt_
+               evt.seg_size.is_init = 0;
+       }
+       evt.seg_size.media_range_start = ctx->offset_at_seg_start;
++#if LIBAVFORMAT_VERSION_MAJOR < 60
+       evt.seg_size.media_range_end = ctx->muxer->pb ? (ctx->muxer->pb->written-1) : 0;
++#else
++      evt.seg_size.media_range_end = ctx->muxer->pb ? (ctx->muxer->pb->bytes_written-1) : 0;
++#endif
+       ctx->offset_at_seg_start = evt.seg_size.media_range_end;
+       gf_filter_pid_send_event(pid, &evt);
+@@ -1013,13 +1017,21 @@ static GF_Err ffmx_configure_pid(GF_Filter *filter, GF_FilterPid *pid, Bool is_r
+               ff_codec_id = ffmpeg_codecid_from_gpac(codec_id, &ff_codec_tag);
+       }
++
++      res = 1;
++#if LIBAVFORMAT_VERSION_MAJOR < 60
+       if (ctx->muxer->oformat && ctx->muxer->oformat->query_codec) {
+               res = ctx->muxer->oformat->query_codec(ff_codec_id, 1);
+-              if (!res) {
+-                      GF_LOG(GF_LOG_ERROR, GF_LOG_CONTAINER, ("[FFMux] Codec %s not supported in container %s\n", gf_codecid_name(codec_id), ctx->muxer->oformat->name));
+-                      return GF_NOT_SUPPORTED;
+-              }
+       }
++#else
++      res = avformat_query_codec(ctx->muxer->oformat, ff_codec_id, FF_COMPLIANCE_NORMAL);
++#endif
++
++      if (!res) {
++              GF_LOG(GF_LOG_ERROR, GF_LOG_CONTAINER, ("[FFMux] Codec %s not supported in container %s\n", gf_codecid_name(codec_id), ctx->muxer->oformat->name));
++              return GF_NOT_SUPPORTED;
++      }
++
+       const AVCodec *c = avcodec_find_decoder(ff_codec_id);
+       if (!c) return GF_NOT_SUPPORTED;
diff --git a/gpac-install-is-not-clean.patch b/gpac-install-is-not-clean.patch
deleted file mode 100644 (file)
index aed276d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- gpac-1.0.1/applications/mp4client/Makefile~        2020-09-10 18:38:49.000000000 +0200
-+++ gpac-1.0.1/applications/mp4client/Makefile 2021-10-24 22:39:03.166080322 +0200
-@@ -66,7 +66,7 @@
- clean:
-       rm -f $(OBJS) ../../bin/gcc/$(PROG)
--install: clean
-+install:
-       install -m 755 $(INSTFLAGS) ../../bin/gcc/MP4Client "$(DESTDIR)$(prefix)/bin"
- uninstall:
index 829eed683b00912e6e657351d552a33ce1cf4103..96f7ad844b73021363f0304d9c584d960439c291 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
 Summary:       GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
 Summary(pl.UTF-8):     GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
-Version:       1.0.1
+Version:       2.2.1
 Release:       1
 License:       LGPL v2+
 Group:         Applications/Multimedia
 #Source0Download: https://github.com/gpac/gpac/releases
 Source0:       https://github.com/gpac/gpac/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 52f6711e43a8d271ebec0c2ea2afab4a
-Patch0:                %{name}-install-is-not-clean.patch
+# Source0-md5: a1a4a6c7f1525431b211b5ba47253ed0
+Patch0:                ffmpeg6.patch
 URL:           http://www.gpac.io/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -171,7 +171,6 @@ chmod a+x configure
        %{!?with_freenect:--use-freenect=no} \
        %{!?with_freetype:--use-ft=no} \
        %{!?with_jpeg:--use-jpeg=no} \
-       %{!?with_js:--use-js=no} \
        %{!?with_mad:--use-mad=no} \
        %{!?with_png:--use-png=no} \
        %{!?with_xvid:--use-xvid=no} \
@@ -179,7 +178,7 @@ chmod a+x configure
 
 %{!?with_directfb: sed -i 's/CONFIG_DIRECTFB.*/CONFIG_DIRECTFB=no/' config.mak}
 
-%{__make} -j1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -210,19 +209,17 @@ fi
 %defattr(644,root,root,755)
 %doc Changelog README.md
 %attr(755,root,root) %{_bindir}/MP4Box
-%attr(755,root,root) %{_bindir}/MP4Client
 %attr(755,root,root) %{_bindir}/gpac
 %attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgpac.so.10
+%attr(755,root,root) %ghost %{_libdir}/libgpac.so.12
 %dir %{_libdir}/gpac
 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
 %{_datadir}/gpac
 %{_mandir}/man1/gpac.1*
 %{_mandir}/man1/gpac-filters.1*
 %{_mandir}/man1/mp4box.1*
-%{_mandir}/man1/mp4client.1*
 %{_desktopdir}/gpac.desktop
-%{_pixmapsdir}/gpac.png
+%{_iconsdir}/hicolor/*x*/apps/gpac.png
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.194336 seconds and 4 git commands to generate.