]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- updated to 0.4.0
authormaciek2w <maciek2w@pld-linux.org>
Sun, 19 Mar 2006 12:43:44 +0000 (12:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- changed licence to LGPL
- added subpackage with browser plugin

Changed files:
    gpac-install.patch -> 1.5
    gpac-wxWidgets.patch -> 1.2
    gpac.spec -> 1.14

gpac-install.patch
gpac-wxWidgets.patch
gpac.spec

index 26127f28b4c724c768450a30477dd6be03d1c67c..317e4a089b71bceb8bd43b07ef59358047c51e53 100644 (file)
@@ -1,35 +1,73 @@
---- gpac/Applications/MP4Client/Makefile.orig  2005-04-09 04:10:13.000000000 +0200
-+++ gpac/Applications/MP4Client/Makefile       2005-04-09 04:10:23.000000000 +0200
-@@ -13,7 +13,7 @@
- OBJS= main.o 
- ifeq ($(BUILD_INSTALL), yes)
--INSTALL_FLAGS=-DM4_PLUGIN_PATH=\"$(plugdir)\"
-+INSTALL_FLAGS=-DM4_PLUGIN_PATH=\"$(real_plugdir)\"
+--- gpac/Makefile.orig 2006-03-17 22:16:39.000000000 +0100
++++ gpac/Makefile      2006-03-17 22:17:29.000000000 +0100
+@@ -71,8 +71,8 @@
+ ifeq ($(CONFIG_WIN32),yes)
+       install -s -m 755 bin/gcc/libgpac.dll $(prefix)/lib
  else
- INSTALL_FLAGS=
- endif
---- gpac/Applications/Osmo4_wx/Makefile.orig   2005-04-09 04:10:42.000000000 +0200
-+++ gpac/Applications/Osmo4_wx/Makefile        2005-04-09 04:10:52.000000000 +0200
-@@ -13,7 +13,7 @@
- OBJS= wxOsmo4.o wxGPACControl.o fileprops.o Playlist.o menubtn.o
- ifeq ($(BUILD_INSTALL), yes)
--INSTALL_FLAGS=-DM4_PLUGIN_PATH=\"$(plugdir)\"
-+INSTALL_FLAGS=-DM4_PLUGIN_PATH=\"$(real_plugdir)\"
+-      install -s -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(prefix)/lib/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
+-      ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(prefix)/lib/libgpac.$(DYN_LIB_SUFFIX)
++      install -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
++      ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
+ #not sure wether darwin uses ldconfig or not...
+ ifeq ($(CONFIG_DARWIN),yes)
  else
- INSTALL_FLAGS=
+--- gpac/Makefile.orig 2006-03-17 22:27:49.000000000 +0100
++++ gpac/Makefile      2006-03-17 22:27:58.000000000 +0100
+@@ -64,7 +64,7 @@
+       install -c -s -m 755 bin/gcc/MP4Box "$(prefix)/bin"
+       install -c -s -m 755 bin/gcc/MP42Avi "$(prefix)/bin"
+       $(MAKE) -C applications install
+-      install -d "$(moddir)"
++      install -d "$(libdir)/gpac"
+       install -c bin/gcc/*.$(DYN_LIB_SUFFIX) "$(moddir)"
+       rm -f $(moddir)/libgpac.$(DYN_LIB_SUFFIX)
+       rm -f $(moddir)/nposmozilla.$(DYN_LIB_SUFFIX)
+--- gpac/applications/osmozilla/Makefile.orig  2006-03-17 22:47:48.000000000 +0100
++++ gpac/applications/osmozilla/Makefile       2006-03-17 22:54:03.000000000 +0100
+@@ -5,10 +5,6 @@
+ GECKO_PATH=$(SRC_PATH)/extra_lib/include/gecko-sdk
+ USER_NAME=$(shell whoami)
+-ifeq ($(USER_NAME), root)
+-else
+-MOZILLA_DIR=local
+-endif
+ CFLAGS= $(OPTFLAGS) -Wall -I$(SRC_PATH)/include \
+   -I$(GECKO_PATH) \
+@@ -71,18 +67,8 @@
  endif
---- gpac/Makefile.orig 2005-01-31 15:41:05.000000000 +0100
-+++ gpac/Makefile      2005-04-27 12:33:09.000000000 +0200
-@@ -73,8 +73,8 @@
+ install: $(LIB)
+-ifeq ($(MOZILLA_DIR), local)
+-ifeq ($(USER_NAME), root)
+-      @echo "*** Root cannot install local mozilla plugins! ***"
+-      @echo "*** Exit root mode and reinstall mozilla plugin! ***"
+-else
+-      install -D -m 755 ../../bin/gcc/$(LIB) "$(HOME)/.mozilla/plugins/$(LIB)"
+-      install -D -m 755 ../../bin/gcc/nposmozilla.xpt "$(HOME)/.mozilla/components/nposmozilla.xpt"
+-endif
+-else
+-      install -D -m 755 ../../bin/gcc/$(LIB) "$(MOZILLA_DIR)/components/$(LIB)"
+-      install -D -m 755 ../../bin/gcc/nposmozilla.xpt "$(MOZILLA_DIR)/components/nposmozilla.xpt"
+-endif
++      install -D -m 755 ../../bin/gcc/$(LIB) "$(MOZILLA_DIR)/$(LIB)"
++      install -D -m 755 ../../bin/gcc/nposmozilla.xpt "$(MOZILLA_DIR)/nposmozilla.xpt"
+ dep: depend
+--- gpac/Makefile.orig 2006-03-17 22:55:15.000000000 +0100
++++ gpac/Makefile      2006-03-17 22:56:22.000000000 +0100
+@@ -65,9 +65,9 @@
+       install -c -s -m 755 bin/gcc/MP42Avi "$(prefix)/bin"
+       $(MAKE) -C applications install
+       install -d "$(libdir)/gpac"
+-      install -c bin/gcc/*.$(DYN_LIB_SUFFIX) "$(moddir)"
+-      rm -f $(moddir)/libgpac.$(DYN_LIB_SUFFIX)
+-      rm -f $(moddir)/nposmozilla.$(DYN_LIB_SUFFIX)
++      install -c bin/gcc/*.$(DYN_LIB_SUFFIX) "$(libdir)/gpac"
++      rm -f $(libdir)/libgpac.$(DYN_LIB_SUFFIX)
++      rm -f $(libdir)/nposmozilla.$(DYN_LIB_SUFFIX)
  ifeq ($(CONFIG_WIN32),yes)
-       install -s -m 755 bin/gcc/libm4systems.dll $(prefix)/lib
+       install -s -m 755 bin/gcc/libgpac.dll $(prefix)/lib
  else
--      install -s -m 755 bin/gcc/libm4systems.so $(prefix)/lib/libm4systems-$(VERSION).so
--      ln -sf libm4systems-$(VERSION).so $(prefix)/lib/libm4systems.so
-+      install -m 755 bin/gcc/libm4systems.so $(libdir)/libm4systems-$(VERSION).so
-+      ln -sf libm4systems-$(VERSION).so $(libdir)/libm4systems.so
-       ldconfig || true
- endif
-       install -d "$(mandir)/man1"
index 749920d6087cab2efa74479fa75321b9df8d91ff..fdc2242f39cc78b6259bb5c96d984d6a7d43123b 100644 (file)
@@ -1,22 +1,22 @@
---- gpac/configure.orig        2005-03-31 20:42:08.000000000 +0200
-+++ gpac/configure     2005-04-09 04:02:36.000000000 +0200
-@@ -588,8 +588,8 @@
+--- gpac/configure.orig        2005-07-23 19:59:27.000000000 +0200
++++ gpac/configure     2006-03-19 12:18:44.000000000 +0100
+@@ -689,8 +689,8 @@
  #look for wxWidgets support
  has_wx="no"
  wx_too_old="no"
--wx_cflags=`wx-config --cxxflags`
+-wx_cflags=`wx-config --cppflags`
 -wx_lflags=`wx-config --libs`
-+wx_cflags=`wx-gtk2-ansi-config --cxxflags`
++wx_cflags=`wx-gtk2-ansi-config --cppflags`
 +wx_lflags=`wx-gtk2-ansi-config --libs`
  
  cat > $TMPCPP << EOF
  #include <wx/wx.h>
-@@ -597,7 +597,7 @@
+@@ -698,7 +698,7 @@
  EOF
  
  if $cc $wx_cflags -o $TMPO $TMPCPP $wx_lflags > /dev/null 2>&1 ; then
 -wx_version=`wx-config --version | sed 's/[^0-9]//g'`
 +wx_version=`wx-gtk2-ansi-config --version | sed 's/[^0-9]//g'`
- if test "$wx_version" -lt 252 ; then
+ if test "$wx_version" -lt 254 ; then
  wx_too_old="yes"
  else
index 58bd64c483f93f8ec79196dfd2ed4babaae60785..f31afde4a7613a358598413b152677a3bb57556f 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
 Summary:       GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
 Summary(pl):   GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
 Name:          gpac
-Version:       0.2.4
-Release:       3
-License:       GPL
+Version:       0.4.0
+Release:       1
+License:       LGPL
 Group:         Applications
 Source0:       http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
-# Source0-md5: cbbea28e99c23d1839d38c54c2cc090a
+# Source0-md5: a8b4b3206cabda946850240f1e7aea93
 Source1:       http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
 # Source1-md5: 705f6993fbf890e92eb7a331e7c716d1
 Patch0:                %{name}-install.patch
@@ -50,6 +50,7 @@ Requires:     SDL
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define         _noautoreq   libm4systems.so
+%define         _plugindir      %{_libdir}/browser-plugins
 
 %description
 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
@@ -81,6 +82,25 @@ DSP) z prostym celem: wymaga
 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzêdzia
 do publikacji w celu dystrybucji materia³ów.
 
+%package -n browser-plugin-%{name}
+Summary:       GPAC browser plugin
+Summary(pl):   Wtyczka GPAC do przegl±derek WWW
+Group:         X11/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      browser-plugins(%{_target_cpu})
+
+%define browsers mozilla, mozilla-firefox
+
+%description -n browser-plugin-%{name}
+GPAC plugin for Netscape-compatible WWW browsers.
+
+Supported browsers: %{browsers}.
+
+%description -n browser-plugin-%{name} -l pl
+Wtyczka GPAC dla przegl±darek WWW zgodnych z Netscape.
+
+Obs³ugiwane przegl±darki: %{browsers}.
+
 %prep
 %setup -q -n gpac
 %patch0 -p1 
@@ -94,6 +114,10 @@ unzip -j 26073-530_ANSI_C_source_code.zip
 %endif
 chmod a+x configure
 
+# files for w32 and linux was swapped
+rm -rf applications/osmozilla/nsIOsmozilla.xpt_linux
+mv applications/osmozilla/nsIOsmozilla.xpt_w32 applications/osmozilla/nsIOsmozilla.xpt_linux
+
 %build
 %configure \
        --enable-oss-audio \
@@ -121,7 +145,8 @@ rm -rf $RPM_BUILD_ROOT
        mandir=$RPM_BUILD_ROOT%{_mandir} \
         plugdir=$RPM_BUILD_ROOT%{_libdir}/gpac \
         real_plugdir=%{_libdir}/gpac \
-        prefix=$RPM_BUILD_ROOT/usr
+        prefix=$RPM_BUILD_ROOT/usr \
+       MOZILLA_DIR=$RPM_BUILD_ROOT%{_plugindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -129,6 +154,35 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
+%triggerin -n browser-plugin-%{name} -- mozilla-firefox
+%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nposmozilla.so nposmozilla.xpt
+
+%triggerun -n browser-plugin-%{name} -- mozilla-firefox
+%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nposmozilla.so nposmozilla.xpt
+
+%triggerin -n browser-plugin-%{name} -- mozilla
+%nsplugin_install -d %{_libdir}/mozilla/plugins nposmozilla.so nposmozilla.xpt
+if [ -d /usr/%{_lib}/mozilla ]; then
+        umask 022
+        rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
+        if [ -x /usr/bin/regxpcom ]; then
+                MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
+        fi
+fi
+
+%triggerun -n browser-plugin-%{name} -- mozilla
+%nsplugin_uninstall -d %{_libdir}/mozilla/plugins nposmozilla.so nposmozilla.xpt
+if [ -d /usr/%{_lib}/mozilla ]; then
+        umask 022
+        rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
+        if [ -x /usr/bin/regxpcom ]; then
+                MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
+        fi
+fi
+
+%triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-%{name}
+%nsplugin_install -f -d %{_libdir}/mozilla/plugins nposmozilla.so nposmozilla.xpt
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS BUGS Changelog README TODO
@@ -137,3 +191,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/gpac
 %attr(755,root,root) %{_libdir}/gpac/*.so
 %{_mandir}/man1/*
+
+%files -n browser-plugin-%{name}
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_plugindir}/nposmozilla.so
+%attr(755,root,root) %{_plugindir}/nposmozilla.xpt
This page took 0.064219 seconds and 4 git commands to generate.