]> git.pld-linux.org Git - packages/gpac.git/commitdiff
- lets try to fix amd64
authorhawk <hawk@pld-linux.org>
Mon, 12 Jun 2006 17:16:24 +0000 (17:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gpac-amd64.patch -> 1.1
    gpac.spec -> 1.20

gpac-amd64.patch [new file with mode: 0644]
gpac.spec

diff --git a/gpac-amd64.patch b/gpac-amd64.patch
new file mode 100644 (file)
index 0000000..9c8c518
--- /dev/null
@@ -0,0 +1,88 @@
+diff -ur gpac.orig/extra_lib/include/gecko-sdk/nspr/include/md/_linux.h gpac/extra_lib/include/gecko-sdk/nspr/include/md/_linux.h
+--- gpac.orig/extra_lib/include/gecko-sdk/nspr/include/md/_linux.h     2005-07-18 17:51:49.000000000 +0200
++++ gpac/extra_lib/include/gecko-sdk/nspr/include/md/_linux.h  2006-06-12 19:10:17.766003500 +0200
+@@ -49,6 +49,8 @@
+ #define _PR_SI_ARCHITECTURE "alpha"
+ #elif defined(__ia64__)
+ #define _PR_SI_ARCHITECTURE "ia64"
++#elif defined(__x86_64__)
++#define _PR_SI_ARCHITECTURE "x86-64"
+ #elif defined(__mc68000__)
+ #define _PR_SI_ARCHITECTURE "m68k"
+ #elif defined(__sparc__)
+@@ -109,6 +111,19 @@
+ #define _MD_ATOMIC_SET                _PR_ia64_AtomicSet
+ #endif
++#if defined(__x86_64__)
++#define _PR_HAVE_ATOMIC_OPS
++#define _MD_INIT_ATOMIC()
++extern PRInt32 _PR_x86_64_AtomicIncrement(PRInt32 *val);
++#define _MD_ATOMIC_INCREMENT          _PR_x86_64_AtomicIncrement
++extern PRInt32 _PR_x86_64_AtomicDecrement(PRInt32 *val);
++#define _MD_ATOMIC_DECREMENT          _PR_x86_64_AtomicDecrement
++extern PRInt32 _PR_x86_64_AtomicAdd(PRInt32 *ptr, PRInt32 val);
++#define _MD_ATOMIC_ADD                _PR_x86_64_AtomicAdd
++extern PRInt32 _PR_x86_64_AtomicSet(PRInt32 *val, PRInt32 newval);
++#define _MD_ATOMIC_SET                _PR_x86_64_AtomicSet
++#endif
++
+ #define USE_SETJMP
+ #if defined(__GLIBC__) && __GLIBC__ >= 2
+ #define _PR_POLL_AVAILABLE
+diff -ur gpac.orig/extra_lib/include/gecko-sdk/nspr/include/prcpucfg.h gpac/extra_lib/include/gecko-sdk/nspr/include/prcpucfg.h
+--- gpac.orig/extra_lib/include/gecko-sdk/nspr/include/prcpucfg.h      2005-07-18 17:51:52.000000000 +0200
++++ gpac/extra_lib/include/gecko-sdk/nspr/include/prcpucfg.h   2006-06-12 19:09:24.586680000 +0200
+@@ -347,6 +347,52 @@
+ #define PR_BYTES_PER_WORD_LOG2  3
+ #define PR_BYTES_PER_DWORD_LOG2 3
++#elif defined(__x86_64__)
++
++#define IS_LITTLE_ENDIAN 1
++#undef  IS_BIG_ENDIAN
++#define IS_64
++
++#define PR_BYTES_PER_BYTE   1
++#define PR_BYTES_PER_SHORT  2
++#define PR_BYTES_PER_INT    4
++#define PR_BYTES_PER_INT64  8
++#define PR_BYTES_PER_LONG   8
++#define PR_BYTES_PER_FLOAT  4
++#define PR_BYTES_PER_DOUBLE 8
++#define PR_BYTES_PER_WORD   8
++#define PR_BYTES_PER_DWORD  8
++
++#define PR_BITS_PER_BYTE    8
++#define PR_BITS_PER_SHORT   16
++#define PR_BITS_PER_INT     32
++#define PR_BITS_PER_INT64   64
++#define PR_BITS_PER_LONG    64
++#define PR_BITS_PER_FLOAT   32
++#define PR_BITS_PER_DOUBLE  64
++#define PR_BITS_PER_WORD    64
++
++#define PR_BITS_PER_BYTE_LOG2   3
++#define PR_BITS_PER_SHORT_LOG2  4
++#define PR_BITS_PER_INT_LOG2    5
++#define PR_BITS_PER_INT64_LOG2  6
++#define PR_BITS_PER_LONG_LOG2   6
++#define PR_BITS_PER_FLOAT_LOG2  5
++#define PR_BITS_PER_DOUBLE_LOG2 6
++#define PR_BITS_PER_WORD_LOG2   6
++
++#define PR_ALIGN_OF_SHORT   2
++#define PR_ALIGN_OF_INT     4
++#define PR_ALIGN_OF_LONG    8
++#define PR_ALIGN_OF_INT64   8
++#define PR_ALIGN_OF_FLOAT   4
++#define PR_ALIGN_OF_DOUBLE  8
++#define PR_ALIGN_OF_POINTER 8
++#define PR_ALIGN_OF_WORD    8
++
++#define PR_BYTES_PER_WORD_LOG2  3
++#define PR_BYTES_PER_DWORD_LOG2 3
++
+ #elif defined(__mc68000__)
+ #undef  IS_LITTLE_ENDIAN
index 32ecc506e511d2bd5555f8889f71c32e1ffb76f3..203dd736cbec5cf53d75208cead70b45ee4058d8 100644 (file)
--- a/gpac.spec
+++ b/gpac.spec
@@ -27,6 +27,7 @@ Source1:      http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
 # Source1-md5: 705f6993fbf890e92eb7a331e7c716d1
 Patch0:                %{name}-install.patch
 Patch1:                %{name}-wxWidgets.patch
+Patch2:                %{name}-amd64.patch
 URL:           http://gpac.sourceforge.net/
 BuildRequires: SDL-devel
 %{?with_faad:BuildRequires:    faad2-devel}
@@ -107,6 +108,7 @@ Obs
 %setup -q -n %{name}
 %patch0 -p1
 %{?with_wx:%patch1 -p1}
+%patch2 -p1
 %if %{with amr}
 mkdir -p Plugins/amr_dec/AMR_NB
 cd Plugins/amr_dec/AMR_NB
This page took 0.61389 seconds and 4 git commands to generate.