]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- xpidl was replaced by pyxpidl tools in xulrunner-9.0
[packages/gpac.git] / gpac.spec
1 #
2 # Conditional build:
3 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
4 %bcond_without  faad            # AAC decoding support
5 %bcond_without  ffmpeg          # ffmpeg support
6 %bcond_without  freetype        # freetype support
7 %bcond_without  jpeg            # JPEG support
8 %bcond_without  js              # JavaScript support
9 %bcond_without  mad             # MP3 support
10 %bcond_without  png             # PNG support
11 %bcond_without  xvid            # xvid support
12 %bcond_without  wx              # wxWidgets support
13 #
14 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
15 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
16 Name:           gpac
17 Version:        0.4.5
18 Release:        8
19 License:        LGPL v2+
20 Group:          Applications/Multimedia
21 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
22 # Source0-md5:  755e8c438a48ebdb13525dd491f5b0d1
23 Patch0:         %{name}-install.patch
24 Patch1:         %{name}-libpng.patch
25 Patch2:         %{name}-pic.patch
26 Patch3:         %{name}-xulrunner.patch
27 Patch4:         %{name}-amr.patch
28 Patch5:         %{name}-ffmpeg.patch
29 Patch6:         %{name}-install-is-not-clean.patch
30 Patch7:         %{name}-flags.patch
31 Patch8:         %{name}-ffmpeg-0.8.patch
32 Patch9:         %{name}-idl_uuid.patch
33 URL:            http://gpac.sourceforge.net/
34 BuildRequires:  SDL-devel
35 BuildRequires:  a52dec-libs-devel
36 BuildRequires:  alsa-lib-devel >= 0.9
37 %{?with_amr:BuildRequires:      amrnb-devel}
38 %{?with_amr:BuildRequires:      amrwb-devel}
39 %{?with_faad:BuildRequires:     faad2-devel}
40 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
41 %{?with_freetype:BuildRequires: freetype-devel}
42 BuildRequires:  jack-audio-connection-kit-devel
43 %{?with_js:BuildRequires:       js-devel}
44 %{?with_jpeg:BuildRequires:     libjpeg-devel}
45 %{?with_mad:BuildRequires:      libmad-devel}
46 BuildRequires:  libogg-devel
47 %{?with_png:BuildRequires:      libpng-devel}
48 BuildRequires:  libtheora-devel
49 BuildRequires:  libvorbis-devel
50 BuildRequires:  libxml2-devel
51 BuildRequires:  openjpeg-devel
52 BuildRequires:  pulseaudio-devel
53 BuildRequires:  rpmbuild(macros) >= 1.357
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  unzip
56 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
57 BuildRequires:  xmlrpc-c-server-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXv-devel
60 BuildRequires:  xulrunner-devel >= 2:9.0.0
61 %{?with_xvid:BuildRequires:     xvid-devel}
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
66 14496-1) developed from scratch in ANSI C.
67
68 The main development goal is to provide a clean (a.k.a. readable by as
69 many people as possible), small and flexible alternative to the MPEG-4
70 Systems reference software (known as IM1 and distributed in ISO/IEC
71 14496-5). The MPEG-4 Reference software is indeed a very large piece
72 of software, designed to verify the standard rather than provide a
73 small, production-stable software. GPAC is written in ANSI C for
74 portability reasons (embedded platforms and DSPs) with a simple goal:
75 keep the memory footprint as low as possible. The project will at term
76 provide player(s), systems encoders and publishing tools for content
77 distribution.
78
79 %description -l pl.UTF-8
80 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
81 stworzona od zera w ANSI C.
82
83 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
84 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
85 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
86 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
87 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
88 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
89 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
90 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
91 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
92 do publikacji w celu dystrybucji materiałów.
93
94 %package devel
95 Summary:        Header files for GPAC library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPAC
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description devel
101 Header files for GPAC library.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe biblioteki GPAC.
105
106 %package gui
107 Summary:        wxWidgets-based GUI for GPAC
108 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
109 Group:          X11/Applications/Multimedia
110 Requires:       %{name} = %{version}-%{release}
111
112 %description gui
113 Osmo4 - wxWidgets-based GUI for GPAC.
114
115 %description gui -l pl.UTF-8
116 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
117
118 %package -n browser-plugin-%{name}
119 Summary:        GPAC browser plugin
120 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
121 Group:          X11/Libraries
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       browser-plugins >= 2.0
124 Requires:       browser-plugins(%{_target_base_arch})
125
126 %description -n browser-plugin-%{name}
127 GPAC plugin for Netscape-compatible WWW browsers.
128
129 %description -n browser-plugin-%{name} -l pl.UTF-8
130 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
131
132 %prep
133 %setup -q -n %{name}
134 %patch0 -p1
135 %patch1 -p1
136 %patch2 -p1
137 %patch3 -p1
138 %patch4 -p1
139 %patch5 -p1
140 %patch6 -p1
141 %patch7 -p1
142 %patch8 -p1
143 %patch9 -p1
144
145 %if %{with amr}
146 sed -i -e 's/amr_\([nw]b\)_ft/amr\1/' modules/amr_float_dec/amr_float_dec.c
147 %endif
148 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
149 chmod a+x configure
150
151 %build
152 cd applications/osmozilla
153 /usr/lib/xulrunner-sdk/sdk/bin/header.py -I /usr/share/idl/xulrunner -o nsIOsmozilla.h nsIOsmozilla.idl
154 /usr/lib/xulrunner-sdk/sdk/bin/typelib.py -I /usr/share/idl/xulrunner -o nsIOsmozilla.xpt nsIOsmozilla.idl
155 cp -f nsIOsmozilla.xpt nsIOsmozilla.xpt_linux
156 cd ../..
157 %configure \
158         --X11-path=/usr \
159         --cc="%{__cc}" \
160         --disable-opt \
161         %{!?with_wx:--disable-wx} \
162         %{?with_amr:--enable-amr} \
163         --enable-joystick \
164         --enable-pic \
165         --extra-cflags="%{rpmcflags}" \
166         --extra-ldflags="%{rpmldflags}" \
167         --mozdir=%{_browserpluginsdir} \
168         %{!?with_faad:--use-faad=no} \
169         %{!?with_ffmpeg:--use-ffmpeg=no} \
170         %{!?with_freetype:--use-ft=no} \
171         %{!?with_jpeg:--use-jpeg=no} \
172         %{!?with_js:--use-js=no} \
173         %{!?with_mad:--use-mad=no} \
174         %{!?with_png:--use-png=no} \
175         %{!?with_xvid:--use-xvid=no} \
176         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
177
178 %{__make} -j1 \
179         BUILD_INSTALL=yes \
180         CXX="%{__cxx} -fPIC" \
181         libdir=%{_lib}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT \
188         libdir=%{_lib} \
189         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
190
191 install -d $RPM_BUILD_ROOT%{_includedir}
192 cp -a include/gpac $RPM_BUILD_ROOT%{_includedir}/gpac
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %post   -p /sbin/ldconfig
198 %postun -p /sbin/ldconfig
199
200 %post -n browser-plugin-%{name}
201 %update_browser_plugins
202
203 %postun -n browser-plugin-%{name}
204 if [ "$1" = 0 ]; then
205         %update_browser_plugins
206 fi
207
208 %files
209 %defattr(644,root,root,755)
210 %doc AUTHORS BUGS Changelog README TODO
211 %attr(755,root,root) %{_bindir}/MP4Box
212 %attr(755,root,root) %{_bindir}/MP4Client
213 %attr(755,root,root) %{_libdir}/libgpac-%{version}.so
214 %attr(755,root,root) %ghost %{_libdir}/libgpac.so
215 %dir %{_libdir}/gpac
216 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
217 %{_datadir}/gpac
218 %{_mandir}/man1/gpac.1*
219 %{_mandir}/man1/mp4box.1*
220 %{_mandir}/man1/mp4client.1*
221
222 %files devel
223 %defattr(644,root,root,755)
224 %{_includedir}/gpac
225
226 %if %{with wx}
227 %files gui
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_bindir}/Osmo4
230 %endif
231
232 %files -n browser-plugin-%{name}
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
235 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.039595 seconds and 3 git commands to generate.