]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.1.6
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_with     tpm     # TPM support in gnutls (cannot be used with GPL programs)
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.1.6
11 Release:        1
12 License:        LGPL v3+ (libgnutls), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.1/%{name}-%{version}.tar.lz
15 # Source0-md5:  770d3ed5adfb67b075b5b398f13f484c
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-pl.po-update.patch
19 Patch3:         %{name}-am.patch
20 URL:            http://www.gnutls.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11.3
23 BuildRequires:  gettext-devel >= 0.18
24 BuildRequires:  gtk-doc >= 1.1
25 BuildRequires:  guile-devel >= 5:2.0
26 BuildRequires:  libcfg+-devel
27 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
28 BuildRequires:  libidn-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtasn1-devel >= 2.14
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  lzip
33 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.5}
34 # miniopencdk is included in sources and currently maintained
35 # as part of gnutls, not external package
36 #BuildRequires: opencdk-devel >= 0.6.6
37 BuildRequires:  p11-kit-devel >= 0.11
38 BuildRequires:  pkgconfig
39 BuildRequires:  readline-devel
40 BuildRequires:  rpmbuild(macros) >= 1.383
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  texinfo >= 4.8
44 %{?with_tpm:BuildRequires:      trousers-devel}
45 %{?with_dane:BuildRequires:     unbound-devel}
46 BuildRequires:  zlib-devel
47 Requires(post,postun):  /sbin/ldconfig
48 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
49 Requires:       libtasn1 >= 2.14
50 %{!?with_gcrypt:Requires:       nettle >= 2.5}
51 #Requires:      opencdk >= 0.6.6
52 Requires:       p11-kit >= 0.11
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 GnuTLS is a project that aims to develop a library which provides a
57 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
58 the gnuTLS library implements the proposed standards by the IETF's TLS
59 working group.
60
61 %description -l pl.UTF-8
62 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
63 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
64 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
65 grupę roboczą IETF TLS.
66
67 %package devel
68 Summary:        Header files etc to develop gnutls applications
69 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
70 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
74 Requires:       libtasn1-devel >= 2.14
75 %{!?with_gcrypt:Requires:       nettle-devel >= 2.5}
76 #Requires:      opencdk-devel >= 0.6.6
77 Requires:       p11-kit-devel >= 0.11
78 %{?with_tpm:Requires:   trousers-devel}
79 %{?with_dane:Requires:  unbound-devel}
80 Requires:       zlib-devel
81
82 %description devel
83 Header files etc to develop gnutls applications.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe i inne do gnutls.
87
88 %package static
89 Summary:        Static gnutls library
90 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
91 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static gnutls library.
97
98 %description static -l pl.UTF-8
99 Biblioteka statyczna gnutls.
100
101 %package c++
102 Summary:        libgnutlsxx - C++ interface to gnutls library
103 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
104 License:        LGPL v2.1+
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description c++
109 libgnutlsxx - C++ interface to gnutls library.
110
111 %description c++ -l pl.UTF-8
112 libgnutlsxx - interfejs C++ do biblioteki gnutls.
113
114 %package c++-devel
115 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
116 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
117 License:        LGPL v2.1+
118 Group:          Development/Libraries
119 Requires:       %{name}-c++ = %{version}-%{release}
120 Requires:       %{name}-devel = %{version}-%{release}
121 Requires:       libstdc++-devel
122
123 %description c++-devel
124 Header files for libgnutlsxx, a C++ interface to gnutls library.
125
126 %description c++-devel -l pl.UTF-8
127 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
128
129 %package c++-static
130 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
131 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
132 License:        LGPL v2.1+
133 Group:          Development/Libraries
134 Requires:       %{name}-c++-devel = %{version}-%{release}
135
136 %description c++-static
137 Static version of libgnutlsxx, a C++ interface to gnutls library.
138
139 %description c++-static -l pl.UTF-8
140 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
141
142 %package -n guile-gnutls
143 Summary:        Guile bindings for GnuTLS
144 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
145 License:        LGPL v2.1+
146 Group:          Development/Languages
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       guile >= 5:2.0
149
150 %description -n guile-gnutls
151 Guile bindings for GnuTLS.
152
153 %description -n guile-gnutls -l pl.UTF-8
154 Wiązania Guile do GnuTLS.
155
156 %prep
157 %setup -q
158 %patch0 -p1
159 %patch1 -p1
160 %patch2 -p1
161 %patch3 -p1
162
163 %{__rm} po/stamp-po
164
165 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
166 # (after gnutls or libtool change)
167 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
168
169 %build
170 %{__libtoolize}
171 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
172 %{__autoconf}
173 %{__autoheader}
174 %{__automake}
175 %configure \
176         --disable-silent-rules \
177         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
178         %{?with_gcrypt:--with-libgcrypt} \
179         %{?with_tpm:--with-tpm}
180
181 # docs build is broken with -jN
182 %{__make} -j1
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 # although libgnutls.la is obsoleted by pkg-config, there is
191 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
192
193 # guile module - dynamic only
194 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
195
196 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
197
198 %find_lang %{name}
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post
204 /sbin/ldconfig
205 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
206
207 %postun
208 /sbin/ldconfig
209 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
210
211 %post   c++ -p /sbin/ldconfig
212 %postun c++ -p /sbin/ldconfig
213
214 %post   -n guile-gnutls -p /sbin/ldconfig
215 %postun -n guile-gnutls -p /sbin/ldconfig
216
217 %files -f %{name}.lang
218 %defattr(644,root,root,755)
219 %doc AUTHORS ChangeLog NEWS README THANKS
220 %attr(755,root,root) %{_bindir}/certtool
221 %attr(755,root,root) %{_bindir}/crywrap
222 %{?with_dane:%attr(755,root,root) %{_bindir}/danetool}
223 %attr(755,root,root) %{_bindir}/gnutls-*
224 %attr(755,root,root) %{_bindir}/ocsptool
225 %attr(755,root,root) %{_bindir}/p11tool
226 %attr(755,root,root) %{_bindir}/psktool
227 %attr(755,root,root) %{_bindir}/srptool
228 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
229 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
230 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
231 %if %{with dane}
232 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
233 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
234 %endif
235 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
236 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
237 %{_mandir}/man1/certtool.1*
238 %{?with_dane:%{_mandir}/man1/danetool.1*}
239 %{_mandir}/man1/gnutls-*.1*
240 %{_mandir}/man1/ocsptool.1*
241 %{_mandir}/man1/p11tool.1*
242 %{_mandir}/man1/psktool.1*
243 %{_mandir}/man1/srptool.1*
244 %{_mandir}/man1/tpmtool.1*
245 %{_infodir}/gnutls.info*
246 %{_infodir}/gnutls-*.png
247 %{_infodir}/pkcs11-vision.png
248
249 %files devel
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/libgnutls.so
252 %{?with_dane:%attr(755,root,root) %{_libdir}/libgnutls-dane.so}
253 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
254 %{_libdir}/libgnutls.la
255 %{?with_dane:%{_libdir}/libgnutls-dane.la}
256 %{_libdir}/libgnutls-openssl.la
257 %{_includedir}/gnutls
258 %exclude %{_includedir}/gnutls/gnutlsxx.h
259 %{_pkgconfigdir}/gnutls.pc
260 %{?with_dane:%{_pkgconfigdir}/gnutls-dane.pc}
261 %{_mandir}/man3/gnutls_*.3*
262
263 %files static
264 %defattr(644,root,root,755)
265 %{_libdir}/libgnutls.a
266 %{?with_dane:%{_libdir}/libgnutls-dane.a}
267 %{_libdir}/libgnutls-openssl.a
268
269 %files c++
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
272 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
273
274 %files c++-devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
277 %{_libdir}/libgnutlsxx.la
278 %{_includedir}/gnutls/gnutlsxx.h
279
280 %files c++-static
281 %defattr(644,root,root,755)
282 %{_libdir}/libgnutlsxx.a
283
284 %files -n guile-gnutls
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
287 %{_datadir}/guile/site/gnutls.scm
288 %{_datadir}/guile/site/gnutls
289 %{_infodir}/gnutls-guile.info*
This page took 0.054314 seconds and 3 git commands to generate.