]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- up to 0.12.0
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  portaudio       # gsnd tool
5 #
6 Summary:        GNUstep GUI library package
7 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
8 Name:           gnustep-gui
9 %define ver     0.12
10 Version:        %{ver}.0
11 Release:        1
12 License:        LGPL/GPL
13 Group:          Libraries
14 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
15 # Source0-md5:  13f1ec9910a99105ed0f1f79f2ff2db0
16 Patch0:         %{name}-themes.patch
17 Patch1:         %{name}-nocompressdocs.patch
18 Patch2:         %{name}-segv.patch
19 Patch3:         %{name}-doc.patch
20 URL:            http://www.gnustep.org/
21 BuildRequires:  aspell-devel
22 BuildRequires:  audiofile-devel
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  gcc-objc
25 BuildRequires:  giflib-devel
26 BuildRequires:  gnustep-base-devel >= 1.13.0
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtiff-devel
30 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
31 BuildRequires:  zlib-devel
32 Requires:       gnustep-base >= 1.13.0
33 Conflicts:      gnustep-core
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 It is a library of graphical user interface classes written completely
38 in the Objective-C language; the classes are based upon the OpenStep
39 specification as release by NeXT Software, Inc. The library does not
40 completely conform to the specification and has been enhanced in a
41 number of ways to take advantage of the GNU system. These classes
42 include graphical objects such as buttons, text fields, popup lists,
43 browser lists, and windows; there are also many associated classes for
44 handling events, colors, fonts, pasteboards and images.
45
46 %description -l pl.UTF-8
47 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
48 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
49 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
50 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
51 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
52 rozwijane, listy przewijane i okienka; jest także wiele klas do
53 obsługi zdarzeń, kolorów, fontów i obrazków.
54
55 %package devel
56 Summary:        GNUstep GUI headers and libs
57 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       audiofile-devel
61 Requires:       gnustep-base-devel >= 1.13.0
62 Requires:       libjpeg-devel
63 Requires:       libtiff-devel
64 Conflicts:      gnustep-core
65
66 %description devel
67 Header files required to build applications against the GNUstep GUI
68 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
72 biblioteki GNUstep GUI.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80
81 %build
82 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
83 export GNUSTEP_FLATTENED=yes
84 # disable gsnd - not ready for current portaudio
85 %configure \
86         %{!?with_cups:--disable-cups} \
87         %{!?with_portaudio:--disable-gsnd}
88
89 %{__make} \
90         messages=yes
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
95 export GNUSTEP_FLATTENED=yes
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %{__make} install -C Documentation \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
104         -type f -name .cvsignore | xargs rm -f
105
106 # not (yet?) supported by rpm-compress-doc
107 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
108         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc ChangeLog
119 %docdir %{_datadir}/GNUstep/Documentation
120 %dir %{_datadir}/GNUstep/Documentation/Developer
121 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
122 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
123 %{_datadir}/GNUstep/Documentation/User
124
125 %{_mandir}/man1/*
126
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*
129
130 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
131 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
132 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
133 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
134 %if %{with cups}
135 # R: cups-lib - separate?
136 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
137 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
138 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
139 %endif
140
141 %dir %{_libdir}/GNUstep/Bundles/TextConverters
142 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
143 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
144 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
145 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
146 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
147 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
148
149 %dir %{_libdir}/GNUstep/ColorPickers
150 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
151 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
152 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
153 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
154 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
155 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
156 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
157 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
158 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
159 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
160 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
161 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
162 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
163 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
164
165 %{_libdir}/GNUstep/Images/*
166 %{_libdir}/GNUstep/KeyBindings/*.dict
167
168 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
169 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
170 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
171 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
172 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
173 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
174 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
175 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
176 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
177 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
178
179 %dir %{_libdir}/GNUstep/PostScript
180 %{_libdir}/GNUstep/PostScript/GSProlog.ps
181 %dir %{_libdir}/GNUstep/PostScript/PPD
182 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
183 %dir %{_libdir}/GNUstep/Services/GSspell.service
184 %{_libdir}/GNUstep/Services/GSspell.service/Resources
185 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
186
187 %files devel
188 %defattr(644,root,root,755)
189 %docdir %{_datadir}/GNUstep/Documentation
190 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
191 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
192 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
193 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
194 %{_infodir}/*.info*
195
196 %{_includedir}/AppKit
197 %{_includedir}/Cocoa
198 %{_includedir}/GNUstepGUI
199 %{_includedir}/gnustep/gui
200
201 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
202 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.091728 seconds and 4 git commands to generate.