]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- rebuild with new Headers directory layout, release 2
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.8.8
5 Release:        2
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  cf555e09fb1074a74e850ccfc5c6652b
10 Patch0:         %{name}-themes.patch
11 URL:            http://www.gnustep.org/
12 BuildRequires:  audiofile-devel
13 BuildRequires:  gcc-objc
14 BuildRequires:  gnustep-base-devel >= 1.7.3
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libtiff-devel
17 BuildRequires:  zlib-devel
18 Requires:       gnustep-base >= 1.7.3
19 Conflicts:      gnustep-core
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _prefix         /usr/lib/GNUstep
23
24 %define         libcombo        gnu-gnu-gnu
25 %define         gsos            linux-gnu
26 %ifarch %{ix86}
27 %define         gscpu           ix86
28 %else
29 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
30 %define         gscpu           %{_target_cpu}
31 %endif
32
33 %description
34 It is a library of graphical user interface classes written completely
35 in the Objective-C language; the classes are based upon the OpenStep
36 specification as release by NeXT Software, Inc. The library does not
37 completely conform to the specification and has been enhanced in a
38 number of ways to take advantage of the GNU system. These classes
39 include graphical objects such as buttons, text fields, popup lists,
40 browser lists, and windows; there are also many associated classes for
41 handling events, colors, fonts, pasteboards and images.
42
43 %description -l pl
44 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
45 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
46 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
47 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
48 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
49 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
50 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
51
52 %package devel
53 Summary:        GNUstep GUI headers and libs
54 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}
57 Requires:       audiofile-devel
58 Requires:       gnustep-base-devel >= 1.7.3
59 Requires:       libjpeg-devel
60 Requires:       libtiff-devel
61 Conflicts:      gnustep-core
62
63 %description devel
64 Header files required to build applications against the GNUstep GUI
65 library.
66
67 %description devel -l pl
68 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
69 biblioteki GNUstep GUI.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
77 %configure
78
79 %{__make} \
80         messages=yes
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
85
86 %{__make} install \
87         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
88         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
89
90 # not (yet?) supported by rpm-compress-doc
91 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
92         -type f -a ! -name '*.html' | xargs gzip -9nf
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog
103
104 %docdir %{_prefix}/System/Library/Documentation
105 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
106 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
107
108 %dir %{_prefix}/System/Library/Bundles/TextConverters
109 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
110 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
111 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
112 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
113 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
114 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
115
116 %dir %{_prefix}/System/Library/ColorPickers
117 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
118 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
119 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
120 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
121 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
122 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
123 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
124 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
125 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
126 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
127 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
128
129 %dir %{_prefix}/System/Applications/md5Digest.app
130 %dir %{_prefix}/System/Applications/md5Digest.app/Resources
131 %{_prefix}/System/Applications/md5Digest.app/Resources/*.desktop
132 %{_prefix}/System/Applications/md5Digest.app/Resources/*.plist
133 %attr(755,root,root) %{_prefix}/System/Applications/md5Digest.app/%{gscpu}
134 %attr(755,root,root) %{_prefix}/System/Applications/md5Digest.app/md5Digest
135
136 %{_prefix}/System/Library/Images/*
137 %{_prefix}/System/Library/KeyBindings/*.dict
138
139 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
140 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
141 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
142
143 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
144
145 %dir %{_prefix}/System/Library/PostScript
146 %{_prefix}/System/Library/PostScript/GSProlog.ps
147 %{_prefix}/System/Library/PostScript/Printers
148 %dir %{_prefix}/System/Library/PostScript/PPD
149 %{_prefix}/System/Library/PostScript/PPD/English.lproj
150 %lang(fr) %{_prefix}/System/Library/PostScript/PPD/French.lproj
151 %lang(de) %{_prefix}/System/Library/PostScript/PPD/German.lproj
152 %lang(it) %{_prefix}/System/Library/PostScript/PPD/Italian.lproj
153 %lang(es) %{_prefix}/System/Library/PostScript/PPD/Spanish.lproj
154 %lang(sv) %{_prefix}/System/Library/PostScript/PPD/Swedish.lproj
155
156 %dir %{_prefix}/System/Library/Services/GSspell.service
157 %{_prefix}/System/Library/Services/GSspell.service/Resources
158 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
159 %dir %{_prefix}/System/Library/Services/example.service
160 %{_prefix}/System/Library/Services/example.service/Resources
161 %attr(755,root,root) %{_prefix}/System/Library/Services/example.service/%{gscpu}
162
163 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %docdir %{_prefix}/System/Library/Documentation
168 %{_prefix}/System/Library/Documentation/Developer/Gui/Manual
169 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
170 %{_prefix}/System/Library/Documentation/info/*.info*
171
172 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
173 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
174
175 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
176 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.088496 seconds and 4 git commands to generate.