]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- reverted evil changes (caused some wrong file permissions and directories
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.8.4
5 Release:        0.1
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 URL:            http://www.gnustep.org/
10 BuildRequires:  audiofile-devel
11 BuildRequires:  gcc-objc
12 BuildRequires:  gnustep-base-devel
13 BuildRequires:  libjpeg-devel
14 BuildRequires:  libtiff-devel
15 BuildRequires:  zlib-devel
16 Requires:       gnustep-base
17 Conflicts:      gnustep-core
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _prefix         /usr/lib/GNUstep
21
22 %define         libcombo        gnu-gnu-gnu
23 %define         gsos            linux-gnu
24 %ifarch %{ix86}
25 %define         gscpu           ix86
26 %else
27 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
28 %define         gscpu           %{_target_cpu}
29 %endif
30
31 %description
32 It is a library of graphical user interface classes written completely
33 in the Objective-C language; the classes are based upon the OpenStep
34 specification as release by NeXT Software, Inc. The library does not
35 completely conform to the specification and has been enhanced in a
36 number of ways to take advantage of the GNU system. These classes
37 include graphical objects such as buttons, text fields, popup lists,
38 browser lists, and windows; there are also many associated classes for
39 handling events, colors, fonts, pasteboards and images.
40
41 %description -l pl
42 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
43 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
44 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
45 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
46 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
47 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
48 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
49
50 %package devel
51 Summary:        GNUstep GUI headers and libs
52 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}
55 Requires:       audiofile-devel
56 Requires:       gnustep-base-devel
57 Requires:       libjpeg-devel
58 Requires:       libtiff-devel
59 Conflicts:      gnustep-core
60
61 %description devel
62 Header files required to build applications against the GNUstep GUI
63 library.
64
65 %description devel -l pl
66 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
67 biblioteki GNUstep GUI.
68
69 %prep
70 %setup -q
71
72 %build
73 . %{_prefix}/System/Makefiles/GNUstep.sh
74 %configure
75
76 %{__make} \
77         messages=yes
78
79 %{__make} -C Documentation
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 . %{_prefix}/System/Makefiles/GNUstep.sh
84
85 %{__make} install \
86         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
87         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
88
89 %{__make} install -C Documentation \
90         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
91
92 # not (yet?) supported by rpm-compress-doc
93 find $RPM_BUILD_ROOT%{_prefix}/System/Documentation \
94         -type f -a ! -name '*.html' | xargs gzip -9nf
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ChangeLog
105
106 %{_prefix}/System/Documentation/info/*.info*
107
108 %{_prefix}/System/Libraries/Resources/English.lproj/*
109 %{_prefix}/System/Libraries/Resources/Images
110 %{_prefix}/System/Libraries/Resources/KeyBindings
111 %dir %{_prefix}/System/Libraries/Resources/PrinterTypes
112 %{_prefix}/System/Libraries/Resources/PrinterTypes/GSProlog.ps
113 %{_prefix}/System/Libraries/Resources/PrinterTypes/Printers
114 %{_prefix}/System/Libraries/Resources/PrinterTypes/English.lproj
115 %lang(fr) %{_prefix}/System/Libraries/Resources/PrinterTypes/French.lproj
116 %lang(de) %{_prefix}/System/Libraries/Resources/PrinterTypes/German.lproj
117 %lang(it) %{_prefix}/System/Libraries/Resources/PrinterTypes/Italian.lproj
118 %lang(es) %{_prefix}/System/Libraries/Resources/PrinterTypes/Spanish.lproj
119 %lang(sv) %{_prefix}/System/Libraries/Resources/PrinterTypes/Swedish.lproj
120 %dir %{_prefix}/System/Libraries/Resources/gnustep-gui
121 %dir %{_prefix}/System/Libraries/Resources/gnustep-gui/Resources
122 %{_prefix}/System/Libraries/Resources/gnustep-gui/Resources/English.lproj
123 %lang(it) %{_prefix}/System/Libraries/Resources/gnustep-gui/Resources/Italian.lproj
124
125 %{_prefix}/System/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
126
127 %dir %{_prefix}/System/Library/Bundles/TextConverters
128 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
129 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
130 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
131 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
132 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
133 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
134 %dir %{_prefix}/System/Library/ColorPickers
135 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
136 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
137 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
138 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
139 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
140 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
141 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
142 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
143 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
144 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
145 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
146
147 %{_prefix}/System/Library/Model
148
149 %dir %{_prefix}/System/Library/Services/GSspell.service
150 %{_prefix}/System/Library/Services/GSspell.service/Resources
151 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
152 %dir %{_prefix}/System/Library/Services/example.service
153 %{_prefix}/System/Library/Services/example.service/Resources
154 %attr(755,root,root) %{_prefix}/System/Library/Services/example.service/%{gscpu}
155
156 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %{_prefix}/System/Documentation/Developer/Gui
161 %{_prefix}/System/Headers/AppKit
162 %{_prefix}/System/Headers/gnustep/gui
163 %{_prefix}/System/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
164 %{_prefix}/System/Makefiles/Additional/gui.make
This page took 0.104751 seconds and 3 git commands to generate.