]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- libwraster (WindowMaker) no longer used
[packages/gnustep-back.git] / gnustep-back.spec
1 #
2 # Conditional build:
3 %bcond_without art      # don't build art backend
4 #
5 Summary:        The GNUstep backend bundle
6 Summary(pl):    Pakiet backendowy GNUstep
7 Name:           gnustep-back
8 Version:        0.9.3
9 Release:        1
10 License:        LGPL/GPL
11 Vendor:         The GNUstep Project
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
14 # Source0-md5:  2ee883c140eb7cf47bb284b2f72c1adc
15 Patch0:         %{name}-freetype.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  XFree86-devel
19 BuildRequires:  XFree86-DPS-devel
20 %{?with_art:BuildRequires:      freetype-devel >= 2.1.4}
21 BuildRequires:  gnustep-gui-devel >= %{version}
22 %{?with_art:BuildRequires:      libart_lgpl-devel}
23 BuildRequires:  xft-devel
24 Requires:       OpenGL
25 Requires:       gnustep-gui >= %{version}
26 Obsoletes:      gnustep-back-devel
27 Obsoletes:      gnustep-xgps
28 Conflicts:      gnustep-core
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/%{_lib}/GNUstep
32
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
34
35 %define         libcombo        gnu-gnu-gnu
36 %define         gsos            linux-gnu
37 %ifarch %{ix86}
38 %define         gscpu           ix86
39 %else
40 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
41 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
42 %endif
43
44 %description
45 This is a backend for the GNUstep gui Library which allows you to use
46 the GNUstep gui Library on an X Window System (other backends will
47 be added later to allow you to use the GNUstep gui Library in other
48 windowing environments).
49
50 This package contains common part and xlib graphics backend.
51
52 %description -l pl
53 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
54 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
55 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
56 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
57
58 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
59
60 %package art
61 Summary:        GNUstep graphics backend - art
62 Summary(pl):    Graficzny backend GNUstep - art
63 Group:          X11/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       freetype >= 2.1.4
66 Conflicts:      gnustep-core
67
68 %description art
69 GNUstep graphics backend - art.
70
71 %description art -l pl
72 Graficzny backend GNUstep - art.
73
74 %package xdps
75 Summary:        GNUstep graphics backend - xdps
76 Summary(pl):    Graficzny backend GNUstep - xdps
77 Group:          X11/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Obsoletes:      gnustep-xdps
80 Conflicts:      gnustep-core
81
82 %description xdps
83 GNUstep graphics backend - xdps.
84
85 %description xdps -l pl
86 Graficzny backend GNUstep - xdps.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 # prepare three trees (for art, xdps and xlib backends)
93 echo * > files.list
94 %if %{with art}
95 install -d back-art 
96 cp -a `cat files.list` back-art
97 %endif
98 install -d back-xdps
99 cp -a `cat files.list` back-xdps
100 ln -sf . back-xlib
101
102 %build
103 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
104
105 for g in %{?with_art:art} xdps xlib ; do
106 cd back-$g
107 if [ "$g" = "xlib" ]; then
108         INC='--with-include-flags=-I/usr/include/freetype2'
109         NAME="back"
110 else
111         INC=
112         NAME="back-$g"
113 fi
114 %configure \
115         --enable-graphics=$g \
116         --with-name=$NAME \
117         $INC
118
119 %{__make} \
120         messages=yes
121 cd ..
122 done
123
124 %{__make} -C Documentation
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
129
130 for g in %{?with_art:art} xdps xlib ; do
131 if [ "$g" = "xlib" ]; then
132         NAME="back"
133 else
134         NAME="back-$g"
135 fi
136 %{__make} install -C back-$g \
137         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
138         BUILD_GRAPHICS="$g" \
139         BACKEND_NAME="$NAME"
140 done
141
142 %{__make} install -C Documentation \
143         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
144
145 # not (yet?) supported by rpm-compress-doc
146 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
147         ! -name '*.gz' | xargs gzip -9nf
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc ChangeLog
158 %docdir %{_prefix}/System/Library/Documentation
159 %{_prefix}/System/Library/Documentation/Developer/Back
160 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
161
162 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
163 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
164 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
165
166 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
167
168 %if %{with art}
169 %files art
170 %defattr(644,root,root,755)
171 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
172 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
173 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
174 %endif
175
176 %files xdps
177 %defattr(644,root,root,755)
178 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
179 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
180 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.050247 seconds and 4 git commands to generate.