]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- disable cairo
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 # - reenable cairo as soon as versions >= 0.5 will be supported
4 #
5 # Conditional build:
6 %bcond_without  art     # don't build art backend
7 %bcond_with     cairo   # don't build cairo backend
8 #
9 Summary:        The GNUstep backend bundle
10 Summary(pl):    Pakiet backendowy GNUstep
11 Name:           gnustep-back
12 Version:        0.10.0
13 Release:        2
14 License:        LGPL/GPL
15 Vendor:         The GNUstep Project
16 Group:          X11/Libraries
17 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
18 # Source0-md5:  8031e2d93b4d3359e167be620d1925fb
19 URL:            http://www.gnustep.org/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  XFree86-DPS-devel
23 %{?with_cairo:BuildRequires:    cairo-devel < 0.5.0}
24 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
25 BuildRequires:  gnustep-gui-devel >= %{version}
26 %{?with_art:BuildRequires:      libart_lgpl-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  xft-devel
29 Requires:       OpenGL
30 Requires:       gnustep-gui >= %{version}
31 Obsoletes:      gnustep-back-devel
32 Obsoletes:      gnustep-xgps
33 Conflicts:      gnustep-core
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _prefix         /usr/%{_lib}/GNUstep
37
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
39
40 %define         libcombo        gnu-gnu-gnu
41 %define         gsos            linux-gnu
42 %ifarch %{ix86}
43 %define         gscpu           ix86
44 %else
45 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
46 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
47 %endif
48
49 %description
50 This is a backend for the GNUstep gui Library which allows you to use
51 the GNUstep gui Library on an X Window System (other backends will
52 be added later to allow you to use the GNUstep gui Library in other
53 windowing environments).
54
55 This package contains common part and xlib graphics backend.
56
57 %description -l pl
58 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
59 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
60 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
61 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
62
63 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
64
65 %package art
66 Summary:        GNUstep graphics backend - art
67 Summary(pl):    Graficzny backend GNUstep - art
68 Group:          X11/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       freetype >= 2.1.8
71 Conflicts:      gnustep-core
72
73 %description art
74 GNUstep graphics backend - art.
75
76 %description art -l pl
77 Graficzny backend GNUstep - art.
78
79 %package cairo
80 Summary:        GNUstep graphics backend - cairo
81 Summary(pl):    Graficzny backend GNUstep - cairo
82 Group:          X11/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       cairo < 0.5.0
85
86 %description cairo
87 GNUstep graphics backend - cairo.
88
89 %description cairo -l pl
90 Graficzny backend GNUstep - cairo.
91
92 %package xdps
93 Summary:        GNUstep graphics backend - xdps
94 Summary(pl):    Graficzny backend GNUstep - xdps
95 Group:          X11/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Obsoletes:      gnustep-xdps
98 Conflicts:      gnustep-core
99
100 %description xdps
101 GNUstep graphics backend - xdps.
102
103 %description xdps -l pl
104 Graficzny backend GNUstep - xdps.
105
106 %prep
107 %setup -q
108
109 # prepare the trees (for art, cairo, xdps, xlib backends)
110 echo * > files.list
111 %if %{with art}
112 install -d back-art 
113 cp -a `cat files.list` back-art
114 %endif
115 %if %{with cairo}
116 install -d back-cairo
117 cp -a `cat files.list` back-cairo
118 %endif
119 install -d back-xdps
120 cp -a `cat files.list` back-xdps
121 ln -sf . back-xlib
122
123 %build
124 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
125
126 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
127 cd back-$g
128 if [ "$g" = "xlib" ]; then
129         INC='--with-include-flags=-I/usr/include/freetype2'
130         NAME="back"
131 else
132         INC=
133         NAME="back-$g"
134 fi
135 %configure \
136         --enable-graphics=$g \
137         --with-name=$NAME \
138         $INC
139
140 %{__make} \
141         messages=yes
142 cd ..
143 done
144
145 %{__make} -C Documentation
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
150
151 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
152 if [ "$g" = "xlib" ]; then
153         NAME="back"
154 else
155         NAME="back-$g"
156 fi
157 %{__make} install -C back-$g \
158         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
159         BUILD_GRAPHICS="$g" \
160         BACKEND_NAME="$NAME"
161 done
162
163 %{__make} install -C Documentation \
164         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
165
166 # not (yet?) supported by rpm-compress-doc
167 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
168         ! -name '*.gz' | xargs gzip -9nf
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc ChangeLog
179 %docdir %{_prefix}/System/Library/Documentation
180 %{_prefix}/System/Library/Documentation/Developer/Back
181 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
182
183 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle
184 %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/Resources
185 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/%{gscpu}
186
187 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
188 %{_prefix}/System/Library/Fonts/Helvetica.nfont
189
190 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
191
192 %if %{with art}
193 %files art
194 %defattr(644,root,root,755)
195 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle
196 %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/Resources
197 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/%{gscpu}
198 %endif
199
200 %if %{with cairo}
201 %files cairo
202 %defattr(644,root,root,755)
203 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle
204 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/Resources
205 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/%{gscpu}
206 %endif
207
208 %files xdps
209 %defattr(644,root,root,755)
210 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle
211 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/Resources
212 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/%{gscpu}
This page took 0.0716 seconds and 4 git commands to generate.