]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.24.0
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # art backend
6 %bcond_with     dps     # xdps backend
7 %bcond_without  cairo   # cairo backend
8 %bcond_with     glitz   # glitz support in cairo backend (requires cairo built with glitz)
9 #
10 Summary:        The GNUstep backend bundle
11 Summary(pl.UTF-8):      Pakiet backendowy GNUstep
12 Name:           gnustep-back
13 Version:        0.24.0
14 Release:        1
15 License:        LGPL v2+ (libraries), GPL v3+ (applicatinos)
16 Vendor:         The GNUstep Project
17 Group:          X11/Libraries
18 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
19 # Source0-md5:  0b8393832bd928b9d3ec4eb68d7f6564
20 Patch0:         %{name}-format.patch
21 URL:            http://www.gnustep.org/
22 BuildRequires:  OpenGL-GLX-devel
23 %{?with_dps:BuildRequires:      X11-DPS-devel}
24 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
25 %{?with_cairo:BuildRequires:    fontconfig-devel}
26 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
27 %{?with_glitz:BuildRequires:    glitz-devel}
28 BuildRequires:  gnustep-gui-devel >= %{version}
29 %{?with_art:BuildRequires:      libart_lgpl-devel}
30 BuildRequires:  libtiff-devel
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libXcursor-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXfixes-devel
35 BuildRequires:  xorg-lib-libXft-devel
36 BuildRequires:  xorg-lib-libXmu-devel
37 %{?with_cairo:BuildRequires:    xorg-lib-libXrender-devel}
38 %{?with_dps:BuildRequires:      xorg-lib-libXt-devel}
39 Requires:       gnustep-gui >= %{version}
40 Obsoletes:      gnustep-back-devel
41 %{!?with_dps:Obsoletes: gnustep-back-xdps}
42 Obsoletes:      gnustep-xgps
43 Conflicts:      gnustep-core
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # bundles version (echo %{version} | cut -d. -f1,2 | tr -d .)
47 %define         bver    024
48
49 %description
50 This is a backend for the GNUstep gui Library which allows you to use
51 the GNUstep gui Library on an X Window System (other backends will
52 be added later to allow you to use the GNUstep gui Library in other
53 windowing environments).
54
55 This package contains common part and xlib graphics backend.
56
57 %description -l pl.UTF-8
58 To jest backend dla biblioteki GNUstep GUI, pozwalający na używanie
59 biblioteki graficznego interfejsu użytkownika GNUstep pod systemem X
60 Window (inne backendy, pozwalające na używanie biblioteki GNUstep GUI
61 w innych środowiskach okienkowych, zostaną dodane później).
62
63 Ten pakiet zawiera część wspólną i backend graficzny xlib.
64
65 %package art
66 Summary:        GNUstep graphics backend - art
67 Summary(pl.UTF-8):      Graficzny backend GNUstep - art
68 Group:          X11/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       freetype >= 2.1.8
71 Conflicts:      gnustep-core
72
73 %description art
74 GNUstep graphics backend - art.
75
76 %description art -l pl.UTF-8
77 Graficzny backend GNUstep - art.
78
79 %package cairo
80 Summary:        GNUstep graphics backend - cairo
81 Summary(pl.UTF-8):      Graficzny backend GNUstep - cairo
82 Group:          X11/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       cairo >= 1.0
85
86 %description cairo
87 GNUstep graphics backend - cairo.
88
89 %description cairo -l pl.UTF-8
90 Graficzny backend GNUstep - cairo.
91
92 %package xdps
93 Summary:        GNUstep graphics backend - xdps
94 Summary(pl.UTF-8):      Graficzny backend GNUstep - xdps
95 Group:          X11/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Obsoletes:      gnustep-xdps
98 Conflicts:      gnustep-core
99
100 %description xdps
101 GNUstep graphics backend - xdps.
102
103 %description xdps -l pl.UTF-8
104 Graficzny backend GNUstep - xdps.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 %if %{with cairo}
111 # hack cairo header - objc doesn't allow #defines in #include
112 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
113         Headers/cairo-ft.h
114 %endif
115
116 # prepare the trees (for art, cairo, xdps, xlib backends)
117 echo * > files.list
118 %if %{with art}
119 install -d back-art 
120 cp -a `cat files.list` back-art
121 %endif
122 %if %{with cairo}
123 install -d back-cairo
124 cp -a `cat files.list` back-cairo
125 %endif
126 %if %{with dps}
127 install -d back-xdps
128 cp -a `cat files.list` back-xdps
129 %endif
130 ln -sf . back-xlib
131
132 %build
133 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
134 export GNUSTEP_FLATTENED=yes
135 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
136
137 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
138 cd back-$g
139 if [ "$g" = "xlib" ]; then
140         NAME="back"
141 else
142         NAME="back-$g"
143 fi
144 if [ "$g" = "cairo" ]; then
145         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2"
146 fi
147 %configure \
148         %{!?with_glitz:--disable-glitz} \
149         --enable-graphics=$g \
150         --with-name=$NAME
151
152 %{__make} \
153         messages=yes
154 cd ..
155 done
156
157 %{__make} -C Documentation
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
162 export GNUSTEP_FLATTENED=yes
163 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
164
165 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
166 if [ "$g" = "xlib" ]; then
167         NAME="back"
168 else
169         NAME="back-$g"
170 fi
171 %{__make} install -C back-$g \
172         DESTDIR=$RPM_BUILD_ROOT \
173         BUILD_GRAPHICS="$g" \
174         BACKEND_NAME="$NAME"
175 done
176
177 %{__make} install -C Documentation \
178         DESTDIR=$RPM_BUILD_ROOT
179
180 # not (yet?) supported by rpm-compress-doc
181 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
182         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %doc ChangeLog
193
194 %docdir %{_datadir}/GNUstep/Documentation
195 %{_datadir}/GNUstep/Documentation/Developer/Back
196
197 %attr(755,root,root) %{_bindir}/font_cacher
198 %attr(755,root,root) %{_bindir}/gpbs
199
200 %{_mandir}/man1/gpbs.1*
201
202 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle
203 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/libgnustep-back-%{bver}
204 %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/Resources
205 %{_libdir}/GNUstep/Bundles/libgnustep-back-%{bver}.bundle/stamp.make
206
207 %dir %{_libdir}/GNUstep/Fonts
208 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
209 %{_libdir}/GNUstep/Fonts/Helvetica.nfont
210
211 %if %{with art}
212 %files art
213 %defattr(644,root,root,755)
214 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle
215 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/libgnustep-back-art-%{bver}
216 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/Resources
217 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-%{bver}.bundle/stamp.make
218 %endif
219
220 %if %{with cairo}
221 %files cairo
222 %defattr(644,root,root,755)
223 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle
224 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/libgnustep-back-cairo-%{bver}
225 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/Resources
226 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-%{bver}.bundle/stamp.make
227 %endif
228
229 %if %{with dps}
230 %files xdps
231 %defattr(644,root,root,755)
232 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle
233 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/libgnustep-back-xdps-%{bver}
234 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/Resources
235 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-%{bver}.bundle/stamp.make
236 %endif
This page took 0.117812 seconds and 4 git commands to generate.