]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- converted to UTF-8
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # art backend
6 %bcond_with     dps     # xdps backend
7 %bcond_without  cairo   # cairo backend
8 %bcond_with     glitz   # glitz support in cairo backend (requires cairo built with glitz)
9 #
10 Summary:        The GNUstep backend bundle
11 Summary(pl.UTF-8):   Pakiet backendowy GNUstep
12 Name:           gnustep-back
13 Version:        0.11.0
14 Release:        1
15 License:        LGPL/GPL
16 Vendor:         The GNUstep Project
17 Group:          X11/Libraries
18 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
19 # Source0-md5:  fece87a22336e233b70e9ce999e1ea10
20 URL:            http://www.gnustep.org/
21 BuildRequires:  OpenGL-GLX-devel
22 %{?with_dps:BuildRequires:      X11-DPS-devel}
23 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
24 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
25 %{?with_glitz:BuildRequires:    glitz-devel}
26 BuildRequires:  gnustep-gui-devel >= %{version}
27 %{?with_art:BuildRequires:      libart_lgpl-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXmu-devel
31 BuildRequires:  xorg-lib-libXft-devel
32 Requires:       gnustep-gui >= %{version}
33 Obsoletes:      gnustep-back-devel
34 %{!?with_dps:Obsoletes: gnustep-back-xdps}
35 Obsoletes:      gnustep-xgps
36 Conflicts:      gnustep-core
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _prefix         /usr/%{_lib}/GNUstep
40
41 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
42
43 %description
44 This is a backend for the GNUstep gui Library which allows you to use
45 the GNUstep gui Library on an X Window System (other backends will
46 be added later to allow you to use the GNUstep gui Library in other
47 windowing environments).
48
49 This package contains common part and xlib graphics backend.
50
51 %description -l pl.UTF-8
52 To jest backend dla biblioteki GNUstep GUI, pozwalający na używanie
53 biblioteki graficznego interfejsu użytkownika GNUstep pod systemem X
54 Window (inne backendy, pozwalające na używanie biblioteki GNUstep GUI
55 w innych środowiskach okienkowych, zostaną dodane później).
56
57 Ten pakiet zawiera część wspólną i backend graficzny xlib.
58
59 %package art
60 Summary:        GNUstep graphics backend - art
61 Summary(pl.UTF-8):   Graficzny backend GNUstep - art
62 Group:          X11/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       freetype >= 2.1.8
65 Conflicts:      gnustep-core
66
67 %description art
68 GNUstep graphics backend - art.
69
70 %description art -l pl.UTF-8
71 Graficzny backend GNUstep - art.
72
73 %package cairo
74 Summary:        GNUstep graphics backend - cairo
75 Summary(pl.UTF-8):   Graficzny backend GNUstep - cairo
76 Group:          X11/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       cairo >= 1.0
79
80 %description cairo
81 GNUstep graphics backend - cairo.
82
83 %description cairo -l pl.UTF-8
84 Graficzny backend GNUstep - cairo.
85
86 %package xdps
87 Summary:        GNUstep graphics backend - xdps
88 Summary(pl.UTF-8):   Graficzny backend GNUstep - xdps
89 Group:          X11/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Obsoletes:      gnustep-xdps
92 Conflicts:      gnustep-core
93
94 %description xdps
95 GNUstep graphics backend - xdps.
96
97 %description xdps -l pl.UTF-8
98 Graficzny backend GNUstep - xdps.
99
100 %prep
101 %setup -q
102
103 %if %{with cairo}
104 # hack cairo header - objc doesn't allow #defines in #include
105 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
106         Headers/cairo-ft.h
107 %endif
108
109 # prepare the trees (for art, cairo, xdps, xlib backends)
110 echo * > files.list
111 %if %{with art}
112 install -d back-art 
113 cp -a `cat files.list` back-art
114 %endif
115 %if %{with cairo}
116 install -d back-cairo
117 cp -a `cat files.list` back-cairo
118 %endif
119 %if %{with dps}
120 install -d back-xdps
121 cp -a `cat files.list` back-xdps
122 %endif
123 ln -sf . back-xlib
124
125 %build
126 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
127 export GNUSTEP_FLATTENED=yes
128
129 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
130 cd back-$g
131 if [ "$g" = "xlib" ]; then
132         NAME="back"
133 else
134         NAME="back-$g"
135 fi
136 if [ "$g" = "cairo" ]; then
137         CPPFLAGS="-I/usr/include/freetype2"
138 fi
139 %configure \
140         %{!?with_glitz:--disable-glitz} \
141         --enable-graphics=$g \
142         --with-name=$NAME
143
144 %{__make} \
145         messages=yes
146 cd ..
147 done
148
149 %{__make} -C Documentation
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
154 export GNUSTEP_FLATTENED=yes
155
156 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
157 if [ "$g" = "xlib" ]; then
158         NAME="back"
159 else
160         NAME="back-$g"
161 fi
162 %{__make} install -C back-$g \
163         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
164         BUILD_GRAPHICS="$g" \
165         BACKEND_NAME="$NAME"
166 done
167
168 %{__make} install -C Documentation \
169         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
170
171 # not (yet?) supported by rpm-compress-doc
172 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
173         ! -name '*.gz' | xargs gzip -9nf
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc ChangeLog
184 %docdir %{_prefix}/System/Library/Documentation
185 %{_prefix}/System/Library/Documentation/Developer/Back
186 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
187
188 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-011.bundle
189 %{_prefix}/System/Library/Bundles/libgnustep-back-011.bundle/Resources
190 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-011.bundle/libgnustep-back-011
191
192 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
193 %{_prefix}/System/Library/Fonts/Helvetica.nfont
194
195 %attr(755,root,root) %{_prefix}/System/Tools/*
196
197 %if %{with art}
198 %files art
199 %defattr(644,root,root,755)
200 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art-011.bundle
201 %{_prefix}/System/Library/Bundles/libgnustep-back-art-011.bundle/Resources
202 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art-011.bundle/libgnustep-back-art-011
203 %endif
204
205 %if %{with cairo}
206 %files cairo
207 %defattr(644,root,root,755)
208 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-011.bundle
209 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-011.bundle/Resources
210 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-011.bundle/libgnustep-back-cairo-011
211 %endif
212
213 %if %{with dps}
214 %files xdps
215 %defattr(644,root,root,755)
216 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-011.bundle
217 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-011.bundle/Resources
218 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-011.bundle/libgnustep-back-xdps-011
219 %endif
This page took 0.167025 seconds and 4 git commands to generate.