]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- disable art until fixed to work with new freetype
[packages/gnustep-back.git] / gnustep-back.spec
1 %bcond_with art # Build art backend
2 Summary:        The GNUstep backend bundle
3 Summary(pl):    Pakiet backendowy GNUstep
4 Name:           gnustep-back
5 Version:        0.9.2
6 Release:        2
7 License:        LGPL/GPL
8 Vendor:         The GNUstep Project
9 Group:          X11/Libraries
10 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
11 # Source0-md5:  8c011a6663f6d9703ae2d879c317e7d7
12 URL:            http://www.gnustep.org/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  WindowMaker-devel
15 BuildRequires:  XFree86-devel
16 BuildRequires:  XFree86-DPS-devel
17 %{?with_art:BuildRequires:      freetype-devel >= 2.1.4}
18 %{?with_art:BuildRequires:      freetype-devel < 2.1.8}
19 BuildRequires:  gnustep-gui-devel >= %{version}
20 %{?with_art:BuildRequires:      libart_lgpl-devel}
21 BuildRequires:  xft-devel
22 Requires:       OpenGL
23 Requires:       gnustep-gui >= %{version}
24 Obsoletes:      gnustep-back-devel
25 Obsoletes:      gnustep-xgps
26 Conflicts:      gnustep-core
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/lib/GNUstep
30
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
32
33 %define         libcombo        gnu-gnu-gnu
34 %define         gsos            linux-gnu
35 %ifarch %{ix86}
36 %define         gscpu           ix86
37 %else
38 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
39 %define         gscpu           %{_target_cpu}
40 %endif
41
42 %description
43 This is a backend for the GNUstep gui Library which allows you to use
44 the GNUstep gui Library on an X Window System (other backends will
45 be added later to allow you to use the GNUstep gui Library in other
46 windowing environments).
47
48 This package contains common part and xlib graphics backend.
49
50 %description -l pl
51 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
52 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
53 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
54 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
55
56 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
57
58 %package art
59 Summary:        GNUstep graphics backend - art
60 Summary(pl):    Graficzny backend GNUstep - art
61 Group:          X11/Libraries
62 Requires:       %{name} = %{version}
63 Requires:       freetype >= 2.1.4
64 Conflicts:      gnustep-core
65
66 %description art
67 GNUstep graphics backend - art.
68
69 %description art -l pl
70 Graficzny backend GNUstep - art.
71
72 %package xdps
73 Summary:        GNUstep graphics backend - xdps
74 Summary(pl):    Graficzny backend GNUstep - xdps
75 Group:          X11/Libraries
76 Requires:       %{name} = %{version}
77 Obsoletes:      gnustep-xdps
78 Conflicts:      gnustep-core
79
80 %description xdps
81 GNUstep graphics backend - xdps.
82
83 %description xdps -l pl
84 Graficzny backend GNUstep - xdps.
85
86 %prep
87 %setup -q
88
89 # prepare three trees (for art, xdps and xlib backends)
90 echo * > files.list
91 %if %{with art}
92 install -d back-art 
93 cp -a `cat files.list` back-art
94 %endif
95 install -d back-xdps
96 cp -a `cat files.list` back-xdps
97 ln -sf . back-xlib
98
99 %build
100 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
101
102 for g in %{?with_art:art} xdps xlib ; do
103 cd back-$g
104 if [ "$g" = "xlib" ]; then
105         INC='--with-include-flags=-I/usr/include/freetype2'
106         NAME="back"
107 else
108         INC=
109         NAME="back-$g"
110 fi
111 %configure \
112         --enable-graphics=$g \
113         --with-name=$NAME \
114         $INC
115
116 %{__make} \
117         messages=yes
118 cd ..
119 done
120
121 %{__make} -C Documentation
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
126
127 for g in %{?with_art:art} xdps xlib ; do
128 if [ "$g" = "xlib" ]; then
129         NAME="back"
130 else
131         NAME="back-$g"
132 fi
133 %{__make} install -C back-$g \
134         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
135         BUILD_GRAPHICS="$g" \
136         BACKEND_NAME="$NAME"
137 done
138
139 %{__make} install -C Documentation \
140         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
141
142 # not (yet?) supported by rpm-compress-doc
143 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
144         ! -name '*.gz' | xargs gzip -9nf
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc ChangeLog
155 %docdir %{_prefix}/System/Library/Documentation
156 %{_prefix}/System/Library/Documentation/Developer/Back
157 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
158
159 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
160 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
161 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
162
163 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
164
165 %if %{with art}
166 %files art
167 %defattr(644,root,root,755)
168 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
169 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
170 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
171 %endif
172
173 %files xdps
174 %defattr(644,root,root,755)
175 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
176 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
177 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.058964 seconds and 4 git commands to generate.