]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- _noautoreqdep
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.3
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-Xft2.patch
11 Patch1:         %{name}-art-freetype213.patch
12 Patch2:         %{name}-xdps-fix.patch
13 URL:            http://www.gnustep.org/
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  WindowMaker-devel
16 BuildRequires:  XFree86-devel
17 BuildRequires:  XFree86-DPS-devel
18 BuildRequires:  Xft-devel
19 BuildRequires:  freetype-devel >= 2.1.3
20 BuildRequires:  gnustep-gui-devel
21 BuildRequires:  libart_lgpl-devel
22 Requires:       OpenGL
23 Requires:       gnustep-gui
24 Obsoletes:      gnustep-xgps
25 Conflicts:      gnustep-core
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/lib/GNUstep
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %define         libcombo        gnu-gnu-gnu
33 %define         gsos            linux-gnu
34 %ifarch %{ix86}
35 %define         gscpu           ix86
36 %else
37 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
38 %define         gscpu           %{_target_cpu}
39 %endif
40
41 %description
42 This is a backend for the GNUstep gui Library which allows you to use
43 the GNUstep gui Library on an X Windows System (other backends will
44 be added later to allow you to use the GNUstep gui Library in other
45 windowing environments).
46
47 This package contains common part and xlib graphics backend.
48
49 %description -l pl
50 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
51 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
52 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
53 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
54
55 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
56
57 %package art
58 Summary:        GNUstep graphics backend - art
59 Summary(pl):    Graficzny backend GNUstep - art
60 Group:          X11/Libraries
61 Requires:       %{name} = %{version}
62 Conflicts:      gnustep-core
63
64 %description art
65 GNUstep graphics backend - art.
66
67 %description art -l pl
68 Graficzny backend GNUstep - art.
69
70 %package xdps
71 Summary:        GNUstep graphics backend - xdps
72 Summary(pl):    Graficzny backend GNUstep - xdps
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 Obsoletes:      gnustep-xdps
76 Conflicts:      gnustep-core
77
78 %description xdps
79 GNUstep graphics backend - xdps.
80
81 %description xdps -l pl
82 Graficzny backend GNUstep - xdps.
83
84 %package devel
85 Summary:        Headers for GNUstep backends
86 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
87 Group:          X11/Development/Libraries
88 Requires:       %{name} = %{version}
89 Requires:       XFree86-devel
90 Requires:       Xft-devel
91 Requires:       gnustep-gui-devel
92 Obsoletes:      gnustep-xdps-devel
93 Obsoletes:      gnustep-xgps-devel
94 Conflicts:      gnustep-core
95
96 %description devel
97 This package contains development headers for GNUstep backends. It
98 includes also files specific for all x11 graphic backends (xlib,
99 art, xdps).
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
103 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
104 xdps).
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 %build
113 . %{_prefix}/System/Makefiles/GNUstep.sh
114 for g in art xdps xlib ; do
115 if [ "$g" = "xlib" ]; then
116         INC='--with-include-flags=-I/usr/include/freetype2'
117         NAME="back"
118 else
119         INC=
120         NAME="back-$g"
121 fi
122 %configure \
123         --enable-graphics=$g \
124         --with-name=$NAME \
125         $INC
126
127 %{__make} \
128         messages=yes
129 cp -f back.make back-$g.make
130 done
131
132 %{__make} -C Documentation
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 . %{_prefix}/System/Makefiles/GNUstep.sh
137
138 for g in art xdps xlib ; do
139 if [ "$g" = "xlib" ]; then
140         NAME="back"
141 else
142         NAME="back-$g"
143 fi
144 %{__make} install \
145         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
146         BUILD_GRAPHICS="$g" \
147         BACKEND_NAME="$NAME"
148 done
149
150 %{__make} install -C Documentation \
151         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
152 # not (yet?) supported by rpm-compress-doc
153 find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc ChangeLog
164 %{_prefix}/System/Documentation/Developer/Back
165
166 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
167 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
168 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
169
170 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
171
172 %files art
173 %defattr(644,root,root,755)
174 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
175 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
176 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
177
178 %files xdps
179 %defattr(644,root,root,755)
180 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
181 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
182 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
183
184 %files devel
185 %defattr(644,root,root,755)
186 %{_prefix}/System/Headers/gnustep/gsc
187 %{_prefix}/System/Headers/gnustep/x11
188
189 %{_prefix}/System/Headers/gnustep/xlib
190 %{_prefix}/System/Headers/gnustep/art
191 %{_prefix}/System/Headers/gnustep/xdps
This page took 0.082638 seconds and 4 git commands to generate.