]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.23.0
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # art backend
6 %bcond_with     dps     # xdps backend
7 %bcond_without  cairo   # cairo backend
8 %bcond_with     glitz   # glitz support in cairo backend (requires cairo built with glitz)
9 #
10 Summary:        The GNUstep backend bundle
11 Summary(pl.UTF-8):      Pakiet backendowy GNUstep
12 Name:           gnustep-back
13 Version:        0.23.0
14 Release:        1
15 License:        LGPL v2+ (libraries), GPL v3+ (applicatinos)
16 Vendor:         The GNUstep Project
17 Group:          X11/Libraries
18 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
19 # Source0-md5:  bde6f222bc74a0ba02f57fa1908c200e
20 URL:            http://www.gnustep.org/
21 BuildRequires:  OpenGL-GLX-devel
22 %{?with_dps:BuildRequires:      X11-DPS-devel}
23 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
24 %{?with_cairo:BuildRequires:    fontconfig-devel}
25 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
26 %{?with_glitz:BuildRequires:    glitz-devel}
27 BuildRequires:  gnustep-gui-devel >= %{version}
28 %{?with_art:BuildRequires:      libart_lgpl-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  xorg-lib-libXcursor-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXfixes-devel
33 BuildRequires:  xorg-lib-libXft-devel
34 BuildRequires:  xorg-lib-libXmu-devel
35 %{?with_cairo:BuildRequires:    xorg-lib-libXrender-devel}
36 %{?with_dps:BuildRequires:      xorg-lib-libXt-devel}
37 Requires:       gnustep-gui >= %{version}
38 Obsoletes:      gnustep-back-devel
39 %{!?with_dps:Obsoletes: gnustep-back-xdps}
40 Obsoletes:      gnustep-xgps
41 Conflicts:      gnustep-core
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
45
46 %description
47 This is a backend for the GNUstep gui Library which allows you to use
48 the GNUstep gui Library on an X Window System (other backends will
49 be added later to allow you to use the GNUstep gui Library in other
50 windowing environments).
51
52 This package contains common part and xlib graphics backend.
53
54 %description -l pl.UTF-8
55 To jest backend dla biblioteki GNUstep GUI, pozwalający na używanie
56 biblioteki graficznego interfejsu użytkownika GNUstep pod systemem X
57 Window (inne backendy, pozwalające na używanie biblioteki GNUstep GUI
58 w innych środowiskach okienkowych, zostaną dodane później).
59
60 Ten pakiet zawiera część wspólną i backend graficzny xlib.
61
62 %package art
63 Summary:        GNUstep graphics backend - art
64 Summary(pl.UTF-8):      Graficzny backend GNUstep - art
65 Group:          X11/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       freetype >= 2.1.8
68 Conflicts:      gnustep-core
69
70 %description art
71 GNUstep graphics backend - art.
72
73 %description art -l pl.UTF-8
74 Graficzny backend GNUstep - art.
75
76 %package cairo
77 Summary:        GNUstep graphics backend - cairo
78 Summary(pl.UTF-8):      Graficzny backend GNUstep - cairo
79 Group:          X11/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       cairo >= 1.0
82
83 %description cairo
84 GNUstep graphics backend - cairo.
85
86 %description cairo -l pl.UTF-8
87 Graficzny backend GNUstep - cairo.
88
89 %package xdps
90 Summary:        GNUstep graphics backend - xdps
91 Summary(pl.UTF-8):      Graficzny backend GNUstep - xdps
92 Group:          X11/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Obsoletes:      gnustep-xdps
95 Conflicts:      gnustep-core
96
97 %description xdps
98 GNUstep graphics backend - xdps.
99
100 %description xdps -l pl.UTF-8
101 Graficzny backend GNUstep - xdps.
102
103 %prep
104 %setup -q
105
106 %if %{with cairo}
107 # hack cairo header - objc doesn't allow #defines in #include
108 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
109         Headers/cairo-ft.h
110 %endif
111
112 # prepare the trees (for art, cairo, xdps, xlib backends)
113 echo * > files.list
114 %if %{with art}
115 install -d back-art 
116 cp -a `cat files.list` back-art
117 %endif
118 %if %{with cairo}
119 install -d back-cairo
120 cp -a `cat files.list` back-cairo
121 %endif
122 %if %{with dps}
123 install -d back-xdps
124 cp -a `cat files.list` back-xdps
125 %endif
126 ln -sf . back-xlib
127
128 %build
129 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
130 export GNUSTEP_FLATTENED=yes
131 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
132
133 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
134 cd back-$g
135 if [ "$g" = "xlib" ]; then
136         NAME="back"
137 else
138         NAME="back-$g"
139 fi
140 if [ "$g" = "cairo" ]; then
141         CPPFLAGS="%{rpmcppflags} -I/usr/include/freetype2"
142 fi
143 %configure \
144         %{!?with_glitz:--disable-glitz} \
145         --enable-graphics=$g \
146         --with-name=$NAME
147
148 %{__make} \
149         messages=yes
150 cd ..
151 done
152
153 %{__make} -C Documentation
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
158 export GNUSTEP_FLATTENED=yes
159 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
160
161 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
162 if [ "$g" = "xlib" ]; then
163         NAME="back"
164 else
165         NAME="back-$g"
166 fi
167 %{__make} install -C back-$g \
168         DESTDIR=$RPM_BUILD_ROOT \
169         BUILD_GRAPHICS="$g" \
170         BACKEND_NAME="$NAME"
171 done
172
173 %{__make} install -C Documentation \
174         DESTDIR=$RPM_BUILD_ROOT
175
176 # not (yet?) supported by rpm-compress-doc
177 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
178         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post   -p /sbin/ldconfig
184 %postun -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %doc ChangeLog
189
190 %docdir %{_datadir}/GNUstep/Documentation
191 %{_datadir}/GNUstep/Documentation/Developer/Back
192
193 %attr(755,root,root) %{_bindir}/font_cacher
194 %attr(755,root,root) %{_bindir}/gpbs
195
196 %{_mandir}/man1/gpbs.1*
197
198 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-023.bundle
199 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-023.bundle/libgnustep-back-023
200 %{_libdir}/GNUstep/Bundles/libgnustep-back-023.bundle/Resources
201 %{_libdir}/GNUstep/Bundles/libgnustep-back-023.bundle/stamp.make
202
203 %dir %{_libdir}/GNUstep/Fonts
204 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
205 %{_libdir}/GNUstep/Fonts/Helvetica.nfont
206
207 %if %{with art}
208 %files art
209 %defattr(644,root,root,755)
210 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-023.bundle
211 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-023.bundle/libgnustep-back-art-023
212 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-023.bundle/Resources
213 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-023.bundle/stamp.make
214 %endif
215
216 %if %{with cairo}
217 %files cairo
218 %defattr(644,root,root,755)
219 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-023.bundle
220 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-023.bundle/libgnustep-back-cairo-023
221 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-023.bundle/Resources
222 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-023.bundle/stamp.make
223 %endif
224
225 %if %{with dps}
226 %files xdps
227 %defattr(644,root,root,755)
228 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-023.bundle
229 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-023.bundle/libgnustep-back-xdps-023
230 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-023.bundle/Resources
231 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-023.bundle/stamp.make
232 %endif
This page took 0.089937 seconds and 4 git commands to generate.