]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.9.3, added freetype patch, amd64/ppc fixes
[packages/gnustep-back.git] / gnustep-back.spec
1 #
2 # Conditional build:
3 %bcond_without art      # don't build art backend
4 #
5 Summary:        The GNUstep backend bundle
6 Summary(pl):    Pakiet backendowy GNUstep
7 Name:           gnustep-back
8 Version:        0.9.3
9 Release:        1
10 License:        LGPL/GPL
11 Vendor:         The GNUstep Project
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
14 # Source0-md5:  2ee883c140eb7cf47bb284b2f72c1adc
15 Patch0:         %{name}-freetype.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  WindowMaker-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  XFree86-DPS-devel
21 %{?with_art:BuildRequires:      freetype-devel >= 2.1.4}
22 BuildRequires:  gnustep-gui-devel >= %{version}
23 %{?with_art:BuildRequires:      libart_lgpl-devel}
24 BuildRequires:  xft-devel
25 Requires:       OpenGL
26 Requires:       gnustep-gui >= %{version}
27 Obsoletes:      gnustep-back-devel
28 Obsoletes:      gnustep-xgps
29 Conflicts:      gnustep-core
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _prefix         /usr/%{_lib}/GNUstep
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %define         libcombo        gnu-gnu-gnu
37 %define         gsos            linux-gnu
38 %ifarch %{ix86}
39 %define         gscpu           ix86
40 %else
41 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
42 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
43 %endif
44
45 %description
46 This is a backend for the GNUstep gui Library which allows you to use
47 the GNUstep gui Library on an X Window System (other backends will
48 be added later to allow you to use the GNUstep gui Library in other
49 windowing environments).
50
51 This package contains common part and xlib graphics backend.
52
53 %description -l pl
54 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
55 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
56 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
57 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
58
59 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
60
61 %package art
62 Summary:        GNUstep graphics backend - art
63 Summary(pl):    Graficzny backend GNUstep - art
64 Group:          X11/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       freetype >= 2.1.4
67 Conflicts:      gnustep-core
68
69 %description art
70 GNUstep graphics backend - art.
71
72 %description art -l pl
73 Graficzny backend GNUstep - art.
74
75 %package xdps
76 Summary:        GNUstep graphics backend - xdps
77 Summary(pl):    Graficzny backend GNUstep - xdps
78 Group:          X11/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Obsoletes:      gnustep-xdps
81 Conflicts:      gnustep-core
82
83 %description xdps
84 GNUstep graphics backend - xdps.
85
86 %description xdps -l pl
87 Graficzny backend GNUstep - xdps.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92
93 # prepare three trees (for art, xdps and xlib backends)
94 echo * > files.list
95 %if %{with art}
96 install -d back-art 
97 cp -a `cat files.list` back-art
98 %endif
99 install -d back-xdps
100 cp -a `cat files.list` back-xdps
101 ln -sf . back-xlib
102
103 %build
104 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
105
106 for g in %{?with_art:art} xdps xlib ; do
107 cd back-$g
108 if [ "$g" = "xlib" ]; then
109         INC='--with-include-flags=-I/usr/include/freetype2'
110         NAME="back"
111 else
112         INC=
113         NAME="back-$g"
114 fi
115 %configure \
116         --enable-graphics=$g \
117         --with-name=$NAME \
118         $INC
119
120 %{__make} \
121         messages=yes
122 cd ..
123 done
124
125 %{__make} -C Documentation
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
130
131 for g in %{?with_art:art} xdps xlib ; do
132 if [ "$g" = "xlib" ]; then
133         NAME="back"
134 else
135         NAME="back-$g"
136 fi
137 %{__make} install -C back-$g \
138         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
139         BUILD_GRAPHICS="$g" \
140         BACKEND_NAME="$NAME"
141 done
142
143 %{__make} install -C Documentation \
144         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
145
146 # not (yet?) supported by rpm-compress-doc
147 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
148         ! -name '*.gz' | xargs gzip -9nf
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc ChangeLog
159 %docdir %{_prefix}/System/Library/Documentation
160 %{_prefix}/System/Library/Documentation/Developer/Back
161 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
162
163 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
164 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
165 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
166
167 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
168
169 %if %{with art}
170 %files art
171 %defattr(644,root,root,755)
172 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
173 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
174 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
175 %endif
176
177 %files xdps
178 %defattr(644,root,root,755)
179 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
180 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
181 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.110475 seconds and 4 git commands to generate.