]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- rel 2
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # art backend
6 %bcond_with     dps     # xdps backend
7 %bcond_without  cairo   # cairo backend
8 %bcond_with     glitz   # glitz support in cairo backend (requires cairo built with glitz)
9 #
10 Summary:        The GNUstep backend bundle
11 Summary(pl.UTF-8):      Pakiet backendowy GNUstep
12 Name:           gnustep-back
13 Version:        0.13.0
14 Release:        2
15 License:        LGPL/GPL
16 Vendor:         The GNUstep Project
17 Group:          X11/Libraries
18 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
19 # Source0-md5:  998466053c8cb651eeadf6d0bf69dd94
20 URL:            http://www.gnustep.org/
21 BuildRequires:  OpenGL-GLX-devel
22 %{?with_dps:BuildRequires:      X11-DPS-devel}
23 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
24 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
25 %{?with_glitz:BuildRequires:    glitz-devel}
26 BuildRequires:  gnustep-gui-devel >= %{version}
27 %{?with_art:BuildRequires:      libart_lgpl-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXmu-devel
31 BuildRequires:  xorg-lib-libXft-devel
32 Requires:       gnustep-gui >= %{version}
33 Obsoletes:      gnustep-back-devel
34 %{!?with_dps:Obsoletes: gnustep-back-xdps}
35 Obsoletes:      gnustep-xgps
36 Conflicts:      gnustep-core
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
40
41 %description
42 This is a backend for the GNUstep gui Library which allows you to use
43 the GNUstep gui Library on an X Window System (other backends will
44 be added later to allow you to use the GNUstep gui Library in other
45 windowing environments).
46
47 This package contains common part and xlib graphics backend.
48
49 %description -l pl.UTF-8
50 To jest backend dla biblioteki GNUstep GUI, pozwalający na używanie
51 biblioteki graficznego interfejsu użytkownika GNUstep pod systemem X
52 Window (inne backendy, pozwalające na używanie biblioteki GNUstep GUI
53 w innych środowiskach okienkowych, zostaną dodane później).
54
55 Ten pakiet zawiera część wspólną i backend graficzny xlib.
56
57 %package art
58 Summary:        GNUstep graphics backend - art
59 Summary(pl.UTF-8):      Graficzny backend GNUstep - art
60 Group:          X11/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       freetype >= 2.1.8
63 Conflicts:      gnustep-core
64
65 %description art
66 GNUstep graphics backend - art.
67
68 %description art -l pl.UTF-8
69 Graficzny backend GNUstep - art.
70
71 %package cairo
72 Summary:        GNUstep graphics backend - cairo
73 Summary(pl.UTF-8):      Graficzny backend GNUstep - cairo
74 Group:          X11/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       cairo >= 1.0
77
78 %description cairo
79 GNUstep graphics backend - cairo.
80
81 %description cairo -l pl.UTF-8
82 Graficzny backend GNUstep - cairo.
83
84 %package xdps
85 Summary:        GNUstep graphics backend - xdps
86 Summary(pl.UTF-8):      Graficzny backend GNUstep - xdps
87 Group:          X11/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 Obsoletes:      gnustep-xdps
90 Conflicts:      gnustep-core
91
92 %description xdps
93 GNUstep graphics backend - xdps.
94
95 %description xdps -l pl.UTF-8
96 Graficzny backend GNUstep - xdps.
97
98 %prep
99 %setup -q
100
101 %if %{with cairo}
102 # hack cairo header - objc doesn't allow #defines in #include
103 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
104         Headers/cairo-ft.h
105 %endif
106
107 # prepare the trees (for art, cairo, xdps, xlib backends)
108 echo * > files.list
109 %if %{with art}
110 install -d back-art 
111 cp -a `cat files.list` back-art
112 %endif
113 %if %{with cairo}
114 install -d back-cairo
115 cp -a `cat files.list` back-cairo
116 %endif
117 %if %{with dps}
118 install -d back-xdps
119 cp -a `cat files.list` back-xdps
120 %endif
121 ln -sf . back-xlib
122
123 %build
124 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
125 export GNUSTEP_FLATTENED=yes
126
127 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
128 cd back-$g
129 if [ "$g" = "xlib" ]; then
130         NAME="back"
131 else
132         NAME="back-$g"
133 fi
134 if [ "$g" = "cairo" ]; then
135         CPPFLAGS="-I/usr/include/freetype2"
136 fi
137 %configure \
138         %{!?with_glitz:--disable-glitz} \
139         --enable-graphics=$g \
140         --with-name=$NAME
141
142 %{__make} \
143         messages=yes
144 cd ..
145 done
146
147 %{__make} -C Documentation
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
152 export GNUSTEP_FLATTENED=yes
153
154 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
155 if [ "$g" = "xlib" ]; then
156         NAME="back"
157 else
158         NAME="back-$g"
159 fi
160 %{__make} install -C back-$g \
161         DESTDIR=$RPM_BUILD_ROOT \
162         BUILD_GRAPHICS="$g" \
163         BACKEND_NAME="$NAME"
164 done
165
166 %{__make} install -C Documentation \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 # not (yet?) supported by rpm-compress-doc
170 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
171         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc ChangeLog
182 %docdir %{_datadir}/GNUstep/Documentation
183 %{_datadir}/GNUstep/Documentation/Developer/Back
184 %{_mandir}/man1/gpbs.1*
185
186 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle
187 %{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle/Resources
188 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-013.bundle/libgnustep-back-013
189
190 %dir %{_libdir}/GNUstep/Fonts
191 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
192 %{_libdir}/GNUstep/Fonts/Helvetica.nfont
193
194 %attr(755,root,root) %{_bindir}/*
195
196 %if %{with art}
197 %files art
198 %defattr(644,root,root,755)
199 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle
200 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle/Resources
201 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-013.bundle/libgnustep-back-art-013
202 %endif
203
204 %if %{with cairo}
205 %files cairo
206 %defattr(644,root,root,755)
207 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle
208 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle/Resources
209 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-013.bundle/libgnustep-back-cairo-013
210 %endif
211
212 %if %{with dps}
213 %files xdps
214 %defattr(644,root,root,755)
215 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle
216 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle/Resources
217 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-013.bundle/libgnustep-back-xdps-013
218 %endif
This page took 0.089159 seconds and 4 git commands to generate.