]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- up to 0.9.2
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.9.2
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 # Source0-md5:  8c011a6663f6d9703ae2d879c317e7d7
11 URL:            http://www.gnustep.org/
12 BuildRequires:  OpenGL-devel
13 BuildRequires:  WindowMaker-devel
14 BuildRequires:  XFree86-devel
15 BuildRequires:  XFree86-DPS-devel
16 BuildRequires:  freetype-devel >= 2.1.4
17 BuildRequires:  gnustep-gui-devel >= %{version}
18 BuildRequires:  libart_lgpl-devel
19 BuildRequires:  xft-devel
20 Requires:       OpenGL
21 Requires:       gnustep-gui >= %{version}
22 Obsoletes:      gnustep-back-devel
23 Obsoletes:      gnustep-xgps
24 Conflicts:      gnustep-core
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/lib/GNUstep
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %define         libcombo        gnu-gnu-gnu
32 %define         gsos            linux-gnu
33 %ifarch %{ix86}
34 %define         gscpu           ix86
35 %else
36 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
37 %define         gscpu           %{_target_cpu}
38 %endif
39
40 %description
41 This is a backend for the GNUstep gui Library which allows you to use
42 the GNUstep gui Library on an X Window System (other backends will
43 be added later to allow you to use the GNUstep gui Library in other
44 windowing environments).
45
46 This package contains common part and xlib graphics backend.
47
48 %description -l pl
49 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
50 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
51 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
52 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
53
54 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
55
56 %package art
57 Summary:        GNUstep graphics backend - art
58 Summary(pl):    Graficzny backend GNUstep - art
59 Group:          X11/Libraries
60 Requires:       %{name} = %{version}
61 Requires:       freetype >= 2.1.4
62 Conflicts:      gnustep-core
63
64 %description art
65 GNUstep graphics backend - art.
66
67 %description art -l pl
68 Graficzny backend GNUstep - art.
69
70 %package xdps
71 Summary:        GNUstep graphics backend - xdps
72 Summary(pl):    Graficzny backend GNUstep - xdps
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 Obsoletes:      gnustep-xdps
76 Conflicts:      gnustep-core
77
78 %description xdps
79 GNUstep graphics backend - xdps.
80
81 %description xdps -l pl
82 Graficzny backend GNUstep - xdps.
83
84 %prep
85 %setup -q
86
87 # prepare three trees (for art, xdps and xlib backends)
88 echo * > files.list
89 install -d back-art back-xdps
90 cp -a `cat files.list` back-art
91 cp -a `cat files.list` back-xdps
92 ln -sf . back-xlib
93
94 %build
95 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
96
97 for g in art xdps xlib ; do
98 cd back-$g
99 if [ "$g" = "xlib" ]; then
100         INC='--with-include-flags=-I/usr/include/freetype2'
101         NAME="back"
102 else
103         INC=
104         NAME="back-$g"
105 fi
106 %configure \
107         --enable-graphics=$g \
108         --with-name=$NAME \
109         $INC
110
111 %{__make} \
112         messages=yes
113 cd ..
114 done
115
116 %{__make} -C Documentation
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
121
122 for g in art xdps xlib ; do
123 if [ "$g" = "xlib" ]; then
124         NAME="back"
125 else
126         NAME="back-$g"
127 fi
128 %{__make} install -C back-$g \
129         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
130         BUILD_GRAPHICS="$g" \
131         BACKEND_NAME="$NAME"
132 done
133
134 %{__make} install -C Documentation \
135         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
136
137 # not (yet?) supported by rpm-compress-doc
138 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
139         ! -name '*.gz' | xargs gzip -9nf
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ChangeLog
150 %docdir %{_prefix}/System/Library/Documentation
151 %{_prefix}/System/Library/Documentation/Developer/Back
152 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
153
154 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
155 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
156 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
157
158 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
159
160 %files art
161 %defattr(644,root,root,755)
162 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
163 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
164 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
165
166 %files xdps
167 %defattr(644,root,root,755)
168 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
169 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
170 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.0481510000000001 seconds and 4 git commands to generate.