]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.9.5, removed obsolete freetype patch, added destdir patch
[packages/gnustep-back.git] / gnustep-back.spec
1 # NOTE: when built on ft < 2.1.8, needs ft < 2.1.8 (and vice versa)
2 #
3 # Conditional build:
4 %bcond_without art      # don't build art backend
5 #
6 Summary:        The GNUstep backend bundle
7 Summary(pl):    Pakiet backendowy GNUstep
8 Name:           gnustep-back
9 Version:        0.9.5
10 Release:        1
11 License:        LGPL/GPL
12 Vendor:         The GNUstep Project
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
15 # Source0-md5:  65793b1026b2a06198b8438718309deb
16 Patch0:         %{name}-destdir.patch
17 URL:            http://www.gnustep.org/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  XFree86-DPS-devel
21 BuildRequires:  cairo-devel
22 %{?with_art:BuildRequires:      freetype-devel >= 2.1.4}
23 BuildRequires:  gnustep-gui-devel >= %{version}
24 %{?with_art:BuildRequires:      libart_lgpl-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  xft-devel
27 Requires:       OpenGL
28 Requires:       gnustep-gui >= %{version}
29 Obsoletes:      gnustep-back-devel
30 Obsoletes:      gnustep-xgps
31 Conflicts:      gnustep-core
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _prefix         /usr/%{_lib}/GNUstep
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37
38 %define         libcombo        gnu-gnu-gnu
39 %define         gsos            linux-gnu
40 %ifarch %{ix86}
41 %define         gscpu           ix86
42 %else
43 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
44 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
45 %endif
46
47 %description
48 This is a backend for the GNUstep gui Library which allows you to use
49 the GNUstep gui Library on an X Window System (other backends will
50 be added later to allow you to use the GNUstep gui Library in other
51 windowing environments).
52
53 This package contains common part and xlib graphics backend.
54
55 %description -l pl
56 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
57 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
58 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
59 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
60
61 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
62
63 %package art
64 Summary:        GNUstep graphics backend - art
65 Summary(pl):    Graficzny backend GNUstep - art
66 Group:          X11/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       freetype >= 2.1.4
69 Conflicts:      gnustep-core
70
71 %description art
72 GNUstep graphics backend - art.
73
74 %description art -l pl
75 Graficzny backend GNUstep - art.
76
77 %package cairo
78 Summary:        GNUstep graphics backend - cairo
79 Summary(pl):    Graficzny backend GNUstep - cairo
80 Group:          X11/Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description cairo
84 GNUstep graphics backend - cairo.
85
86 %description cairo -l pl
87 Graficzny backend GNUstep - cairo.
88
89 %package xdps
90 Summary:        GNUstep graphics backend - xdps
91 Summary(pl):    Graficzny backend GNUstep - xdps
92 Group:          X11/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Obsoletes:      gnustep-xdps
95 Conflicts:      gnustep-core
96
97 %description xdps
98 GNUstep graphics backend - xdps.
99
100 %description xdps -l pl
101 Graficzny backend GNUstep - xdps.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 # prepare the trees (for art, cairo, xdps, xlib backends)
108 echo * > files.list
109 %if %{with art}
110 install -d back-art 
111 cp -a `cat files.list` back-art
112 %endif
113 install -d back-cairo
114 cp -a `cat files.list` back-cairo
115 install -d back-xdps
116 cp -a `cat files.list` back-xdps
117 ln -sf . back-xlib
118
119 %build
120 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
121
122 for g in %{?with_art:art} cairo xdps xlib ; do
123 cd back-$g
124 if [ "$g" = "xlib" ]; then
125         INC='--with-include-flags=-I/usr/include/freetype2'
126         NAME="back"
127 else
128         INC=
129         NAME="back-$g"
130 fi
131 %configure \
132         --enable-graphics=$g \
133         --with-name=$NAME \
134         $INC
135
136 %{__make} \
137         messages=yes
138 cd ..
139 done
140
141 %{__make} -C Documentation
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
146
147 for g in %{?with_art:art} cairo xdps xlib ; do
148 if [ "$g" = "xlib" ]; then
149         NAME="back"
150 else
151         NAME="back-$g"
152 fi
153 %{__make} install -C back-$g \
154         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
155         BUILD_GRAPHICS="$g" \
156         BACKEND_NAME="$NAME"
157 done
158
159 %{__make} install -C Documentation \
160         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
161
162 # not (yet?) supported by rpm-compress-doc
163 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
164         ! -name '*.gz' | xargs gzip -9nf
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post   -p /sbin/ldconfig
170 %postun -p /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %doc ChangeLog
175 %docdir %{_prefix}/System/Library/Documentation
176 %{_prefix}/System/Library/Documentation/Developer/Back
177 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
178
179 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
180 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
181 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
182
183 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
184
185 %if %{with art}
186 %files art
187 %defattr(644,root,root,755)
188 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
189 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
190 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
191 %endif
192
193 %files cairo
194 %defattr(644,root,root,755)
195 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle
196 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/Resources
197 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/%{gscpu}
198
199 %files xdps
200 %defattr(644,root,root,755)
201 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
202 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
203 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.095074 seconds and 4 git commands to generate.