]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- updated to 0.10.1
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # don't build art backend
6 %bcond_without  cairo   # don't build cairo backend
7 #
8 Summary:        The GNUstep backend bundle
9 Summary(pl):    Pakiet backendowy GNUstep
10 Name:           gnustep-back
11 Version:        0.10.1
12 Release:        1
13 License:        LGPL/GPL
14 Vendor:         The GNUstep Project
15 Group:          X11/Libraries
16 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
17 # Source0-md5:  139052b97ca5111dbcc9dd6b83c8d66f
18 URL:            http://www.gnustep.org/
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  XFree86-devel
21 BuildRequires:  XFree86-DPS-devel
22 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
23 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
24 BuildRequires:  gnustep-gui-devel >= %{version}
25 %{?with_art:BuildRequires:      libart_lgpl-devel}
26 BuildRequires:  pkgconfig
27 BuildRequires:  xft-devel
28 Requires:       OpenGL
29 Requires:       gnustep-gui >= %{version}
30 Obsoletes:      gnustep-back-devel
31 Obsoletes:      gnustep-xgps
32 Conflicts:      gnustep-core
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _prefix         /usr/%{_lib}/GNUstep
36
37 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
38
39 %define         libcombo        gnu-gnu-gnu
40 %define         gsos            linux-gnu
41 %ifarch %{ix86}
42 %define         gscpu           ix86
43 %else
44 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
45 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
46 %endif
47
48 %description
49 This is a backend for the GNUstep gui Library which allows you to use
50 the GNUstep gui Library on an X Window System (other backends will
51 be added later to allow you to use the GNUstep gui Library in other
52 windowing environments).
53
54 This package contains common part and xlib graphics backend.
55
56 %description -l pl
57 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
58 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
59 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
60 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
61
62 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
63
64 %package art
65 Summary:        GNUstep graphics backend - art
66 Summary(pl):    Graficzny backend GNUstep - art
67 Group:          X11/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       freetype >= 2.1.8
70 Conflicts:      gnustep-core
71
72 %description art
73 GNUstep graphics backend - art.
74
75 %description art -l pl
76 Graficzny backend GNUstep - art.
77
78 %package cairo
79 Summary:        GNUstep graphics backend - cairo
80 Summary(pl):    Graficzny backend GNUstep - cairo
81 Group:          X11/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       cairo >= 1.0
84
85 %description cairo
86 GNUstep graphics backend - cairo.
87
88 %description cairo -l pl
89 Graficzny backend GNUstep - cairo.
90
91 %package xdps
92 Summary:        GNUstep graphics backend - xdps
93 Summary(pl):    Graficzny backend GNUstep - xdps
94 Group:          X11/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Obsoletes:      gnustep-xdps
97 Conflicts:      gnustep-core
98
99 %description xdps
100 GNUstep graphics backend - xdps.
101
102 %description xdps -l pl
103 Graficzny backend GNUstep - xdps.
104
105 %prep
106 %setup -q
107
108 %if %{with cairo}
109 # hack cairo header - objc doesn't allow #defines in #include
110 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
111         Headers/cairo-ft.h
112 %endif
113
114 # prepare the trees (for art, cairo, xdps, xlib backends)
115 echo * > files.list
116 %if %{with art}
117 install -d back-art 
118 cp -a `cat files.list` back-art
119 %endif
120 %if %{with cairo}
121 install -d back-cairo
122 cp -a `cat files.list` back-cairo
123 %endif
124 install -d back-xdps
125 cp -a `cat files.list` back-xdps
126 ln -sf . back-xlib
127
128 %build
129 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
130
131 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
132 cd back-$g
133 if [ "$g" = "xlib" ]; then
134         NAME="back"
135 else
136         NAME="back-$g"
137 fi
138 if [ "$g" = "cairo" ]; then
139         CPPFLAGS="-I/usr/include/freetype2"
140 fi
141 %configure \
142         --enable-graphics=$g \
143         --with-name=$NAME
144
145 %{__make} \
146         messages=yes
147 cd ..
148 done
149
150 %{__make} -C Documentation
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
155
156 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
157 if [ "$g" = "xlib" ]; then
158         NAME="back"
159 else
160         NAME="back-$g"
161 fi
162 %{__make} install -C back-$g \
163         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
164         BUILD_GRAPHICS="$g" \
165         BACKEND_NAME="$NAME"
166 done
167
168 %{__make} install -C Documentation \
169         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
170
171 # not (yet?) supported by rpm-compress-doc
172 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
173         ! -name '*.gz' | xargs gzip -9nf
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc ChangeLog
184 %docdir %{_prefix}/System/Library/Documentation
185 %{_prefix}/System/Library/Documentation/Developer/Back
186 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
187
188 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle
189 %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/Resources
190 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/%{gscpu}
191
192 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
193 %{_prefix}/System/Library/Fonts/Helvetica.nfont
194
195 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
196
197 %if %{with art}
198 %files art
199 %defattr(644,root,root,755)
200 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle
201 %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/Resources
202 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/%{gscpu}
203 %endif
204
205 %if %{with cairo}
206 %files cairo
207 %defattr(644,root,root,755)
208 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle
209 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/Resources
210 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/%{gscpu}
211 %endif
212
213 %files xdps
214 %defattr(644,root,root,755)
215 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle
216 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/Resources
217 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/%{gscpu}
This page took 0.06163 seconds and 4 git commands to generate.