]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- cleanup
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.9
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 # Source0-md5:  af2ba9a683a28f75ebdeb91dd58debec
11 Patch0:               %{name}-xdps-fix.patch
12 URL:            http://www.gnustep.org/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  WindowMaker-devel
15 BuildRequires:  XFree86-devel
16 BuildRequires:  XFree86-DPS-devel
17 BuildRequires:  freetype-devel >= 2.1.4
18 BuildRequires:  gnustep-gui-devel >= %{version}
19 BuildRequires:  libart_lgpl-devel
20 BuildRequires:  xft-devel
21 Requires:       OpenGL
22 Requires:       gnustep-gui >= %{version}
23 Obsoletes:      gnustep-back-devel
24 Obsoletes:      gnustep-xgps
25 Conflicts:      gnustep-core
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/lib/GNUstep
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %define         libcombo        gnu-gnu-gnu
33 %define         gsos            linux-gnu
34 %ifarch %{ix86}
35 %define         gscpu           ix86
36 %else
37 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
38 %define         gscpu           %{_target_cpu}
39 %endif
40
41 %description
42 This is a backend for the GNUstep gui Library which allows you to use
43 the GNUstep gui Library on an X Window System (other backends will
44 be added later to allow you to use the GNUstep gui Library in other
45 windowing environments).
46
47 This package contains common part and xlib graphics backend.
48
49 %description -l pl
50 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
51 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
52 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
53 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
54
55 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
56
57 %package art
58 Summary:        GNUstep graphics backend - art
59 Summary(pl):    Graficzny backend GNUstep - art
60 Group:          X11/Libraries
61 Requires:       %{name} = %{version}
62 Requires:       freetype >= 2.1.4
63 Conflicts:      gnustep-core
64
65 %description art
66 GNUstep graphics backend - art.
67
68 %description art -l pl
69 Graficzny backend GNUstep - art.
70
71 %package xdps
72 Summary:        GNUstep graphics backend - xdps
73 Summary(pl):    Graficzny backend GNUstep - xdps
74 Group:          X11/Libraries
75 Requires:       %{name} = %{version}
76 Obsoletes:      gnustep-xdps
77 Conflicts:      gnustep-core
78
79 %description xdps
80 GNUstep graphics backend - xdps.
81
82 %description xdps -l pl
83 Graficzny backend GNUstep - xdps.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 # prepare three trees (for art, xdps and xlib backends)
90 echo * > files.list
91 install -d back-art back-xdps
92 cp -a `cat files.list` back-art
93 cp -a `cat files.list` back-xdps
94 ln -sf . back-xlib
95
96 %build
97 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
98
99 for g in art xdps xlib ; do
100 cd back-$g
101 if [ "$g" = "xlib" ]; then
102         INC='--with-include-flags=-I/usr/include/freetype2'
103         NAME="back"
104 else
105         INC=
106         NAME="back-$g"
107 fi
108 %configure \
109         --enable-graphics=$g \
110         --with-name=$NAME \
111         $INC
112
113 %{__make} \
114         messages=yes
115 cd ..
116 done
117
118 %{__make} -C Documentation
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
123
124 for g in art xdps xlib ; do
125 if [ "$g" = "xlib" ]; then
126         NAME="back"
127 else
128         NAME="back-$g"
129 fi
130 %{__make} install -C back-$g \
131         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
132         BUILD_GRAPHICS="$g" \
133         BACKEND_NAME="$NAME"
134 done
135
136 %{__make} install -C Documentation \
137         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
138
139 # not (yet?) supported by rpm-compress-doc
140 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
141         ! -name '*.gz' | xargs gzip -9nf
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc ChangeLog
152 %docdir %{_prefix}/System/Library/Documentation
153 %{_prefix}/System/Library/Documentation/Developer/Back
154 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
155
156 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
157 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
158 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
159
160 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
161
162 %files art
163 %defattr(644,root,root,755)
164 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
165 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
166 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
167
168 %files xdps
169 %defattr(644,root,root,755)
170 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
171 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
172 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.105435 seconds and 4 git commands to generate.