]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- rebuild with new Headers directory layout, release 2
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.8
5 Release:        2
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 # Source0-md5:  20c2d2f4f44bac053f7df02025c968d5
11 Patch0:         %{name}-xdps-fix.patch
12 URL:            http://www.gnustep.org/
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  WindowMaker-devel
15 BuildRequires:  XFree86-devel
16 BuildRequires:  XFree86-DPS-devel
17 BuildRequires:  freetype-devel >= 2.1.4
18 BuildRequires:  gnustep-gui-devel >= 0.8.8-2
19 BuildRequires:  libart_lgpl-devel
20 BuildRequires:  xft-devel
21 Requires:       OpenGL
22 Requires:       gnustep-gui >= 0.8.8-2
23 Obsoletes:      gnustep-xgps
24 Conflicts:      gnustep-core
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/lib/GNUstep
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %define         libcombo        gnu-gnu-gnu
32 %define         gsos            linux-gnu
33 %ifarch %{ix86}
34 %define         gscpu           ix86
35 %else
36 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
37 %define         gscpu           %{_target_cpu}
38 %endif
39
40 %description
41 This is a backend for the GNUstep gui Library which allows you to use
42 the GNUstep gui Library on an X Window System (other backends will
43 be added later to allow you to use the GNUstep gui Library in other
44 windowing environments).
45
46 This package contains common part and xlib graphics backend.
47
48 %description -l pl
49 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
50 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
51 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
52 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
53
54 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
55
56 %package art
57 Summary:        GNUstep graphics backend - art
58 Summary(pl):    Graficzny backend GNUstep - art
59 Group:          X11/Libraries
60 Requires:       %{name} = %{version}
61 Requires:       freetype >= 2.1.4
62 Conflicts:      gnustep-core
63
64 %description art
65 GNUstep graphics backend - art.
66
67 %description art -l pl
68 Graficzny backend GNUstep - art.
69
70 %package xdps
71 Summary:        GNUstep graphics backend - xdps
72 Summary(pl):    Graficzny backend GNUstep - xdps
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 Obsoletes:      gnustep-xdps
76 Conflicts:      gnustep-core
77
78 %description xdps
79 GNUstep graphics backend - xdps.
80
81 %description xdps -l pl
82 Graficzny backend GNUstep - xdps.
83
84 %package devel
85 Summary:        Headers for GNUstep backends
86 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
87 Group:          X11/Development/Libraries
88 Requires:       %{name} = %{version}
89 Requires:       XFree86-devel
90 Requires:       gnustep-gui-devel >= 0.8.8-2
91 Requires:       xft-devel
92 Obsoletes:      gnustep-xdps-devel
93 Obsoletes:      gnustep-xgps-devel
94 Conflicts:      gnustep-core
95
96 %description devel
97 This package contains development headers for GNUstep backends. It
98 includes also files specific for all x11 graphic backends (xlib,
99 art, xdps).
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
103 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
104 xdps).
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 # prepare three trees (for art, xdps and xlib backends)
111 echo * > files.list
112 install -d back-art back-xdps
113 cp -a `cat files.list` back-art
114 cp -a `cat files.list` back-xdps
115 ln -sf . back-xlib
116
117 %build
118 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
119
120 for g in art xdps xlib ; do
121 cd back-$g
122 if [ "$g" = "xlib" ]; then
123         INC='--with-include-flags=-I/usr/include/freetype2'
124         NAME="back"
125 else
126         INC=
127         NAME="back-$g"
128 fi
129 %configure \
130         --enable-graphics=$g \
131         --with-name=$NAME \
132         $INC
133
134 %{__make} \
135         messages=yes
136 cd ..
137 done
138
139 %{__make} -C Documentation
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
144
145 for g in art xdps xlib ; do
146 if [ "$g" = "xlib" ]; then
147         NAME="back"
148 else
149         NAME="back-$g"
150 fi
151 %{__make} install -C back-$g \
152         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
153         BUILD_GRAPHICS="$g" \
154         BACKEND_NAME="$NAME"
155 done
156
157 %{__make} install -C Documentation \
158         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
159
160 # not (yet?) supported by rpm-compress-doc
161 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
162         ! -name '*.gz' | xargs gzip -9nf
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 %doc ChangeLog
173 %docdir %{_prefix}/System/Library/Documentation
174 %{_prefix}/System/Library/Documentation/Developer/Back
175 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
176
177 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
178 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
179 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
180
181 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
182
183 %files art
184 %defattr(644,root,root,755)
185 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
186 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
187 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
188
189 %files xdps
190 %defattr(644,root,root,755)
191 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
192 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
193 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
194
195 %files devel
196 %defattr(644,root,root,755)
197 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gsc
198 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/x11
199
200 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/xlib
201 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/art
202 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/xdps
This page took 0.084069 seconds and 4 git commands to generate.