]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- 0.16.0
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO:
2 # - symlink Helvetica from ghostscript-fonts-std?
3 #
4 # Conditional build:
5 %bcond_without  art     # art backend
6 %bcond_with     dps     # xdps backend
7 %bcond_without  cairo   # cairo backend
8 %bcond_with     glitz   # glitz support in cairo backend (requires cairo built with glitz)
9 #
10 Summary:        The GNUstep backend bundle
11 Summary(pl.UTF-8):      Pakiet backendowy GNUstep
12 Name:           gnustep-back
13 Version:        0.16.0
14 Release:        1
15 License:        LGPL/GPL
16 Vendor:         The GNUstep Project
17 Group:          X11/Libraries
18 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
19 # Source0-md5:  31a16abe7c19914c6fe1300881f6c6ab
20 URL:            http://www.gnustep.org/
21 BuildRequires:  OpenGL-GLX-devel
22 %{?with_dps:BuildRequires:      X11-DPS-devel}
23 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0}
24 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
25 %{?with_glitz:BuildRequires:    glitz-devel}
26 BuildRequires:  gnustep-gui-devel >= %{version}
27 %{?with_art:BuildRequires:      libart_lgpl-devel}
28 BuildRequires:  pkgconfig
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXmu-devel
31 BuildRequires:  xorg-lib-libXft-devel
32 Requires:       gnustep-gui >= %{version}
33 Obsoletes:      gnustep-back-devel
34 %{!?with_dps:Obsoletes: gnustep-back-xdps}
35 Obsoletes:      gnustep-xgps
36 Conflicts:      gnustep-core
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
40
41 %description
42 This is a backend for the GNUstep gui Library which allows you to use
43 the GNUstep gui Library on an X Window System (other backends will
44 be added later to allow you to use the GNUstep gui Library in other
45 windowing environments).
46
47 This package contains common part and xlib graphics backend.
48
49 %description -l pl.UTF-8
50 To jest backend dla biblioteki GNUstep GUI, pozwalający na używanie
51 biblioteki graficznego interfejsu użytkownika GNUstep pod systemem X
52 Window (inne backendy, pozwalające na używanie biblioteki GNUstep GUI
53 w innych środowiskach okienkowych, zostaną dodane później).
54
55 Ten pakiet zawiera część wspólną i backend graficzny xlib.
56
57 %package art
58 Summary:        GNUstep graphics backend - art
59 Summary(pl.UTF-8):      Graficzny backend GNUstep - art
60 Group:          X11/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       freetype >= 2.1.8
63 Conflicts:      gnustep-core
64
65 %description art
66 GNUstep graphics backend - art.
67
68 %description art -l pl.UTF-8
69 Graficzny backend GNUstep - art.
70
71 %package cairo
72 Summary:        GNUstep graphics backend - cairo
73 Summary(pl.UTF-8):      Graficzny backend GNUstep - cairo
74 Group:          X11/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       cairo >= 1.0
77
78 %description cairo
79 GNUstep graphics backend - cairo.
80
81 %description cairo -l pl.UTF-8
82 Graficzny backend GNUstep - cairo.
83
84 %package xdps
85 Summary:        GNUstep graphics backend - xdps
86 Summary(pl.UTF-8):      Graficzny backend GNUstep - xdps
87 Group:          X11/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 Obsoletes:      gnustep-xdps
90 Conflicts:      gnustep-core
91
92 %description xdps
93 GNUstep graphics backend - xdps.
94
95 %description xdps -l pl.UTF-8
96 Graficzny backend GNUstep - xdps.
97
98 %prep
99 %setup -q
100
101 %if %{with cairo}
102 # hack cairo header - objc doesn't allow #defines in #include
103 sed -e 's,FT_FREETYPE_H,<freetype/freetype.h>,' /usr/include/cairo/cairo-ft.h > \
104         Headers/cairo-ft.h
105 %endif
106
107 # prepare the trees (for art, cairo, xdps, xlib backends)
108 echo * > files.list
109 %if %{with art}
110 install -d back-art 
111 cp -a `cat files.list` back-art
112 %endif
113 %if %{with cairo}
114 install -d back-cairo
115 cp -a `cat files.list` back-cairo
116 %endif
117 %if %{with dps}
118 install -d back-xdps
119 cp -a `cat files.list` back-xdps
120 %endif
121 ln -sf . back-xlib
122
123 %build
124 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
125 export GNUSTEP_FLATTENED=yes
126 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
127
128 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
129 cd back-$g
130 if [ "$g" = "xlib" ]; then
131         NAME="back"
132 else
133         NAME="back-$g"
134 fi
135 if [ "$g" = "cairo" ]; then
136         CPPFLAGS="-I/usr/include/freetype2"
137 fi
138 %configure \
139         %{!?with_glitz:--disable-glitz} \
140         --enable-graphics=$g \
141         --with-name=$NAME
142
143 %{__make} \
144         messages=yes
145 cd ..
146 done
147
148 %{__make} -C Documentation
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
153 export GNUSTEP_FLATTENED=yes
154 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
155
156 for g in %{?with_art:art} %{?with_cairo:cairo} %{?with_dps:xdps} xlib ; do
157 if [ "$g" = "xlib" ]; then
158         NAME="back"
159 else
160         NAME="back-$g"
161 fi
162 %{__make} install -C back-$g \
163         DESTDIR=$RPM_BUILD_ROOT \
164         BUILD_GRAPHICS="$g" \
165         BACKEND_NAME="$NAME"
166 done
167
168 %{__make} install -C Documentation \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 # not (yet?) supported by rpm-compress-doc
172 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
173         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc ChangeLog
184 %docdir %{_datadir}/GNUstep/Documentation
185 %{_datadir}/GNUstep/Documentation/Developer/Back
186 %{_mandir}/man1/gpbs.1*
187
188 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-016.bundle
189 %{_libdir}/GNUstep/Bundles/libgnustep-back-016.bundle/Resources
190 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-016.bundle/libgnustep-back-016
191
192 %dir %{_libdir}/GNUstep/Fonts
193 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
194 %{_libdir}/GNUstep/Fonts/Helvetica.nfont
195
196 %attr(755,root,root) %{_bindir}/*
197
198 %if %{with art}
199 %files art
200 %defattr(644,root,root,755)
201 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-art-016.bundle
202 %{_libdir}/GNUstep/Bundles/libgnustep-back-art-016.bundle/Resources
203 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-art-016.bundle/libgnustep-back-art-016
204 %endif
205
206 %if %{with cairo}
207 %files cairo
208 %defattr(644,root,root,755)
209 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-016.bundle
210 %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-016.bundle/Resources
211 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-cairo-016.bundle/libgnustep-back-cairo-016
212 %endif
213
214 %if %{with dps}
215 %files xdps
216 %defattr(644,root,root,755)
217 %dir %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-016.bundle
218 %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-016.bundle/Resources
219 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgnustep-back-xdps-016.bundle/libgnustep-back-xdps-016
220 %endif
This page took 0.083155 seconds and 4 git commands to generate.