]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/gnustep-back.git] / gnustep-back.spec
1 # TODO: symlink Helvetica from ghostscript-fonts-std?
2 #
3 # Conditional build:
4 %bcond_without  art     # don't build art backend
5 %bcond_without  cairo   # don't build cairo backend
6 #
7 Summary:        The GNUstep backend bundle
8 Summary(pl):    Pakiet backendowy GNUstep
9 Name:           gnustep-back
10 Version:        0.10.0
11 Release:        1
12 License:        LGPL/GPL
13 Vendor:         The GNUstep Project
14 Group:          X11/Libraries
15 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
16 # Source0-md5:  8031e2d93b4d3359e167be620d1925fb
17 URL:            http://www.gnustep.org/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  XFree86-devel
20 BuildRequires:  XFree86-DPS-devel
21 %{?with_cairo:BuildRequires:    cairo-devel < 0.5.0}
22 %{?with_art:BuildRequires:      freetype-devel >= 2.1.8}
23 BuildRequires:  gnustep-gui-devel >= %{version}
24 %{?with_art:BuildRequires:      libart_lgpl-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  xft-devel
27 Requires:       OpenGL
28 Requires:       gnustep-gui >= %{version}
29 Obsoletes:      gnustep-back-devel
30 Obsoletes:      gnustep-xgps
31 Conflicts:      gnustep-core
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _prefix         /usr/%{_lib}/GNUstep
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37
38 %define         libcombo        gnu-gnu-gnu
39 %define         gsos            linux-gnu
40 %ifarch %{ix86}
41 %define         gscpu           ix86
42 %else
43 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
44 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
45 %endif
46
47 %description
48 This is a backend for the GNUstep gui Library which allows you to use
49 the GNUstep gui Library on an X Window System (other backends will
50 be added later to allow you to use the GNUstep gui Library in other
51 windowing environments).
52
53 This package contains common part and xlib graphics backend.
54
55 %description -l pl
56 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
57 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
58 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
59 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
60
61 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
62
63 %package art
64 Summary:        GNUstep graphics backend - art
65 Summary(pl):    Graficzny backend GNUstep - art
66 Group:          X11/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       freetype >= 2.1.8
69 Conflicts:      gnustep-core
70
71 %description art
72 GNUstep graphics backend - art.
73
74 %description art -l pl
75 Graficzny backend GNUstep - art.
76
77 %package cairo
78 Summary:        GNUstep graphics backend - cairo
79 Summary(pl):    Graficzny backend GNUstep - cairo
80 Group:          X11/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       cairo < 0.5.0
83
84 %description cairo
85 GNUstep graphics backend - cairo.
86
87 %description cairo -l pl
88 Graficzny backend GNUstep - cairo.
89
90 %package xdps
91 Summary:        GNUstep graphics backend - xdps
92 Summary(pl):    Graficzny backend GNUstep - xdps
93 Group:          X11/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 Obsoletes:      gnustep-xdps
96 Conflicts:      gnustep-core
97
98 %description xdps
99 GNUstep graphics backend - xdps.
100
101 %description xdps -l pl
102 Graficzny backend GNUstep - xdps.
103
104 %prep
105 %setup -q
106
107 # prepare the trees (for art, cairo, xdps, xlib backends)
108 echo * > files.list
109 %if %{with art}
110 install -d back-art 
111 cp -a `cat files.list` back-art
112 %endif
113 %if %{with cairo}
114 install -d back-cairo
115 cp -a `cat files.list` back-cairo
116 %endif
117 install -d back-xdps
118 cp -a `cat files.list` back-xdps
119 ln -sf . back-xlib
120
121 %build
122 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
123
124 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
125 cd back-$g
126 if [ "$g" = "xlib" ]; then
127         INC='--with-include-flags=-I/usr/include/freetype2'
128         NAME="back"
129 else
130         INC=
131         NAME="back-$g"
132 fi
133 %configure \
134         --enable-graphics=$g \
135         --with-name=$NAME \
136         $INC
137
138 %{__make} \
139         messages=yes
140 cd ..
141 done
142
143 %{__make} -C Documentation
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
148
149 for g in %{?with_art:art} %{?with_cairo:cairo} xdps xlib ; do
150 if [ "$g" = "xlib" ]; then
151         NAME="back"
152 else
153         NAME="back-$g"
154 fi
155 %{__make} install -C back-$g \
156         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
157         BUILD_GRAPHICS="$g" \
158         BACKEND_NAME="$NAME"
159 done
160
161 %{__make} install -C Documentation \
162         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
163
164 # not (yet?) supported by rpm-compress-doc
165 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
166         ! -name '*.gz' | xargs gzip -9nf
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc ChangeLog
177 %docdir %{_prefix}/System/Library/Documentation
178 %{_prefix}/System/Library/Documentation/Developer/Back
179 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
180
181 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle
182 %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/Resources
183 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-010.bundle/%{gscpu}
184
185 # XXX: n0190{0,2,4,6}{3,4}.{pfb,afm,pfm} - symlink from ghostscript-fonts-std?
186 %{_prefix}/System/Library/Fonts/Helvetica.nfont
187
188 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
189
190 %if %{with art}
191 %files art
192 %defattr(644,root,root,755)
193 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle
194 %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/Resources
195 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art-010.bundle/%{gscpu}
196 %endif
197
198 %if %{with cairo}
199 %files cairo
200 %defattr(644,root,root,755)
201 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle
202 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/Resources
203 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo-010.bundle/%{gscpu}
204 %endif
205
206 %files xdps
207 %defattr(644,root,root,755)
208 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle
209 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/Resources
210 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps-010.bundle/%{gscpu}
This page took 0.112765 seconds and 4 git commands to generate.