]> git.pld-linux.org Git - packages/gnome-vfs2.git/commitdiff
- rel 17; fix build with openssl 1.1.1 auto/th/gnome-vfs2-2.24.4-17
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 17 Sep 2018 08:17:21 +0000 (10:17 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 17 Sep 2018 08:17:21 +0000 (10:17 +0200)
gnome-vfs2.spec
openssl.patch [new file with mode: 0644]

index b254c7db12da249945058e77329115a633ae4835..272a144a3eb14d304079273437f103698bfa74f4 100644 (file)
@@ -7,7 +7,7 @@ Summary:        GNOME - virtual file system
 Summary(pl.UTF-8):     GNOME - wirtualny system plików
 Name:          gnome-vfs2
 Version:       2.24.4
-Release:       16
+Release:       17
 License:       LGPL v2+
 Group:         Applications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-vfs/2.24/gnome-vfs-%{version}.tar.bz2
@@ -20,6 +20,7 @@ Patch3:               %{name}-headers-define.patch
 Patch4:                %{name}-ac-libs.patch
 Patch5:                %{name}-glib.patch
 Patch6:                am.patch
+Patch7:                openssl.patch
 URL:           http://www.gnome.org/
 BuildRequires: GConf2-devel >= 2.22.0
 BuildRequires: acl-devel >= 2.2.34
@@ -137,6 +138,10 @@ Dokumentacja API gnome-vfs.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+
+# fix for make -C doc
+iconv -f iso8859-2 -t utf8 libgnomevfs/gnome-vfs-job-queue.h > libgnomevfs/gnome-vfs-job-queue.h.new && mv libgnomevfs/gnome-vfs-job-queue.h.new libgnomevfs/gnome-vfs-job-queue.h
 
 %build
 %{__gtkdocize}
diff --git a/openssl.patch b/openssl.patch
new file mode 100644 (file)
index 0000000..dd95788
--- /dev/null
@@ -0,0 +1,38 @@
+--- gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c.org   2018-09-17 09:44:37.695718282 +0200
++++ gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c       2018-09-17 09:46:32.792578650 +0200
+@@ -72,6 +72,7 @@ typedef struct {
+ #ifdef HAVE_OPENSSL
+       int sockfd;
+       SSL *ssl;
++      SSL_CTX *ctx;
+       struct timeval *timeout;
+ #elif defined HAVE_GNUTLS
+       int sockfd;
+@@ -367,6 +368,7 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
+         /* FIXME: SSL_CTX_set_verify (ssl_ctx, SSL_VERIFY_PEER, &ssl_verify);*/
+         ssl->private->ssl = SSL_new (ssl_ctx);
++      ssl->private->ctx = ssl_ctx;
+       if (ssl->private->ssl == NULL) {
+               return GNOME_VFS_ERROR_IO;
+@@ -400,8 +402,8 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
+                       }
+               }
+-                if (ssl->private->ssl->ctx)
+-                        SSL_CTX_free (ssl->private->ssl->ctx);
++                if (ssl->private->ctx)
++                        SSL_CTX_free (ssl->private->ctx);
+                 SSL_free (ssl->private->ssl);
+               g_free (ssl->private);
+@@ -705,7 +707,7 @@ gnome_vfs_ssl_destroy (GnomeVFSSSL *ssl,
+               }
+       }
+       
+-      SSL_CTX_free (ssl->private->ssl->ctx);
++      SSL_CTX_free (ssl->private->ctx);
+       SSL_free (ssl->private->ssl);
+       close (ssl->private->sockfd);
+       if (ssl->private->timeout)
This page took 1.390643 seconds and 4 git commands to generate.