]> git.pld-linux.org Git - packages/gnome-todo.git/commitdiff
- added meson patch (fix enums generation); release 3 (evolution 3.46.x) auto/th/gnome-todo-41.0-3
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 30 May 2023 16:31:39 +0000 (18:31 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 30 May 2023 16:31:39 +0000 (18:31 +0200)
gnome-todo-meson.patch [new file with mode: 0644]
gnome-todo.spec

diff --git a/gnome-todo-meson.patch b/gnome-todo-meson.patch
new file mode 100644 (file)
index 0000000..9916f28
--- /dev/null
@@ -0,0 +1,53 @@
+--- gnome-todo-41.0/src/meson.build.orig       2021-09-16 19:48:29.552873400 +0200
++++ gnome-todo-41.0/src/meson.build    2023-05-30 18:28:16.358310543 +0200
+@@ -16,6 +16,25 @@ vcs_identifier_h = declare_dependency(so
+ gnome_todo_deps += vcs_identifier_h
++#########
++# Enums #
++#########
++
++enum_headers = files(
++  join_paths('animation', 'gtd-animation-enums.h'),
++)
++
++enum_types = 'gtd-enum-types'
++
++gtd_enum_types = gnome.mkenums(
++  enum_types,
++     sources: enum_headers,
++  c_template: enum_types + '.c.template',
++  h_template: enum_types + '.h.template'
++)
++
++sources += gtd_enum_types
++
+ ###########
+ # Plugins #
+ ###########
+@@ -43,24 +62,6 @@ gtd_deps = gnome_todo_deps + [
+ ]
+-#########
+-# Enums #
+-#########
+-
+-enum_headers = files(
+-  join_paths('animation', 'gtd-animation-enums.h'),
+-)
+-
+-enum_types = 'gtd-enum-types'
+-
+-sources += gnome.mkenums(
+-  enum_types,
+-     sources: enum_headers,
+-  c_template: enum_types + '.c.template',
+-  h_template: enum_types + '.h.template'
+-)
+-
+-
+ ################
+ # Header files #
+ ################
index 1de0fb3472eb73987a24d730d5699c9ab476b202..e6a76779f8f5cf2ade8201e01239e38ef9049249 100644 (file)
@@ -6,12 +6,13 @@ Summary:      GNOME To Do - application to manage your personal tasks
 Summary(pl.UTF-8):     GNOME To Do - aplikacja do zarzÄ…dzania osobistymi zadaniami
 Name:          gnome-todo
 Version:       41.0
-Release:       2
+Release:       3
 License:       GPL v3+
 Group:         X11/Applications
 Source0:       https://download.gnome.org/sources/gnome-todo/41/%{name}-%{version}.tar.xz
 # Source0-md5: 606b3f54e9f3676ee017a4f02e11948a
 Patch0:                %{name}-libportal.patch
+Patch1:                %{name}-meson.patch
 URL:           https://wiki.gnome.org/Apps/Todo
 BuildRequires: evolution-data-server-devel >= 3.33.2
 BuildRequires: gettext-tools >= 0.19.8
@@ -89,6 +90,7 @@ Dokumentacja API GNOME To Do.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %meson build \
This page took 0.262056 seconds and 4 git commands to generate.