]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
- updated to 0.4.23
[packages/gnome-speech.git] / gnome-speech.spec
1 # TODO:
2 # - build other speech plugins?
3 #
4 # Conditional build:
5 %bcond_without  festival        # don't build Festival plugin
6 %bcond_without  java            # don't build java subpackage
7 #
8 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
9 %undefine       with_java
10 %endif
11 Summary:        GNOME Speech - text-to-speech convertion
12 Summary(pl.UTF-8):      GNOME Speech - przekształcanie tekstu na mowę
13 Name:           gnome-speech
14 Version:        0.4.23
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-speech/0.4/%{name}-%{version}.tar.bz2
19 # Source0-md5:  54041cf87f7de56dd081848e86a08d4c
20 Patch0:         %{name}-jar_dir.patch
21 URL:            http://developer.gnome.org/projects/gap/
22 BuildRequires:  ORBit2-devel >= 1:2.14.7
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  espeak-devel
26 BuildRequires:  gnome-common >= 2.18.0
27 BuildRequires:  gtk-doc >= 1.8
28 %if %{with java}
29 BuildRequires:  java-access-bridge >= 1.18.0
30 BuildRequires:  jdk
31 %endif
32 BuildRequires:  libbonobo-devel >= 2.18.0
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 Requires:       gnome-speech-driver
36 Provides:       gnome_speech
37 Obsoletes:      gnome_speech
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GNOME Speech purpose is to provide a simple general API for producing
42 text-to-speech output.
43
44 %description -l pl.UTF-8
45 Celem GNOME Speech jest udostępnienie prostego, ogólnego API do
46 przekształcania tekstu na mowę.
47
48 %package driver-espeak
49 Summary:        Espeak TTS Speech Driver
50 Summary(pl.UTF-8):      Sterownik mowy ESpeak TTS
51 Group:          Libraries
52 Requires:       espeak
53 Provides:       gnome-speech-driver
54
55 %description driver-espeak
56 Provides text to speech services using the Espeak Speech Synthesis
57 System.
58
59 %description driver-espeak -l pl.UTF-8
60 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
61 użyciu systemu syntezy mowy Espeak.
62
63 %package driver-festival
64 Summary:        Festival TTS Speech Driver
65 Summary(pl.UTF-8):      Sterownik mowy Festival TTS
66 Group:          Libraries
67 Requires:       festival
68 Provides:       gnome-speech-driver
69
70 %description driver-festival
71 Provides the text to speech services using the Festival Speech
72 Synthesis System.
73
74 %description driver-festival -l pl.UTF-8
75 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
76 użyciu systemu syntezy mowy Festival.
77
78 %package driver-speech-dispatcher
79 Summary:        Speech Dispatcher driver
80 Summary(pl.UTF-8):      Sterownik mowy Speech Dispatcher
81 Group:          Libraries
82 Provides:       gnome-speech-driver
83
84 %description driver-speech-dispatcher
85 Provides the text to speech services using Speech Dispatcher.
86
87 %description driver-speech-dispatcher -l pl.UTF-8
88 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
89 użyciu systemu Speech Dispatcher.
90
91 %package devel
92 Summary:        Development files for gnome_speech
93 Summary(pl.UTF-8):      Pliki programistyczne dla gnome_speech
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       libbonobo-devel >= 2.18.0
97 Provides:       gnome_speech-devel
98 Obsoletes:      gnome_speech-devel
99
100 %description devel
101 GNOME Speech files needed for development.
102
103 %description devel -l pl.UTF-8
104 Pliki GNOME Speech potrzebne do programowania.
105
106 %package static
107 Summary:        Static gnome-speech library
108 Summary(pl.UTF-8):      Statyczna biblioteka gnome-speech
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 Static gnome-speech library.
114
115 %description static -l pl.UTF-8
116 Statyczna biblioteka gnome-speech.
117
118 %package java
119 Summary:        Java classes for gnome-speech
120 Summary(pl.UTF-8):      Klasy Java dla gnome-speech
121 Group:          Development/Languages/Java
122 Requires:       jpackage-utils
123
124 %description java
125 Java classes for gnome-speech.
126
127 %description java -l pl.UTF-8
128 Klasy Java dla gnome-speech.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__automake}
139 %{__autoconf}
140 %configure \
141         --enable-static \
142         --enable-gtk-doc \
143         --with%{!?with_festival:out}-festival \
144         --with-speech-dispatcher \
145         %{?with_java:--with-jab-dir=%{_javadir}}
146 %{__make} \
147         espeak_LIBDIR=%{_libdir}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         orbittypelibdir=%{_libdir}/orbit-2.0 \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 # no *.la for orbit modules
157 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/test-speech
168 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libgnomespeech.so.?
170 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
171
172 %files driver-espeak
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/espeak-synthesis-driver
175 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
176
177 %if %{with festival}
178 %files driver-festival
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
181 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
182 %endif
183
184 %files driver-speech-dispatcher
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_bindir}/speechd-synthesis-driver
187 %{_libdir}/bonobo/servers/GNOME_Speech_SynthDriver_Speech_Dispatcher.server
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libgnomespeech.so
192 %{_libdir}/libgnomespeech.la
193 %{_includedir}/gnome-speech-1.0
194 %{_datadir}/idl/gnome-speech-1.0
195 %{_pkgconfigdir}/*.pc
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/libgnomespeech.a
200
201 %if %{with java}
202 %files java
203 %defattr(644,root,root,755)
204 %{_javadir}/*.jar
205 %endif
This page took 0.053654 seconds and 3 git commands to generate.