]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- fix extensions.gnome.org for webkit based browsers
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.1
4 Release:        4
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  9519921d31d8c43d054dbc11e1f0733b
9 Patch0:         browser-plugin-webkit.patch
10 URL:            http://live.gnome.org/GnomeShell
11 BuildRequires:  GConf2-devel
12 BuildRequires:  NetworkManager-devel >= 0.8.999
13 BuildRequires:  autoconf >= 2.63
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  clutter-devel >= 1.7.5
16 BuildRequires:  dbus-glib-devel
17 BuildRequires:  evolution-data-server-devel >= 3.1.90
18 BuildRequires:  folks-devel >= 0.6.1
19 BuildRequires:  gettext-devel >= 0.17
20 BuildRequires:  gjs-devel >= 1.29.18
21 BuildRequires:  glib2-devel >= 1:2.29.10
22 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
23 BuildRequires:  gnome-desktop-devel >= 3.1.90
24 BuildRequires:  gnome-menus-devel >= 3.1.90
25 BuildRequires:  gobject-introspection-devel >= 0.10.1
26 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
27 BuildRequires:  gstreamer-devel >= 0.10.21
28 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
29 BuildRequires:  gtk+3-devel >= 3.0.0
30 BuildRequires:  intltool >= 0.40
31 BuildRequires:  json-glib-devel >= 0.13.90
32 BuildRequires:  libcanberra-devel
33 BuildRequires:  libcroco-devel >= 0.6.2
34 BuildRequires:  libgnome-keyring-devel
35 BuildRequires:  libsoup-devel
36 BuildRequires:  libtool >= 2:2.2.6
37 BuildRequires:  libxml2-devel
38 BuildRequires:  mutter-devel >= 3.2.1
39 BuildRequires:  pkgconfig >= 1:0.22
40 BuildRequires:  polkit-devel >= 0.100
41 BuildRequires:  pulseaudio-devel
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.601
44 BuildRequires:  startup-notification-devel >= 0.11
45 BuildRequires:  tar >= 1:1.22
46 BuildRequires:  telepathy-glib-devel >= 0.15.5
47 BuildRequires:  telepathy-logger-devel >= 0.2.4
48 BuildRequires:  xorg-lib-libXfixes-devel
49 # for libmozjs.so
50 BuildRequires:  xulrunner-libs
51 BuildRequires:  xz
52 Requires(post,postun):  glib2 >= 1:2.26.0
53 Requires(post,preun):   GConf2
54 Requires:       caribou >= 0.3.5
55 Requires:       evolution-data-server >= 3.1.90
56 Requires:       gnome-bluetooth-libs >= 3.1.0
57 Requires:       gnome-menus >= 3.1.90
58 Requires:       gnome-settings-daemon >= 3.1.90
59 Requires:       gsettings-desktop-schemas >= 3.1.90
60 Requires:       mutter >= 3.2.1
61 Requires:       nautilus >= 3.2.0
62 Requires:       telepathy-logger >= 0.2.4
63 %requires_eq    xulrunner-libs
64 Suggests:       gnome-contacts >= 3.2.0
65 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
66 Provides:       gdm-wm = 3.2.1-1
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 GNOME Shell is the defining technology of the GNOME 3 desktop user
71 experience. It provides core interface functions like switching to
72 windows and launching applications. GNOME Shell takes advantage of the
73 capabilities of modern graphics hardware and introduces innovative
74 user interface concepts to provide a delightful and easy to use
75 experience.
76
77 %package -n browser-plugin-%{name}
78 Summary:        gnome-shell plugin for WWW browsers
79 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
80 Group:          X11/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       browser-plugins >= 2.0
83 Requires:       browser-plugins(%{_target_base_arch})
84 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
85 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
86 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
87 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
88
89 %description -n browser-plugin-%{name}
90 gnome-shell plugin for WWW browsers.
91
92 %description -n browser-plugin-%{name} -l pl.UTF-8
93 Wtyczka gnome-shell do przeglÄ…darek WWW.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__intltoolize}
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
107 %configure \
108         --with-ca-certificates=/etc/certs/ca-certificates.crt \
109         --disable-schemas-install \
110         --disable-silent-rules \
111         --disable-static
112 %{__make} -j1
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
117
118 %{__make} install \
119         INSTALL="install -p" \
120         install_sh="install -p" \
121         DESTDIR=$RPM_BUILD_ROOT \
122         mozillalibdir=%{_browserpluginsdir}
123
124 # TODO use rpath at link time instead of this hack
125 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
126 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
127 #!/bin/sh
128 LD_LIBRARY_PATH=%{_libdir}/xulrunner
129 export LD_LIBRARY_PATH
130 exec %{_bindir}/gnome-shell.bin "$@"
131 EOF
132 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
135         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 %gconf_schema_install gnome-shell.schemas
144 %glib_compile_schemas
145
146 %preun
147 %gconf_schema_uninstall gnome-shell.schemas
148
149 %postun
150 if [ "$1" = "0" ]; then
151         %glib_compile_schemas
152 fi
153
154 %post -n browser-plugin-%{name}
155 %update_browser_plugins
156
157 %postun -n browser-plugin-%{name}
158 if [ "$1" = 0 ]; then
159         %update_browser_plugins
160 fi
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/gnome-shell
165 %attr(755,root,root) %{_bindir}/gnome-shell.bin
166 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
167 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
168 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
169 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
170 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
171 %dir %{_libdir}/gnome-shell
172 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
173 %{_libdir}/gnome-shell/Gvc-1.0.typelib
174 %{_libdir}/gnome-shell/Shell-0.1.typelib
175 %{_libdir}/gnome-shell/St-1.0.typelib
176 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
177 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
178 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
179 %{_datadir}/gnome-shell
180 %{_desktopdir}/gnome-shell.desktop
181 %{_mandir}/man1/gnome-shell.1*
182
183 %files -n browser-plugin-%{name}
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.059783 seconds and 4 git commands to generate.