]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 40.3
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.7.5
9 %define         gjs_ver                         1.65.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   3.33.1
14 %define         gtk_ver                         3.15.0
15 %define         json_glib_ver                   0.13.90
16 %define         libsecret_ver                   0.18
17 %define         mutter_ver                      40.0
18 %define         NetworkManager_ver              1.10.4
19 %define         polkit_ver                      0.100
20 %define         pulseaudio_ver                  13
21 %define         startup_notification_ver        0.11
22
23 Summary:        Window manager and application launcher for GNOME
24 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
25 Name:           gnome-shell
26 Version:        40.3
27 Release:        1
28 License:        GPL v2+
29 Group:          X11/Window Managers
30 Source0:        https://download.gnome.org/sources/gnome-shell/40/%{name}-%{version}.tar.xz
31 # Source0-md5:  5cdf05bf088e035311d469abde692f8c
32 URL:            https://wiki.gnome.org/Projects/GnomeShell
33 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
34 BuildRequires:  at-spi2-atk-devel
35 BuildRequires:  bash-completion-devel >= 2.0
36 BuildRequires:  clutter-devel >= %{clutter_ver}
37 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
38 BuildRequires:  gcr-devel >= %{gcr_ver}
39 BuildRequires:  gdk-pixbuf2-devel >= 2.0
40 BuildRequires:  gettext-tools >= 0.19.6
41 BuildRequires:  gjs-devel >= %{gjs_ver}
42 BuildRequires:  glib2-devel >= %{glib_ver}
43 BuildRequires:  gnome-autoar-devel
44 BuildRequires:  gnome-bluetooth-devel >= %{gnome_bluetooth_ver}
45 BuildRequires:  gnome-control-center-devel
46 BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_ver}
47 BuildRequires:  gobject-introspection-devel >= 1.50.0
48 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
49 BuildRequires:  gstreamer-devel >= 1.0.0
50 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
51 BuildRequires:  gtk+3-devel >= %{gtk_ver}
52 BuildRequires:  gtk4-devel >= 4
53 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
54 BuildRequires:  ibus-devel >= 1.5.2
55 BuildRequires:  json-glib-devel >= %{json_glib_ver}
56 BuildRequires:  libcanberra-devel
57 BuildRequires:  libcanberra-gtk3-devel
58 BuildRequires:  libsecret-devel >= %{libsecret_ver}
59 BuildRequires:  libsoup-devel
60 BuildRequires:  libxml2-devel >= 2.0
61 BuildRequires:  libxslt-progs
62 BuildRequires:  meson >= 0.53.0
63 BuildRequires:  mutter-devel >= %{mutter_ver}
64 BuildRequires:  ninja >= 1.5
65 BuildRequires:  pipewire-devel >= 0.3
66 BuildRequires:  pkgconfig >= 1:0.22
67 BuildRequires:  polkit-devel >= %{polkit_ver}
68 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
69 BuildRequires:  python3 >= 1:3
70 BuildRequires:  python3-pygobject3 >= 3
71 BuildRequires:  rpm-build >= 4.6
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  rpmbuild(macros) >= 1.752
74 BuildRequires:  sassc
75 BuildRequires:  sed >= 4.0
76 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
77 BuildRequires:  systemd-devel
78 BuildRequires:  systemd-units
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xorg-lib-libX11-devel
81 BuildRequires:  xorg-lib-libXfixes-devel
82 BuildRequires:  xz
83 Requires(post,postun):  glib2 >= %{glib_ver}
84 # gjs->gi->NMA.gir
85 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
86 Requires:       adwaita-icon-theme
87 Requires:       at-spi2-atk >= 2.4.0
88 Requires:       clutter >= %{clutter_ver}
89 Requires:       evolution-data-server >= %{evolution_data_server_ver}
90 Requires:       gcr >= %{gcr_ver}
91 Requires:       gjs >= %{gjs_ver}
92 Requires:       glib2 >= %{glib_ver}
93 Requires:       gnome-bluetooth-libs >= %{gnome_bluetooth_ver}
94 Requires:       gnome-desktop >= %{gnome_desktop_ver}
95 Requires:       gnome-settings-daemon >= 3.8.0
96 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
97 Requires:       gtk+3 >= %{gtk_ver}
98 Requires:       ibus >= 1.5.2
99 Requires:       json-glib >= %{json_glib_ver}
100 Requires:       libsecret >= %{libsecret_ver}
101 Requires:       mutter >= %{mutter_ver}
102 Requires:       nautilus >= 3.8.0
103 Requires:       polkit >= %{polkit_ver}
104 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
105 Requires:       startup-notification >= %{startup_notification_ver}
106 # gjs->gir->TelepathyGLib
107 Requires:       telepathy-glib >= 0.17.5
108 # gjs->gir->TelepathyLogger
109 Requires:       telepathy-logger-libs >= 0.2
110 Requires:       telepathy-mission-control
111 Suggests:       gnome-contacts >= 3.2.0
112 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
113 Provides:       gdm-wm = 3.8.0
114 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %description
118 GNOME Shell is the defining technology of the GNOME 3 desktop user
119 experience. It provides core interface functions like switching to
120 windows and launching applications. GNOME Shell takes advantage of the
121 capabilities of modern graphics hardware and introduces innovative
122 user interface concepts to provide a delightful and easy to use
123 experience.
124
125 %description -l pl.UTF-8
126 GNOME Shell to technologia definiująca doznania użytkownika środowiska
127 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
128 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
129 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
130 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
131 doznania i łatwość użycia.
132
133 %package -n bash-completion-gnome-shell
134 Summary:        Bash completion for GNOME Shell commands
135 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń GNOME Shell
136 Group:          Applications/Shells
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       bash-completion >= 2.0
139 BuildArch:      noarch
140
141 %description -n bash-completion-gnome-shell
142 Bash completion for GNOME Shell commands.
143
144 %description -n bash-completion-gnome-shell -l pl.UTF-8
145 Bashowe dopełnianie parametrów poleceń GNOME Shell.
146
147 %package devel
148 Summary:        Development files for GNOME Shell
149 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
150 Group:          Development/Libraries
151 BuildArch:      noarch
152
153 %description devel
154 This package provides development files for GNOME Shell.
155
156 %description devel -l pl.UTF-8
157 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
158
159 %package apidocs
160 Summary:        GNOME Shell API documentation
161 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
162 Group:          Documentation
163 Requires:       gtk-doc-common
164 BuildArch:      noarch
165
166 %description apidocs
167 This package provides GNOME Shell API documentation.
168
169 %description apidocs -l pl.UTF-8
170 Ten pakiet dostarcza dokumentację API GNOME Shell.
171
172 %prep
173 %setup -q
174
175 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
176
177 %build
178 %meson build \
179         %{?with_apidocs:-Dgtk_doc=true}
180
181 %meson_build -C build
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
186
187 %meson_install -C build
188
189 # evolution already ships this file
190 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
191
192 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
193
194 %find_lang %{name}
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post
200 %glib_compile_schemas
201
202 %postun
203 if [ "$1" = "0" ]; then
204         %glib_compile_schemas
205 fi
206
207 %files -f %{name}.lang
208 %defattr(644,root,root,755)
209 %doc NEWS README.md
210 %attr(755,root,root) %{_bindir}/gnome-extensions
211 %attr(755,root,root) %{_bindir}/gnome-extensions-app
212 %attr(755,root,root) %{_bindir}/gnome-shell
213 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
214 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
215 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
216 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
217 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
218 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
219 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
220 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
221 %dir %{_libdir}/gnome-shell
222 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
223 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
224 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
225 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
226 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
227 %{_libdir}/gnome-shell/Gvc-1.0.typelib
228 %{_libdir}/gnome-shell/Shell-0.1.typelib
229 %{_libdir}/gnome-shell/St-1.0.typelib
230 %dir %{_libdir}/gnome-shell/girepository-1.0
231 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
232 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
233 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
234 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
235 %{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
236 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
237 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
238 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
239 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
240 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
241 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
242 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
243 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
244 %{_datadir}/gnome-control-center/keybindings/*.xml
245 %{_datadir}/gnome-shell
246 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
247 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
248 %{_desktopdir}/org.gnome.Extensions.desktop
249 %{_desktopdir}/org.gnome.Shell.desktop
250 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
251 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
252 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
253 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
254 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
255 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
256 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
257 %{_mandir}/man1/gnome-extensions.1*
258 %{_mandir}/man1/gnome-shell.1*
259 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
260 %{systemduserunitdir}/org.gnome.Shell.target
261 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
262 %{systemduserunitdir}/org.gnome.Shell@wayland.service
263 %{systemduserunitdir}/org.gnome.Shell@x11.service
264
265 %files -n bash-completion-gnome-shell
266 %defattr(644,root,root,755)
267 %{bash_compdir}/gnome-extensions
268
269 %files devel
270 %defattr(644,root,root,755)
271 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
272 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
273 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
274 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
275 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
276 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
277
278 %if %{with apidocs}
279 %files apidocs
280 %defattr(644,root,root,755)
281 %{_gtkdocdir}/shell
282 %{_gtkdocdir}/st
283 %endif
This page took 0.059671 seconds and 3 git commands to generate.