]> git.pld-linux.org Git - packages/gnome-shell-extensions.git/blob - gnome-shell-extensions.spec
5f994838f80e51212f587f0543f90b8946dbafb7
[packages/gnome-shell-extensions.git] / gnome-shell-extensions.spec
1 %define         major_version           3.8
2 # Minimum GNOME Shell version supported
3 %define         global min_gs_version   %{major_version}.0
4
5 Summary:        Modify and extend GNOME Shell functionality and behavior
6 Name:           gnome-shell-extensions
7 Version:        %{major_version}.1
8 Release:        1
9 Group:          X11/Applications
10 # The entire source code is GPLv2+ except lib/convenience.js which is BSD
11 License:        GPLv2+ and BSD
12 URL:            http://live.gnome.org/GnomeShell/Extensions
13 # Using git archive since upstream doesn't publish tarballs on ftp.gnome.org
14 # anymore
15 # $ git clone git://git.gnome.org/gnome-shell-extensions/
16 # $ cd gnome-shell-extensions/
17 # $ git archive --format=tar --prefix=%{name}-%{version}/ %{version} | xz > ../%{name}-%{version}.tar.xz
18 #Source0:       %{name}-%{version}.tar.xz
19 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell-extensions/3.8/%{name}-%{version}.tar.xz
20 # Source0-md5:  37aaa4731e9355f7904fbcddd56a0e86
21 BuildRequires:  gnome-common
22 BuildRequires:  gnome-desktop-devel
23 BuildRequires:  intltool
24 BuildRequires:  libgtop-devel
25 Requires:       gnome-shell >= %{min_gs_version}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         ext_prefix      gnome-shell-extension
29
30 %description
31 GNOME Shell Extensions is a collection of extensions providing
32 additional and optional functionality to GNOME Shell.
33
34 Enabled extensions:
35   - alternate-tab
36   - alternative-status-menu
37   - apps-menu
38   - auto-move-windows
39   - default-min-max
40   - drive-menu
41   - launch-new-instance
42   - native-window-placement
43   - places-menu
44   - static-workspaces
45   - systemMonitor
46   - user-theme
47   - window-list
48   - windowsNavigator
49   - workspace-indicator
50   - xrandr-indicator
51
52 %package common
53 Summary:        Files common to GNOME Shell Extensions
54 License:        GPL v2+
55 Group:          X11/Applications
56 Requires:       gnome-shell >= %{min_gs_version}
57 Obsoletes:      gnome-shell-extension-dock < 3.8.0
58 Obsoletes:      gnome-shell-extension-gajim < 3.8.0
59
60 %description common
61 GNOME Shell Extensions is a collection of extensions providing
62 additional and optional functionality to GNOME Shell. Common files and
63 directories needed by extensions are provided here.
64
65 %package -n gnome-classic-session
66 Summary:        GNOME "classic" mode session
67 License:        GPL v2+
68 Group:          X11/Applications
69 Requires:       %{ext_prefix}-alternate-tab = %{version}-%{release}
70 Requires:       %{ext_prefix}-apps-menu = %{version}-%{release}
71 Requires:       %{ext_prefix}-default-min-max = %{version}-%{release}
72 Requires:       %{ext_prefix}-launch-new-instance = %{version}-%{release}
73 Requires:       %{ext_prefix}-places-menu = %{version}-%{release}
74 Requires:       %{ext_prefix}-static-workspaces = %{version}-%{release}
75 Requires:       %{ext_prefix}-window-list = %{version}-%{release}
76 Requires:       gnome-session >= 1:3.8.0
77
78 %description -n gnome-classic-session
79 This package contains the required components for the GNOME Shell
80 "classic" mode, which aims to provide a GNOME 2-like user interface.
81
82 %package -n %{ext_prefix}-alternate-tab
83 Summary:        Classic Alt+Tab behavior. Window based instead of app based
84 License:        GPL v2+
85 Group:          X11/Applications
86 Requires:       %{name}-common = %{version}-%{release}
87
88 %description -n %{ext_prefix}-alternate-tab
89 Lets you use classic Alt+Tab (window-based instead of app-based) in
90 GNOME Shell. GNOME Shell groups multiple instances of the same
91 application together. This extension disables grouping.
92
93 %package -n %{ext_prefix}-alternative-status-menu
94 Summary:        For those who want a power off item visible at all the time
95 License:        GPL v2+
96 Group:          X11/Applications
97 Requires:       %{name}-common = %{version}-%{release}
98
99 %description -n %{ext_prefix}-alternative-status-menu
100 For those who want a power off item visible at all the time, replaces
101 GNOME Shell status menu with one featuring separate Suspend and Power
102 Off. Adds the ability to hibernate as well.
103
104 %package -n %{ext_prefix}-apps-menu
105 Summary:        Application menu for GNOME Shell
106 License:        GPL v2+
107 Group:          X11/Applications
108 Requires:       %{name}-common = %{version}-%{release}
109
110 %description  -n %{ext_prefix}-apps-menu
111 Add a GNOME 2.x style menu for applications.
112
113 %package -n %{ext_prefix}-auto-move-windows
114 Summary:        Assign specific workspaces to applications
115 License:        GPL v2+
116 Group:          X11/Applications
117 Requires:       %{name}-common = %{version}-%{release}
118
119 %description -n %{ext_prefix}-auto-move-windows
120 Lets you manage your workspaces more easily, assigning a specific
121 workspace to each application as soon as it creates a window, in a
122 manner configurable with a GSettings key.
123
124 %package -n %{ext_prefix}-default-min-max
125 Summary:        Add minimize and maximize titlebar buttons in GNOME Shell
126 License:        GPL v2+
127 Group:          X11/Applications
128 Requires:       %{name}-common = %{version}-%{release}
129
130 %description -n %{ext_prefix}-default-min-max
131 This GNOME Shell extension adds minimize and maximize buttons to the
132 titlebar by default.
133
134 %package -n %{ext_prefix}-drive-menu
135 Summary:        Disk device manager in the system status area
136 License:        GPL v2+
137 Group:          X11/Applications
138 Requires:       %{name}-common = %{version}-%{release}
139
140 %description -n %{ext_prefix}-drive-menu
141 Adds a menu in the system status area that tracks removable disk
142 devices attached and offers to browse them and eject/unmount them.
143
144 %package -n %{ext_prefix}-launch-new-instance
145 Summary:        Always launch a new application instance for GNOME Shell
146 License:        GPL v2+
147 Group:          X11/Applications
148 Requires:       %{name}-common = %{version}-%{release}
149
150 %description  -n %{ext_prefix}-launch-new-instance
151 This GNOME Shell extension modifies the behavior of clicking in the
152 dash and app launcher to always launch a new application instance.
153
154 %package -n %{ext_prefix}-native-window-placement
155 Summary:        Arrange windows in overview in a more native way
156 License:        GPL v2+
157 Group:          X11/Applications
158 Requires:       %{name}-common = %{version}-%{release}
159
160 %description -n %{ext_prefix}-native-window-placement
161 This extension employs an algorithm (taken from KDE) for layouting the
162 thumbnails in the overview that more closely reflects the positions
163 and relative sizes of the actual windows, instead of using a fixed
164 grid.
165
166 %package -n %{ext_prefix}-places-menu
167 Summary:        Places menu indicator in the system status area
168 License:        GPL v2+
169 Group:          X11/Applications
170 Requires:       %{name}-common = %{version}-%{release}
171
172 %description -n %{ext_prefix}-places-menu
173 Adds a menu in the system status area that resembles the Places menu
174 from GNOME 2.x
175
176 %package -n %{ext_prefix}-static-workspaces
177 Summary:        Disable dynamic workspace management in GNOME Shell
178 License:        GPL v2+
179 Group:          X11/Applications
180 Requires:       %{name}-common = %{version}-%{release}
181
182 %description -n %{ext_prefix}-static-workspaces
183 This GNOME Shell extension disables dynamic workspace management.
184
185 %package -n %{ext_prefix}-systemMonitor
186 Summary:        Monitor your system status
187 License:        GPL v2+
188 Group:          X11/Applications
189 Requires:       %{name}-common = %{version}-%{release}
190 Requires:       libgtop
191
192 %description -n %{ext_prefix}-systemMonitor
193 Monitor your system status
194
195 %package -n %{ext_prefix}-user-theme
196 Summary:        Lets the user select a custom theme for the shell
197 License:        GPL v2+
198 Group:          X11/Applications
199 Requires:       %{name}-common = %{version}-%{release}
200
201 %description -n %{ext_prefix}-user-theme
202 Lets the user select a custom theme for the Gnome shell. It will allow
203 you to apply a style from
204 /.themes/[themeName]/gnome-shell/gnome-shell.css
205
206 %package -n %{ext_prefix}-window-list
207 Summary:        Display a window list at the bottom of the screen in GNOME Shell
208 License:        GPL v2+
209 Group:          X11/Applications
210 Requires:       %{name}-common = %{version}-%{release}
211
212 %description -n %{ext_prefix}-window-list
213 This GNOME Shell extension displays a window list at the bottom of the
214 screen.
215
216 %package -n %{ext_prefix}-windowsNavigator
217 Summary:        Keyboard selection of windows and work-spaces in overlay mode
218 License:        GPL v2+
219 Group:          X11/Applications
220 Requires:       %{name}-common = %{version}-%{release}
221
222 %description -n %{ext_prefix}-windowsNavigator
223 Allow keyboard selection of windows and work-spaces in overlay mode in
224 GNOME Shell. Switch to overview mode (press the windows or alt+f1 key)
225 and press the alt key to show numbers over windows. Press any number
226 to switch to the corresponding window.
227
228 %package -n %{ext_prefix}-workspace-indicator
229 Summary:        Workspace Indicator
230 License:        GPL v2+
231 Group:          X11/Applications
232 Requires:       %{name}-common = %{version}-%{release}
233
234 %description -n %{ext_prefix}-workspace-indicator
235 Put an indicator on the panel signaling in which workspace you are,
236 and give you the possibility of switching to another one.
237
238 %package -n %{ext_prefix}-xrandr-indicator
239 Summary:        Monitor status indicator
240 License:        GPL v2+
241 Group:          X11/Applications
242 Requires:       %{name}-common = %{version}-%{release}
243
244 %description  -n %{ext_prefix}-xrandr-indicator
245 This extension adds a systems status menu for rotating monitors
246 (overrides what is currently provided by gnome-settings-daemon.
247
248 %prep
249 %setup -q
250
251 %build
252 %{__glib_gettextize}
253 %{__intltoolize}
254 %{__libtoolize}
255 %{__aclocal}
256 %{__autoconf}
257 %{__automake}
258 %configure \
259         --enable-extensions="all"
260
261 %{__make}
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265
266 %{__make} install \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 # Drop useless example extension
270 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions/example*
271 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.example.gschema.xml
272
273 %find_lang %{name}
274
275 %clean
276 rm -rf $RPM_BUILD_ROOT
277
278 %post -n %{ext_prefix}-alternative-status-menu
279 %glib_compile_schemas
280
281 %postun -n %{ext_prefix}-alternative-status-menu
282 %glib_compile_schemas
283
284 %post -n %{ext_prefix}-auto-move-windows
285 %glib_compile_schemas
286
287 %postun -n %{ext_prefix}-auto-move-windows
288 %glib_compile_schemas
289
290 %post -n %{ext_prefix}-native-window-placement
291 %glib_compile_schemas
292
293 %postun -n %{ext_prefix}-native-window-placement
294 %glib_compile_schemas
295
296 %post -n %{ext_prefix}-user-theme
297 %glib_compile_schemas
298
299 %postun -n %{ext_prefix}-user-theme
300 %glib_compile_schemas
301
302 %post -n %{ext_prefix}-window-list
303 %glib_compile_schemas
304
305 %postun -n %{ext_prefix}-window-list
306 %glib_compile_schemas
307
308 %files common -f %{name}.lang
309 %defattr(644,root,root,755)
310 %doc COPYING NEWS README
311 %dir %{_datadir}/gnome-shell/extensions
312
313 %files -n gnome-classic-session
314 %defattr(644,root,root,755)
315 %{_desktopdir}/gnome-shell-classic.desktop
316 %{_datadir}/gnome-session/sessions/gnome-classic.session
317 %dir %{_datadir}/gnome-shell/modes
318 %{_datadir}/gnome-shell/modes/classic.json
319 %{_datadir}/gnome-shell/theme/*.svg
320 %{_datadir}/gnome-shell/theme/gnome-classic.css
321 %{_datadir}/xsessions/gnome-classic.desktop
322
323 %files -n %{ext_prefix}-alternate-tab
324 %defattr(644,root,root,755)
325 %{_datadir}/gnome-shell/extensions/alternate-tab*
326
327 %files -n %{ext_prefix}-alternative-status-menu
328 %defattr(644,root,root,755)
329 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.alternative-status-menu.gschema.xml
330 %{_datadir}/gnome-shell/extensions/alternative-status-menu*
331
332 %files -n %{ext_prefix}-apps-menu
333 %defattr(644,root,root,755)
334 %{_datadir}/gnome-shell/extensions/apps-menu*
335
336 %files -n %{ext_prefix}-auto-move-windows
337 %defattr(644,root,root,755)
338 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.auto-move-windows.gschema.xml
339 %{_datadir}/gnome-shell/extensions/auto-move-windows*
340
341 %files -n %{ext_prefix}-default-min-max
342 %defattr(644,root,root,755)
343 %{_datadir}/gnome-shell/extensions/default-min-max*
344
345 %files -n %{ext_prefix}-drive-menu
346 %defattr(644,root,root,755)
347 %{_datadir}/gnome-shell/extensions/drive-menu*
348
349 %files -n %{ext_prefix}-launch-new-instance
350 %defattr(644,root,root,755)
351 %{_datadir}/gnome-shell/extensions/launch-new-instance*
352
353 %files -n %{ext_prefix}-native-window-placement
354 %defattr(644,root,root,755)
355 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.native-window-placement.gschema.xml
356 %{_datadir}/gnome-shell/extensions/native-window-placement*
357
358 %files -n %{ext_prefix}-places-menu
359 %defattr(644,root,root,755)
360 %{_datadir}/gnome-shell/extensions/places-menu*
361
362 %files -n %{ext_prefix}-static-workspaces
363 %defattr(644,root,root,755)
364 %{_datadir}/gnome-shell/extensions/static-workspaces*
365
366 %files -n %{ext_prefix}-systemMonitor
367 %defattr(644,root,root,755)
368 %{_datadir}/gnome-shell/extensions/systemMonitor*
369
370 %files -n %{ext_prefix}-user-theme
371 %defattr(644,root,root,755)
372 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.user-theme.gschema.xml
373 %{_datadir}/gnome-shell/extensions/user-theme*
374
375 %files -n %{ext_prefix}-window-list
376 %defattr(644,root,root,755)
377 %{_datadir}/gnome-shell/extensions/window-list*
378 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.window-list.gschema.xml
379
380 %files -n %{ext_prefix}-windowsNavigator
381 %defattr(644,root,root,755)
382 %{_datadir}/gnome-shell/extensions/windowsNavigator*
383
384 %files -n %{ext_prefix}-workspace-indicator
385 %defattr(644,root,root,755)
386 %{_datadir}/gnome-shell/extensions/workspace-indicator*
387
388 %files -n %{ext_prefix}-xrandr-indicator
389 %defattr(644,root,root,755)
390 %{_datadir}/gnome-shell/extensions/xrandr-indicator*
This page took 0.101569 seconds and 2 git commands to generate.