]> git.pld-linux.org Git - packages/gnome-shell-extensions.git/blob - gnome-shell-extensions.spec
2f8b78661566f3f9cade48535740dc98afc21c62
[packages/gnome-shell-extensions.git] / gnome-shell-extensions.spec
1 %define         major_version           3.24
2 # Minimum GNOME Shell version supported
3 %define         global min_gs_version   %{major_version}.0
4
5 Summary:        Modify and extend GNOME Shell functionality and behavior
6 Name:           gnome-shell-extensions
7 Version:        %{major_version}.0
8 Release:        1
9 Group:          X11/Applications
10 # The entire source code is GPLv2+ except lib/convenience.js which is BSD
11 License:        GPLv2+ and BSD
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell-extensions/3.24/%{name}-%{version}.tar.xz
13 # Source0-md5:  3df6e0afc840d752f73e3f0e8f915b22
14 URL:            http://live.gnome.org/GnomeShell/Extensions
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.10
17 BuildRequires:  gnome-common
18 BuildRequires:  gnome-desktop-devel
19 BuildRequires:  libgtop-devel >= 2.28.3
20 BuildRequires:  pkgconfig >= 1:0.22
21 BuildRequires:  ruby-sass
22 Requires:       gnome-shell >= %{min_gs_version}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         ext_prefix      gnome-shell-extension
26
27 %description
28 GNOME Shell Extensions is a collection of extensions providing
29 additional and optional functionality to GNOME Shell.
30
31 Enabled extensions:
32   - alternate-tab
33   - apps-menu
34   - auto-move-windows
35   - drive-menu
36   - launch-new-instance
37   - native-window-placement
38   - places-menu
39   - screenshot-window-sizer
40   - user-theme
41   - window-list
42   - windowsNavigator
43   - workspace-indicator
44
45 %package common
46 Summary:        Files common to GNOME Shell Extensions
47 License:        GPL v2+
48 Group:          X11/Applications
49 Requires:       gnome-shell >= %{min_gs_version}
50 Obsoletes:      gnome-shell-extension-alternative-status-menu < 3.10.1
51 Obsoletes:      gnome-shell-extension-default-min-max < 3.8.3.1
52 Obsoletes:      gnome-shell-extension-dock < 3.8.0
53 Obsoletes:      gnome-shell-extension-gajim < 3.8.0
54 Obsoletes:      gnome-shell-extension-static-workspaces < 3.8.3.1
55 Obsoletes:      gnome-shell-extension-xrandr-indicator < 3.10.1
56 Obsoletes:      gnome-shell-extension-systemMonitor < 3.16.0
57
58 %description common
59 GNOME Shell Extensions is a collection of extensions providing
60 additional and optional functionality to GNOME Shell. Common files and
61 directories needed by extensions are provided here.
62
63 %package -n gnome-classic-session
64 Summary:        GNOME "classic" mode session
65 License:        GPL v2+
66 Group:          X11/Applications
67 Requires(post,postun):  glib2 >= 1:2.26.0
68 Requires:       %{ext_prefix}-alternate-tab = %{version}-%{release}
69 Requires:       %{ext_prefix}-apps-menu = %{version}-%{release}
70 Requires:       %{ext_prefix}-launch-new-instance = %{version}-%{release}
71 Requires:       %{ext_prefix}-places-menu = %{version}-%{release}
72 Requires:       %{ext_prefix}-window-list = %{version}-%{release}
73 Requires:       gnome-session >= 1:3.14.0
74
75 %description -n gnome-classic-session
76 This package contains the required components for the GNOME Shell
77 "classic" mode, which aims to provide a GNOME 2-like user interface.
78
79 %package -n %{ext_prefix}-alternate-tab
80 Summary:        Classic Alt+Tab behavior. Window based instead of app based
81 License:        GPL v2+
82 Group:          X11/Applications
83 Requires:       %{name}-common = %{version}-%{release}
84
85 %description -n %{ext_prefix}-alternate-tab
86 Lets you use classic Alt+Tab (window-based instead of app-based) in
87 GNOME Shell. GNOME Shell groups multiple instances of the same
88 application together. This extension disables grouping.
89
90 %package -n %{ext_prefix}-apps-menu
91 Summary:        Application menu for GNOME Shell
92 License:        GPL v2+
93 Group:          X11/Applications
94 Requires:       %{name}-common = %{version}-%{release}
95
96 %description  -n %{ext_prefix}-apps-menu
97 Add a GNOME 2.x style menu for applications.
98
99 %package -n %{ext_prefix}-auto-move-windows
100 Summary:        Assign specific workspaces to applications
101 License:        GPL v2+
102 Group:          X11/Applications
103 Requires:       %{name}-common = %{version}-%{release}
104
105 %description -n %{ext_prefix}-auto-move-windows
106 Lets you manage your workspaces more easily, assigning a specific
107 workspace to each application as soon as it creates a window, in a
108 manner configurable with a GSettings key.
109
110 %package -n %{ext_prefix}-drive-menu
111 Summary:        Disk device manager in the system status area
112 License:        GPL v2+
113 Group:          X11/Applications
114 Requires:       %{name}-common = %{version}-%{release}
115
116 %description -n %{ext_prefix}-drive-menu
117 Adds a menu in the system status area that tracks removable disk
118 devices attached and offers to browse them and eject/unmount them.
119
120 %package -n %{ext_prefix}-launch-new-instance
121 Summary:        Always launch a new application instance for GNOME Shell
122 License:        GPL v2+
123 Group:          X11/Applications
124 Requires:       %{name}-common = %{version}-%{release}
125
126 %description  -n %{ext_prefix}-launch-new-instance
127 This GNOME Shell extension modifies the behavior of clicking in the
128 dash and app launcher to always launch a new application instance.
129
130 %package -n %{ext_prefix}-native-window-placement
131 Summary:        Arrange windows in overview in a more native way
132 License:        GPL v2+
133 Group:          X11/Applications
134 Requires:       %{name}-common = %{version}-%{release}
135
136 %description -n %{ext_prefix}-native-window-placement
137 This extension employs an algorithm (taken from KDE) for layouting the
138 thumbnails in the overview that more closely reflects the positions
139 and relative sizes of the actual windows, instead of using a fixed
140 grid.
141
142 %package -n %{ext_prefix}-places-menu
143 Summary:        Places menu indicator in the system status area
144 License:        GPL v2+
145 Group:          X11/Applications
146 Requires:       %{name}-common = %{version}-%{release}
147
148 %description -n %{ext_prefix}-places-menu
149 Adds a menu in the system status area that resembles the Places menu
150 from GNOME 2.x
151
152 %package -n %{ext_prefix}-screenshot-window-sizer
153 Summary:        Screenshot window sizer for GNOME Shell
154 License:        GPL v2+
155 Group:          X11/Applications
156 Requires:       %{name}-common = %{version}-%{release}
157
158 %description -n %{ext_prefix}-screenshot-window-sizer
159 This GNOME Shell extension allows to easily resize windows for GNOME
160 Software screenshots.
161
162 %package -n %{ext_prefix}-user-theme
163 Summary:        Lets the user select a custom theme for the shell
164 License:        GPL v2+
165 Group:          X11/Applications
166 Requires:       %{name}-common = %{version}-%{release}
167
168 %description -n %{ext_prefix}-user-theme
169 Lets the user select a custom theme for the Gnome shell. It will allow
170 you to apply a style from
171 /.themes/[themeName]/gnome-shell/gnome-shell.css
172
173 %package -n %{ext_prefix}-window-list
174 Summary:        Display a window list at the bottom of the screen in GNOME Shell
175 License:        GPL v2+
176 Group:          X11/Applications
177 Requires:       %{name}-common = %{version}-%{release}
178
179 %description -n %{ext_prefix}-window-list
180 This GNOME Shell extension displays a window list at the bottom of the
181 screen.
182
183 %package -n %{ext_prefix}-windowsNavigator
184 Summary:        Keyboard selection of windows and work-spaces in overlay mode
185 License:        GPL v2+
186 Group:          X11/Applications
187 Requires:       %{name}-common = %{version}-%{release}
188
189 %description -n %{ext_prefix}-windowsNavigator
190 Allow keyboard selection of windows and work-spaces in overlay mode in
191 GNOME Shell. Switch to overview mode (press the windows or alt+f1 key)
192 and press the alt key to show numbers over windows. Press any number
193 to switch to the corresponding window.
194
195 %package -n %{ext_prefix}-workspace-indicator
196 Summary:        Workspace Indicator
197 License:        GPL v2+
198 Group:          X11/Applications
199 Requires:       %{name}-common = %{version}-%{release}
200
201 %description -n %{ext_prefix}-workspace-indicator
202 Put an indicator on the panel signaling in which workspace you are,
203 and give you the possibility of switching to another one.
204
205 %prep
206 %setup -q
207
208 %build
209 %{__libtoolize}
210 %{__aclocal}
211 %{__autoconf}
212 %{__automake}
213 %configure \
214         --enable-extensions="all"
215
216 %{__make}
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220
221 %{__make} install \
222         DESTDIR=$RPM_BUILD_ROOT
223
224 # Drop useless example extension
225 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions/example*
226 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.example.gschema.xml
227
228 %find_lang %{name}
229
230 %clean
231 rm -rf $RPM_BUILD_ROOT
232
233 %post -n gnome-classic-session
234 %glib_compile_schemas
235
236 %postun -n gnome-classic-session
237 %glib_compile_schemas
238
239 %post -n %{ext_prefix}-auto-move-windows
240 %glib_compile_schemas
241
242 %postun -n %{ext_prefix}-auto-move-windows
243 %glib_compile_schemas
244
245 %post -n %{ext_prefix}-native-window-placement
246 %glib_compile_schemas
247
248 %postun -n %{ext_prefix}-native-window-placement
249 %glib_compile_schemas
250
251 %post -n %{ext_prefix}-screenshot-window-sizer
252 %glib_compile_schemas
253
254 %postun -n %{ext_prefix}-screenshot-window-sizer
255 %glib_compile_schemas
256
257 %post -n %{ext_prefix}-user-theme
258 %glib_compile_schemas
259
260 %postun -n %{ext_prefix}-user-theme
261 %glib_compile_schemas
262
263 %post -n %{ext_prefix}-window-list
264 %glib_compile_schemas
265
266 %postun -n %{ext_prefix}-window-list
267 %glib_compile_schemas
268
269 %files common -f %{name}.lang
270 %defattr(644,root,root,755)
271 %doc COPYING NEWS README
272 %dir %{_datadir}/gnome-shell/extensions
273
274 %files -n gnome-classic-session
275 %defattr(644,root,root,755)
276 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.classic-overrides.gschema.xml
277 %{_datadir}/gnome-session/sessions/gnome-classic.session
278 %dir %{_datadir}/gnome-shell/modes
279 %{_datadir}/gnome-shell/modes/classic.json
280 %dir %{_datadir}/gnome-shell/theme
281 %{_datadir}/gnome-shell/theme/*.svg
282 %{_datadir}/gnome-shell/theme/gnome-classic.css
283 %{_datadir}/gnome-shell/theme/gnome-classic-high-contrast.css
284 %{_datadir}/xsessions/gnome-classic.desktop
285
286 %files -n %{ext_prefix}-alternate-tab
287 %defattr(644,root,root,755)
288 %{_datadir}/gnome-shell/extensions/alternate-tab*
289
290 %files -n %{ext_prefix}-apps-menu
291 %defattr(644,root,root,755)
292 %{_datadir}/gnome-shell/extensions/apps-menu*
293
294 %files -n %{ext_prefix}-auto-move-windows
295 %defattr(644,root,root,755)
296 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.auto-move-windows.gschema.xml
297 %{_datadir}/gnome-shell/extensions/auto-move-windows*
298
299 %files -n %{ext_prefix}-drive-menu
300 %defattr(644,root,root,755)
301 %{_datadir}/gnome-shell/extensions/drive-menu*
302
303 %files -n %{ext_prefix}-launch-new-instance
304 %defattr(644,root,root,755)
305 %{_datadir}/gnome-shell/extensions/launch-new-instance*
306
307 %files -n %{ext_prefix}-native-window-placement
308 %defattr(644,root,root,755)
309 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.native-window-placement.gschema.xml
310 %{_datadir}/gnome-shell/extensions/native-window-placement*
311
312 %files -n %{ext_prefix}-places-menu
313 %defattr(644,root,root,755)
314 %{_datadir}/gnome-shell/extensions/places-menu*
315
316 %files -n %{ext_prefix}-screenshot-window-sizer
317 %defattr(644,root,root,755)
318 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.screenshot-window-sizer.gschema.xml
319 %{_datadir}/gnome-shell/extensions/screenshot-window-sizer*
320
321 %files -n %{ext_prefix}-user-theme
322 %defattr(644,root,root,755)
323 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.user-theme.gschema.xml
324 %{_datadir}/gnome-shell/extensions/user-theme*
325
326 %files -n %{ext_prefix}-window-list
327 %defattr(644,root,root,755)
328 %{_datadir}/gnome-shell/extensions/window-list*
329 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.window-list.gschema.xml
330
331 %files -n %{ext_prefix}-windowsNavigator
332 %defattr(644,root,root,755)
333 %{_datadir}/gnome-shell/extensions/windowsNavigator*
334
335 %files -n %{ext_prefix}-workspace-indicator
336 %defattr(644,root,root,755)
337 %{_datadir}/gnome-shell/extensions/workspace-indicator*
This page took 0.089719 seconds and 2 git commands to generate.