]> git.pld-linux.org Git - packages/gnome-packagekit.git/blob - gnome-packagekit.spec
- updated to 3.4.2
[packages/gnome-packagekit.git] / gnome-packagekit.spec
1 #
2 # Conditional build:
3 %bcond_with systemd # rely on systemd for session tracking instead of ConsoleKit
4 #
5 Summary:        GNOME PackageKit Client
6 Summary(pl.UTF-8):      Klient PackageKit dla GNOME
7 Name:           gnome-packagekit
8 Version:        3.4.2
9 Release:        1
10 License:        GPL v2+
11 Group:          X11/Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-packagekit/3.4/%{name}-%{version}.tar.xz
13 # Source0-md5:  17530fef9e92c15e2f0624fbe7511ce0
14 URL:            http://www.packagekit.org/
15 BuildRequires:  PackageKit-devel >= 0.6.8
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1.11
18 BuildRequires:  dbus-devel >= 1.2.0
19 BuildRequires:  dbus-glib-devel >= 0.74
20 BuildRequires:  docbook-dtd41-sgml
21 BuildRequires:  docbook-utils
22 BuildRequires:  fontconfig-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 1:2.26.0
25 BuildRequires:  gnome-common
26 BuildRequires:  gnome-doc-utils
27 BuildRequires:  gtk+3-devel >= 3.0.0
28 BuildRequires:  gtk-doc >= 1.9
29 BuildRequires:  intltool >= 0.35.0
30 BuildRequires:  libcanberra-devel >= 0.10
31 BuildRequires:  libcanberra-gtk3-devel >= 0.10
32 BuildRequires:  libnotify-devel >= 0.7.0
33 BuildRequires:  libtool
34 BuildRequires:  libxslt-progs
35 BuildRequires:  pkgconfig
36 BuildRequires:  python
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(find_lang) >= 1.23
39 BuildRequires:  rpmbuild(macros) >= 1.311
40 %{?with_systemd:BuildRequires:  systemd-devel}
41 BuildRequires:  udev-glib-devel
42 BuildRequires:  upower-devel >= 0.9.0
43 BuildRequires:  xorg-lib-libX11-devel
44 Requires(post,postun):  desktop-file-utils
45 Requires(post,postun):  gtk-update-icon-cache
46 Requires(post,postun):  hicolor-icon-theme
47 Requires(post,preun):   glib2 >= 1:2.26.0
48 Requires:       PackageKit >= 0.6.8
49 Requires:       polkit-gnome >= 0.92
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 This package provides session applications for the PackageKit API.
54 There are several utilities designed for installing, updating and
55 removing packages.
56
57 %description -l pl.UTF-8
58 Ten pakiet dostarcza aplikacje sesji dla API PackageKit. Zawiera kilka
59 narzędzi stworzonych do instalacji, aktualizacji i usuwania pakietów.
60
61 %package -n python-gnome-packagekit
62 Summary:        Widgets to use PackageKit in GTK+ applications
63 Summary(pl.UTF-8):      Widgety do użycia PackageKit w aplikacjach GTK+
64 Group:          Libraries/Python
65 Requires:       gnome-packagekit = %{version}-%{release}
66 Requires:       python-packagekit
67 Requires:       python-pygtk-gtk
68
69 %description -n python-gnome-packagekit
70 This module provides widgets to use PackageKit in GTK+ applications.
71
72 %description -n python-gnome-packagekit -l pl.UTF-8
73 Ten moduł dostarcza widgety do użycia PackageKit w aplikacjach GTK+.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --disable-silent-rules \
86         --disable-scrollkeeper \
87         %{__enable_disable systemd systemd} \
88         --disable-schemas-compile
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %py_postclean
99
100 %find_lang %{name} --with-gnome --with-omf
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 %update_icon_cache hicolor
107 %update_desktop_database
108 %glib_compile_schemas
109
110 %postun
111 %update_icon_cache hicolor
112 %update_desktop_database_postun
113 %glib_compile_schemas
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog COPYING NEWS README
118 %attr(755,root,root) %{_bindir}/gpk-application
119 %attr(755,root,root) %{_bindir}/gpk-dbus-service
120 %attr(755,root,root) %{_bindir}/gpk-distro-upgrade
121 %attr(755,root,root) %{_bindir}/gpk-install-catalog
122 %attr(755,root,root) %{_bindir}/gpk-install-local-file
123 %attr(755,root,root) %{_bindir}/gpk-install-mime-type
124 %attr(755,root,root) %{_bindir}/gpk-install-package-name
125 %attr(755,root,root) %{_bindir}/gpk-install-provide-file
126 %attr(755,root,root) %{_bindir}/gpk-log
127 %attr(755,root,root) %{_bindir}/gpk-prefs
128 %attr(755,root,root) %{_bindir}/gpk-service-pack
129 %attr(755,root,root) %{_bindir}/gpk-update-viewer
130 %{_datadir}/GConf/gsettings/org.gnome.packagekit.gschema.migrate
131 %{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
132 %{_datadir}/glib-2.0/schemas/org.gnome.packagekit.gschema.xml
133 %{_datadir}/gnome-packagekit
134 %{_iconsdir}/hicolor/*/*/*
135 %{_desktopdir}/gpk-application.desktop
136 %{_desktopdir}/gpk-dbus-service.desktop
137 %{_desktopdir}/gpk-distro-upgrade.desktop
138 %{_desktopdir}/gpk-install-catalog.desktop
139 %{_desktopdir}/gpk-install-local-file.desktop
140 %{_desktopdir}/gpk-log.desktop
141 %{_desktopdir}/gpk-prefs.desktop
142 %{_desktopdir}/gpk-service-pack.desktop
143 %{_desktopdir}/gpk-update-viewer.desktop
144 %{_mandir}/man1/gpk-application.1*
145 %{_mandir}/man1/gpk-backend-status.1*
146 %{_mandir}/man1/gpk-install-local-file.1*
147 %{_mandir}/man1/gpk-install-mime-type.1*
148 %{_mandir}/man1/gpk-install-package-name.1*
149 %{_mandir}/man1/gpk-install-provide-file.1*
150 %{_mandir}/man1/gpk-prefs.1*
151 %{_mandir}/man1/gpk-repo.1*
152 %{_mandir}/man1/gpk-update-icon.1*
153 %{_mandir}/man1/gpk-update-viewer.1*
154
155 %files -n python-gnome-packagekit
156 %defattr(644,root,root,755)
157 %{py_sitescriptdir}/packagekit/*.py[co]
This page took 0.068334 seconds and 3 git commands to generate.